Frage Externes Mikrofon funktioniert nicht


gnome-volume-control erkennt keine externe Hardware. Meine Kopfhörer funktionieren trotzdem, ein externes Mikrofon nicht. Externe Mikrofone arbeiteten früher, waren aber manchmal temperamentvoll - ich musste mich mit oder ohne Mikrofon ein - oder ausloggen.

Ich betreibe Ubuntu 10.04 LTS (Lucid Lynx) auf einem mSi U100 Wind Notebook mit einer Intel Soundkarte und versuche, ein Jack Mikrofon zu verwenden, das vorher funktioniert hat. USB-Mikrofone waren ebenfalls problematisch.

Ich habe die Grundlagen gemacht:

  • Installierte Upgrades
  • Überprüft ist nichts gedämpft.
  • Habe das Gerät auf gnome-volume-control gesucht.
  • Versucht, ein anderes Mikrofon zu verwenden, das auf einem Computer mit Freunden funktioniert.
  • Getestet funktioniert mein Mikrofon bei Verwendung eines anderen Computers.
  • Überprüft meine Soundkarte kann gesehen werden (cat /proc/asound/cards).

Ich habe kompliziertere Dinge getan:

  • Ich habe versucht, mit Einstellungen in alsamixer herumzuspielen. Nichts ist gedämpft. Ich kann "mic" und "internal mic" unabhängig davon einstellen, ob ein externes Mikrofon ist eingesteckt. Ich habe die Wahl zwischen Eingang Quelle von "mic", "front mic", "line" und "CD". Ich habe herumgespielt dies zu ändern und es hat nicht geholfen. Ich habe nur eine CAPTURE-Option.

    • Im Gnome-Sound-Recorder habe ich die Wahl zwischen Leitung, Mikrofon 1 und Mikrofon 2. Ich habe diese Option geändert. Keiner von Diese nehmen den Ton vom externen Mikrofon auf. Mikrofon 2 ist das Mikrofon auf meinem Laptop, die schlechte Qualität hat.

    • Im Gnome-Sound-Recorder habe ich die Wahl zwischen verschiedenen Profilen, und auch das hat sich nicht geändert.

    • Ich habe es angeschaut gstreamer-properties aber nichts davon schien hilfreich zu sein.

Ich weiß nicht, ob es eine Möglichkeit gibt zu überprüfen, ob diese externen Geräte abgeholt werden. Ich möchte ein externes Mikrofon arbeiten lassen. Bitte helfen Sie!


1
2017-11-05 17:01


Ursprung




Antworten:


Mein Computer, Compaq CQ45-118A, Intel Soundkarte.

Seit ubuntu 10.04 bis 11.04 habe ich hinzugefügt /etc/modprobe.d/alsa-base.conf die folgenden Zeilen und funktionierte für mich:

options snd-pcsp index=-2

alias snd-card-0 snd-hda-intel

alias sound-slot-0 snd-hda-intel

options snd-hda-intel model=dell-m4-1

options snd-hda-intel enable_msi=1

options snd-hda-intel position_fix=1 enable=yes

3
2017-11-08 04:47



Du hast mich gerade sehr glücklich gemacht !! - Koffeehaus


Ich habe eine Lösung gefunden und hochgeladen ein Screencast zu YouTube.

  1. Installieren alsa-tools-gui Paket.
  2. Lauf hdajackretask.
  3. Oben ist der analoge Realtek-Codec bereits ausgewählt. In meinem Fall war es das Realtek ALC270.
  4. Achten Sie auf das linke Feld (Pin-Konfiguration). In meinem Fall zeigte es nur 3 verbundene Pins: Internes Mikrofon, Interner Lautsprecher, Kopfhörer. Beachten Sie, dass ein Stift für das externe Mikrofon fehlt.
  5. Prüfen:  Unverbundene Pins anzeigen.
  6. Mehrere neue Pins werden auf der linken Seite angezeigt. Für jeden, der ist Nicht verbunden:
    • Prüfen  Überschreiben.
    • Suche nach einem Mikrofon Option in der Dropdown-Box.
    • Wenn dort nein Mikrofon In diesem Feld, deaktivieren Sie dann ☐ Überschreiben und versuche den nächsten Pin.
    • Wenn da ein ... ist Mikrofon wählen Sie sie aus und gehen Sie zu Schritt 7.
  7. Sie sollten jetzt einen Pin haben, der zuvor nicht verbunden war, aber jetzt als Mikrofon überschrieben wird. Klicke auf Jetzt bewerben und gib dein Passwort ein.
  8. Wenn Sie eine Fehlermeldung über erhalten Gerät oder Ressource beschäftigtSchließen Sie alle Anwendungen, die die Soundkarte verwenden (z. B. Schließen alsamixer).
  9. Wenn Sie eine Erfolgsmeldung erhalten: Ok, jetzt mach weiter und teste, ob es tatsächlich funktioniert hat!Mach, was es sagt und teste es!
  10. Wenn es funktioniert, klicken Sie auf Installieren Sie die Boot-Überschreibung und gib dein Passwort erneut ein. Wenn es nicht funktioniert, deaktivieren Sie das Kontrollkästchen ☐ Überschreiben und gehe zurück zu Schritt 6.

In meinem Fall, überschreiben Pin 0x18 zu Mikrofon behebt das Problem für mich.


3
2018-05-24 05:22



Ich habe es versucht, aber es hat nicht für mich funktioniert :( - Lokesh
Arbeitete für mich am 18.04, danke! - Santiago


Die einzige Lösung, um das Mikrofon funktionieren zu lassen, ist die Installation linux-backports-modules-alsa-generic.

Gehe einfach zu:

Menü> System> Verwaltung> Synaptic Package Manager

Und suche und markiere für die Installation:

linux-backports-modules-alsa-generic

Tipp: Wenn Sie mehrere Versionen haben, klicken Sie auf den ersten und lesen Sie die Beschreibung, die den zu installierenden Namen enthalten sollte.

Wenn nach dem Neustart und der Stummschaltung des Mikrofons immer noch nicht funktioniert, gehen Sie einfach zum Terminal und tippen Sie:

sudo nano /etc/modprobe.d/alsa-base.conf

und hinzufügen oder ändern Sie Folgendes:

options snd-hda-intel model=auto enable=yes

Dann Strg+X, Art Y zu schreiben und zu beenden, reboot und mic wird funktionieren.


0
2018-03-26 23:23