Frage Einrichten von Wordpress auf Ubuntu, Verzeichnisberechtigungen


Ich habe meine WordPress Repo in geklont /home/me/alliance
Ich habe bearbeitet /etc/apache2/sites-enabled/000-default.conf

Enthalten

    ServerAdmin webmaster@localhost
    #DocumentRoot /var/www/html
    DocumentRoot /home/me/alliance

Ich habe mich selbst hinzugefügt www-data

Ich habe das Verzeichnis geklaut.

chown -R me:www-data alliance

Ich habe die Berechtigungen überprüft. ls -al alliance

drwxrwxr-x 8 me www-data 4096 Apr 1 13:26 alliance

Ich verstehe immer noch Forbidden

Forbidden    
You don't have permission to access / on this server.    
Apache/2.4.7 (Ubuntu) Server at ...northeurope.cloudapp.azure.com Port 80

Ich weiß, dass Apache korrekt funktioniert, da ich es geschafft habe, die Homepage zu öffnen, bevor ich anfing, die Site einzurichten.


1
2018-04-01 13:51


Ursprung




Antworten:


<Directory /home/me/alliance>
        Options Indexes FollowSymLinks
        AllowOverride None
        Require all granted
</Directory>

muss zu apache2.conf hinzugefügt werden


3
2018-04-01 15:41



Spezifisch 'Erfordern alle gewährt' ist die neue Konfiguration für Apache 2.4, wo als 2.2 order / allow Anweisungen verwendet wurden. - bc2946088


Der Besitzer des Ordners sollte www-data sein - nicht Sie.

chown -R www-data:www-data alliance


0
2018-04-01 15:23



das scheint nicht zu helfen, dasselbe Problem. - Jim