Frage kann keine Audio-Software kompilieren


Ich habe versucht, eine Audio-Software (SO-KL5 Synth) zu installieren. Meine Distribution ist Ubuntu 14.04 LTS. Wenn ich versuche, die Software zu kompilieren, sagt es, dass es jack und ALSA Header-Dateien nicht finden kann.

Wo sind diese Dateien?

Bearbeiten 1:

Ich kann nicht installieren libjack-devMein Terminal sagt:

Unable to install some packages . This may be because you
requested an impossible situation or if you are using the distribution
"Unstable" and some required packages have not yet been created or
There have not yet entered from " Incoming ".
The following information may help to resolve the situation :

The following packages have unmet dependencies :
 libjack -dev : Depends : libjack0 ( = 1: 0.121.3 + 20120418git75e3e20b - 2.1ubuntu1 ) but will not be installed
E: Unable to correct problems , you have held packages are broken .

Bearbeiten 2:

Ich konnte diesen Fehler schließlich beheben, indem ich libjack0 neu installiere, anscheinend hatte es einen Fehler.


1
2017-11-09 17:58


Ursprung




Antworten:


Die Jack- und ALSA-Header-Dateien sollten von Paketen bereitgestellt werden libjack-dev und libasound2-dev beziehungsweise.


3
2017-11-09 18:08