Frage Intel Centrino Wireless-N 2230 stellt keine Verbindung her und fragt nach dem Passwort [duplizieren]


Diese Frage hat hier bereits eine Antwort:

Ich bin am Kubuntu 16.04, alle Pakete aktuell.

Gestern, aus heiterem Himmel (nicht nach einem Neustart oder irgendetwas), mein WiFi funktioniert nicht mehr. Die Hardware funktioniert noch, ich kann eine Verbindung über Ethernet herstellen, und alle lokalen WiFi-Netzwerke sind im NetworkManager-Widget aufgelistet. Aber wenn ich versuche, eine Verbindung zu meinem WiFi-Netzwerk herzustellen, heißt es "Schnittstelle konfigurieren ...", fragt nach einem Passwort, bleibt einen Moment stehen, fragt erneut und so weiter, immer wieder und nie wieder verbunden.

Ich habe bereits viele Male neu gestartet, alle Updates installiert und versucht, die Verbindung zu löschen und hinzuzufügen, die Verbindung als "Für alle Benutzer verfügbar" zu markieren und zu deaktivieren kwallet.

BEARBEITEN: Hier ist die Ausgabe von lspci -knn | grep Net -A3:

02:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 2230 [8086:0887] (rev c4)
    Subsystem: Intel Corporation Centrino Wireless-N 2230 BGN [8086:4062]
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi

Die Lösung von diese Frage, vorgeschlagen von user68186, funktioniert für mich (ich bin in der Lage, WiFi zu verbinden, danke!).

Hier ist meine aktualisierte Frage: Gibt es eine Möglichkeit für mich, WiFi ohne die 802.11n-Geschwindigkeit zu deaktivieren?


1
2018-02-09 18:11


Ursprung


@ user68186: Danke, das habe ich bei meinen Suchen verpasst. Ich werde testen, wenn es funktioniert, können wir als Duplikat schließen. - Linuxios
Bitte bearbeiten deine Frage und addiere Ausgabe von lspci -knn | grep Net -A3 Terminalbefehl. - Pilot6
@ Pilot6: Wird tun, sobald der Computer neu gestartet wird. - Linuxios
Stellen Sie sicher, dass Sie WPA2-AES im Router verwenden. Starten Sie Ihren WLAN-Router neu. Löschen / fügen Sie das drahtlose Profil bei Bedarf erneut hinzu. - heynnema
@heynnema: Der Router benutzt WPA2-AES, jedes andere Gerät im Haus funktioniert noch. - Linuxios


Antworten:


Sie müssen eine Kernelmodul-Option festlegen. Lauf in einem Terminal

sudo tee /etc/modprobe.d/iwlwifi-opt.conf <<< "options iwlwifi 11n_disable=8"

und neu starten.

Das setzt die enable agg TX Option für die iwlwifi Modul. Dies ist erforderlich, damit dieser Adapter gut im 802.11n-Modus funktioniert.


2
2018-02-09 18:41



Wenn dies ähnliche Probleme sind, können wir diese zu einer Frage zusammenfassen, möglicherweise mit mehreren Antworten für verschiedene WiFi-Chips? Vielen Dank - user68186
Welche Art von verschiedenen Chips meinst du? Diese Lösung ist spezifisch für einige Intel-Adapter. - Pilot6
Entschuldigung, ich habe den anderen nicht gelesen Frage vorsichtig genug und nahm an, dass sie verschiedene Chips waren. Warum 11n_disable=8 in einem und 11n_disable=1 in dem anderen? - user68186
11n_disable=1 deaktiviert die n Modus. Es ist garantiert, das Problem zu beheben. 8 Deaktiviert nichts außer aktiviert agg TX was auch immer das bedeutet. Es kann es auch beheben. - Pilot6
Ich habs. Vielen Dank! - user68186