Frage Wie man Vollbild in Ubuntu 12.04 in Vmware Player 4.0 + gehen


Ich hatte kürzlich VMware 4.0+ auf meinem Windows 7 Home Premium-Computer installiert. Ich habe Ubuntu 12.04 LTS darauf installiert. Wenn ich jedoch meine VM einschalte, läuft Ubuntu nicht im Vollbildmodus. Darüber hinaus ist die Leistung von VMware ein wenig abgehackt und nicht so reibungslos.

Ich habe ein Full-HD-Display mit 1920x1080 in meinem Windows 7-System. Ich möchte Ubuntu mit derselben Auflösung ausführen können.


11
2017-07-06 16:15


Ursprung




Antworten:


Wenn der automatische Modus fehlschlägt, könnte man versuchen mit xrandr in einer Konsole, um zu sehen, welche Auflösungen Ubuntu unterstützt. Es wird dir so etwas geben:

$ xrandr
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
VGA1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 410mm x 230mm
   1366x768       59.8*+
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  

Und dann:

$xrandr -s  1366x768

11
2018-01-15 13:39



Das manuelle Hinzufügen einer Bildschirmauflösung in einer VM, die auf VMWare Player ausgeführt wird, führt dazu, dass die Gast-CPU zu 100% hochgefahren wird und schließlich nach etwa 10-15 Sekunden abstürzt. - Daniel


  1. Aktivieren Sie die 3D-Beschleunigung in VMware.
  2. Stellen Sie die Display-Option auf "AuTomatic" / "Host-Bildschirm"
  3. Installiere VMware Tools in Ubuntu, um eine dynamische Bildschirmgrößenanpassung zu ermöglichen.
  4. Benutzen Strg+Alt+Eingeben um den Vollbildmodus zu aktivieren / deaktivieren.

8
2017-07-06 16:24



Manchmal reicht es aus, nur VMware Tools zu installieren. - Eliah Kagan
Diese Einstellung existiert nicht für mich (VMware Workstation 12 Player, 12.1.1), stattdessen habe ich die Einstellungen der virtuellen Maschine -> Optionen -> Energie -> "Vollbildmodus nach dem Einschalten aktivieren" aktiviert. - jtpereyda


Dies scheint ein Fehler zu sein, der entweder mit VMWare oder dem xorg-Modul in Ubuntu zusammenhängt. Weitere Informationen können gefunden werden Hier. In meinem Fall entstand dieses Problem, weil ich auf einem Monitor bei der Arbeit, die 16:10 ist, anstelle von 16: 9 auf meinem Laptop-Bildschirm andocken. Ich konnte eine Workaround (erwähnt von Karan in obigem Link) verwenden, wobei ich den Vollbildmodus mit verließ    Strg-Alt-Enter und dann wieder in den Vollbildmodus, indem ich diese erneut drücke und meine 1920x1080-Auflösung wiederherstellte. Hoffentlich funktioniert diese Problemumgehung weiter.


1
2018-04-17 00:24





Aktualisiere Ubuntu auf die neueste Version 13.10 32 bit (da es weniger ressourcenhungrig ist) und aktualisiere deinen vmware player auf die neueste Version, da es kostenlos ist:

https://my.vmware.com/web/vmware/free#desktop_end_user_computing/vmware_player/6_0

Aktivieren Sie dann die 3D-Beschleunigung und installieren Sie VMware Tools:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1022525


1
2018-01-15 14:41





Für meine Version von VMWare Player, 12.1.1 build-3770994, gibt es keine Anzeigeoption für "Automatisch" / "Host-Bildschirm".

Stattdessen ich:

  1. Installierte VMWare-Tools. Ich war auf Ubuntu 16.04 und open-vm-tools-desktop hat am besten für mich funktioniert. Siehe diese Frage.
  2. Checked die Einstellungen der virtuellen Maschine -> Optionen -> Power -> "Vollbildmodus nach dem Einschalten aktivieren" Kontrollkästchen.

0
2017-07-14 17:53