Frage Die neueste Charm-Version kann nicht abgerufen werden, wenn Sie einen lokalen Charm bereitstellen möchten


Beim Versuch, einen lokalen Charm bereitzustellen, erhalte ich den folgenden Fehler:

error: cannot get latest charm revision: no charms found matching "local:precise/devenv"

1
2018-05-24 13:15


Ursprung




Antworten:


Überprüfen Sie, ob Ihre metadata.yaml-Datei korrekt ist. Überprüfen Sie zuerst, ob es gültig ist und überprüfen Sie dann, ob es dem gleichen Format wie die vorhandenen Charms im Charmstore entspricht


1
2018-05-24 13:15



Tut charm proof Arbeit für die Überprüfung von Metadaten Yaml? - Marco Ceppi♦


Ich hatte heute das gleiche Problem. Problem war, dass ich versehentlich Leerzeichen in meine config.yaml-Datei kopiert / eingefügt habe. Stellen Sie sicher, dass Ihre config.yaml einheitlich ist und von Anfang bis Ende dieselbe Struktur aufweist.


0
2017-08-29 14:40