Frage VLC Media Player wird nicht installiert


Nach dem Tippen sudo apt install vlc im Terminal ist das, was ich bekomme:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 vlc : Depends: libgles1-mesa (>= 7.8.1) but it is not going to be installed or
                libgles1
       Depends: libgles2-mesa (>= 7.8.1) but it is not going to be installed or
                libgles2
E: Unable to correct problems, you have held broken packages.

1
2018-02-18 12:38


Ursprung


Könnten Sie bitte bearbeiten Ihre Frage sollte die Ausgabe von einschließen lsb_release -a, apt-cache policy vlc libgles1\*, und dpkg-query -Wf '${Package}\t${Version}\t${Status}\t${Provides}\n' | awk -F '\t' 'index($4, "libgles1")'? Vielen Dank. - David Foerster


Antworten:


sudo apt update
sudo dpkg --configure -a
sudo apt install -f
sudo apt install vlc

Aber wenn Sie die neueste Version von VLC (derzeit VLC 3.0) möchten, installieren Sie von Snap.

sudo snap install vlc

0
2018-02-18 13:39





Geh einfach und installiere es von Ubuntu Softwarecenter

Nach dem Versuch

sudo apt-get update –fix-missing

und

sudo dpkg –configure -a

und

sudo apt-get install -f

Das Problem eines defekten Pakets besteht weiterhin. Die Lösung besteht darin, die dpkg-Statusdatei manuell zu bearbeiten.

$ sudo nano /var/lib/dpkg/status    

(Sie können vim oder gedit anstelle von Nano verwenden) Suchen Sie das beschädigte Paket, entfernen Sie den gesamten Informationsblock und speichern Sie die Datei.

Informationen aus iasptk.com


0
2018-02-18 13:03