Frage Chrome fragt nach dem Kennwort zum Entsperren des Schlüsselbundes beim Start


Wenn ich in Google Chrome auf eine Anmeldeseite gehe, wird ein Fenster angezeigt, in dem Sie gefragt werden, ob Sie "Kennwort für Schlüsselbund eingeben" zum Entsperren "eingeben möchten. In den meisten Fällen, egal, ob ich auf Abbrechen klicke oder mein Passwort eingib, wird das Login-Formular trotzdem automatisch ausgefüllt.

Wie werde ich das Popup loswerden? Ich möchte, dass es sich jedes Mal automatisch anmeldet und nicht nach meinem Systempasswort fragt. Das Dialogfeld wird nie für andere Apps angezeigt.


72
2018-03-23 23:08


Ursprung


Sie können Chrome mit der Befehlszeile starten google-chrome --password-store=basic damit es nicht nach dem Gnome-Schlüsselring fragt. Sehen: code.google.com/p/chromium/wiki/LinuxPasswordStorage   Da es einen Chrome-spezifischen Workaround gibt, sollte diese Frage kein Duplikat sein. - Stephen Ostermiller
rm ~/.local/share/keyrings/* Öffnen Sie nun Chrome, wenn Sie nach Ihrem Passwort gefragt werden, geben Sie keines ein, wählen Sie jedes Mal Fortfahren und ignorieren Sie alle Warnungen. - xinthose
Stimmen Sie mit @ StephenOstermiller überein, eine ausführliche Antwort ist ubuntuforums.org/ ... - new2cpp


Antworten:


Wie beschrieben Hier Sie können das Schlüsselringkennwort auf leer setzen.

Gehen Sie zu System / Einstellungen / Passwort und Verschlüsselungsschlüssel, klicken Sie mit der rechten Maustaste auf den entsprechenden Ordner und klicken Sie auf Passwort ändern. Geben Sie Ihr altes Passwort ein und lassen Sie das neue leer.


21
2018-03-24 01:53



Die Auswahl einer systemweiten Einstellung, um weniger sicher zu sein, scheint eine schlechte Idee zu sein. Es gibt bessere Möglichkeiten auf dieser Seite: siehe libpam-gnome-keyring antwort - Jeff Ward
Sie müssen sich nicht mit den Brieftaschen und Schlüsselringen herumschlagen, sondern nur den Passwortspeicher in Chrom deaktivieren. Sehen meine Antwort unten. - Capi Etheriel
Ich finde, wenn ich das mache, wird es regelmäßig zurückgesetzt, und ich muss mein Passwort erneut eingeben. Es scheint mit Systemaktualisierungen zu korrelieren, aber ich bin mir nicht sicher. Sieht das jemand anderes? - Jack O'Connor


Stellen Sie zuerst sicher libpam-gnome-keyring ist installiert, dann abmelden und wieder rein.

Wenn Sie Chrome erneut öffnen, wird nach dem gefragt Passwort für den Schlüsselring aber wird dir eine Option geben entsperren Sie den Schlüsselring jedes Mal, wenn Sie sich einloggen. Stellen Sie sicher, dass dies ausgewählt ist und geben Sie Ihr Passwort ein, um den Schlüsselring zu entsperren.


35
2017-09-21 19:49



Dies ist eine bessere Lösung als die angenommene Antwort. Man sollte kein leeres Passwort eingeben müssen, um Unannehmlichkeiten zu vermeiden. - Kevin
Diese Option ist bei Mint 16 nicht verfügbar - tomrozb
Zu Ihrer Information, diese Option funktionierte nicht für Chromium 37.0.2062.120 (mit Debian 7 (Wheezy)). In diesem Fall jedoch die Problemumgehung, die in der ausgewählten Antwort angezeigt wird Hier  (vorbei an der --password-store=basic Option, so dass Chrome seinen eigenen Passwortspeicher verwendet, anstatt den GNOME-Schlüsselring zu verwenden), funktioniert immer noch gut! - Digger
Nicht verfügbar in Mint 17, auch wenn das angegebene Paket installiert ist. - Highly Irregular
Dies funktionierte nicht in Xubuntu 17. Keine Entsperrung der angebotenen Schlüsselringoption. der gleiche alte Dialog. - Norman Bird


Von der Manpage:

--password-store = <basic | gnome | kwallet>
  Legen Sie den zu verwendenden Passwortspeicher fest. Die Standardeinstellung ist die automatische Erkennung basierend auf der Desktop-Umgebung. basic wählt den eingebauten, unverschlüsselten Passwortspeicher aus. gnome wählt Gnome Schlüsselring. kwallet wählt (KDE) KWallet aus. (Beachten Sie, dass KWallet möglicherweise außerhalb von KDE nicht zuverlässig funktioniert.)

Der einfachste Weg, dies im Launcher zu beheben, ist das Kopieren des .desktop Datei in Ihren Home-Ordner und bearbeiten Sie es (Google Chrome-Benutzer sollten die entsprechende Datei kopieren):

cp /usr/share/applications/chromium-browser.desktop ~/.local/share/applications

Bearbeiten Sie dann die neue Datei so, dass die Exec Zeile liest sich so:

Exec=chromium --password-store=basic %U

Wenn Sie eine andere Chromium-App installiert haben, .desktop Dateien sollten auch drin sein ~/.local/share/applications, editiere sie entsprechend.


27
2017-10-23 16:48



Vielen Dank! Außer, die Datei, die ich bearbeiten musste, war google-chrome.desktop eher, als chromium-browser.desktop. - njlarsson
Muss die eleganteste Lösung auf der Seite sein - funktioniert für mich in 18.04 (Pre-Release). - Dɑvïd
Es funktioniert, aber Sie müssen dies jedes Mal Chrome Updates tun. - Pietro Coelho
Upvoted. Ausgezeichnete Antwort! - L. Levrel


Sie können diese lästige Nachricht durch entfernen

  1. Gehe zu (Unity-Taste) / Passwörter und Schlüssel
  2. Auf der Registerkarte Passwörter wählen Sie den richtigen Schlüssel (ich hatte nur einen, so dass Sie möglicherweise den richtigen Schlüssel finden müssen). Klicken Sie mit der rechten Maustaste darauf und Löschen.
  3. Starten Sie Chromium neu
  4. Es wird nach einem Passwort gefragt - tippen Sie keine und fahren Sie fort.
  5. Wählen Sie "Verwende unsicheren Speicher"

Bereit für jetzt!

Bezüglich Popups fragt Chromium nach einem Passwort, um Ihre Passwörter für Webseiten zu verschlüsseln. Ohne Passwort (wie gesagt) hat jemand Zugriff auf Ihre Passwörter mit Lesezugriff auf einige Dateien.


8
2018-01-29 13:47





Zunächst einmal bin ich weder Ubuntu noch Sicherheitsexperte. Ich bin nur ein durchschnittlicher Benutzer / Programmierer, der Chrome auf meiner Ubuntu 16.04 VM unter Parallels installieren wollte.

Ich habe Chrome installiert und wurde mit diesem lästigen Schlüsselring-Passwort-Popup aufgefordert und versuchte, das Passwort meines Benutzers vergeblich einzugeben.

Die Lösung, die ich aus Versehen arbeiten musste, war:

  1. Gehe zu Passwörter und Schlüssel
  2. Unter "Passwörter" löschen Sie einfach den Login Keyring darunter
  3. Ubuntu fordert Sie nun auf, das neue Passwort zu erstellen
  4. Jetzt, wenn Sie Chrome starten, stört Sie das Popup-Fenster nicht mehr! (Naja, zumindest für meine, hat es nicht.)

3
2017-09-09 13:17





Wenn Sie Ihr Schlüsselkennwort auf Ihr Anmeldekennwort zurücksetzen, sollte das Problem behoben sein. Wenn Sie das Passwort vollständig entfernen, ist Ihr Schlüsselbund ohne Passwort zugänglich (also von jedem, der Lesezugriff hat).


2
2017-09-01 16:17



Das ist vielleicht die beste Antwort für mich. Es speichert sicher alle Ihre Passwörter, im Vergleich zu allen anderen Antworten! Als Ergänzung würde ich auch hinzufügen, die Option zu deaktivieren, die es jedem ermöglicht, sich mit dem Netzwerk zur Sicherheit zu verbinden superuser.com/a/115737 - Aleks


Ubuntu 12.10

  1. Gehe zu Schlüsselring und Passwort
  2. dann Ansicht> Nach Schlüsselring
  3. Das Fenster wird sich ändern und einen linken Bereich anzeigen. Wählen Sie nun im linken Bereich Login unter Passwörter. Klicke mit der rechten Maustaste und wähle "Passwort ändern"
  4. Geben Sie das alte Passwort ein und lassen Sie das neue Passwort einfach leer.

Hoffe das hilft


2
2018-03-09 06:41