Frage Ubuntu sitzt hinter einem Corporate Proxy / Firewall - wie kann ich Pakete installieren?


Ich habe eine saubere Installation von Ubuntu 16.04 LTS, aber weil meine Maschine hinter einer Unternehmensfirewall / einem Proxy läuft, kann ich nicht herausfinden, wie man die Hindernisse überwindet. Ich weiß, dass wir einen Unternehmens-Proxy haben, und ich habe den Server / Port / Benutzername / Passwort, um es zu verwenden, aber ich weiß nicht, ob das mein Problem anfänglich lösen wird. Ich werde wahrscheinlich immer noch die Paketquelle zu unserer weißen IP-Adressliste hinzufügen müssen.

Um zu beginnen, hier ist jedoch die Fehlermeldung, die Sie bekommen, wenn Sie versuchen, irgendwelche Pakete zu installieren.

sudo apt install software-center
[sudo] password for alilland:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package software-center is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'software-center' has no installation candidates

Wo fange ich an, meinen Knoten zu lösen, den meine Firma gemacht hat?

<----- Bearbeiten 1 ----->

Wenn ich sudo apt-get update Ich bekomme folgende Fehler ...

alilland@TI-AronLilland:~$ sudo apt-get update
[sudo] password for alilland: 
. . . .
Reading package lists... Done
W: The repository 'http://security.ubuntu.com/ubuntu xenial-security Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: The repository 'http://us.archive.ubuntu.com/ubuntu xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: The repository 'http://us.archive.ubuntu.com/ubuntu xenial-updates Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: The repository 'http://us.archive.ubuntu.com/ubuntu xenial-backports Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://security.ubuntu.com/ubuntu/dists/xenial-security/main/binary-i386/Packages  407  Authorization Required
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/xenial/main/binary-amd64/Packages  407  Authorization Required
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/xenial-updates/main/binary-amd64/Packages  407  Authorization Required
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/xenial-backports/main/binary-amd64/Packages  407  Authorization Required
E: Some index files failed to download. They have been ignored, or old ones used instead.

<----- Bearbeiten 2 ----->

nach dem Hinzufügen meines Proxy htttp://[username]:[password]@[ip address]:[port] Ich bekomme jetzt andere Fehler messages, anstatt zu bekommen 407 Authorization Required Ich sehe jetzt 403 Forbidden

. . . . 
E: Failed to fetch http://security.ubuntu.com/ubuntu/dists/xenial-security/main/binary-i386/Packages  403  Forbidden
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/xenial/main/binary-amd64/Packages  403  Forbidden
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/xenial-updates/main/binary-amd64/Packages  403  Forbidden
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/xenial-backports/main/binary-amd64/Packages  403  Forbidden
E: Some index files failed to download. They have been ignored, or old ones used instead.

1
2018-03-30 17:42


Ursprung




Antworten:


Für die temporäre Proxy-Einstellung .. ich meine nur für die aktuelle Sitzung ausgeführt unter Befehl:

export http_proxy=http://yourproxyaddress:proxyport

Um diese Proxy-Einstellung hinzuzufügen, bearbeiten Sie die apt.conf-Datei

gksudo gedit /etc/apt/apt.conf

Und füge folgende Zeile hinzu:

Acquire::http::Proxy "http://yourproxyaddress:proxyport";

0
2018-03-30 17:53



leider ist gksu nicht installiert und ich kann es noch nicht installieren :( Ich gebe Nano einen Schuss - alilland
Entschuldigung ich denke auch es erfordert Authentifizierung..try: sudo -H gedit /etc/apt/apt.conf und füge unterhalb Zeile hinzu: Acquire :: http :: Proxy "Benutzername: Passwort @ Proxyhost: Port / ";; - Vivek
Gibt es eine Möglichkeit, dem Proxy einen Benutzernamen / ein Passwort hinzuzufügen? Ich bin nicht in der Lage, erfolgreich festzustellen, ob mein Proxy akzeptiert wird oder nicht, ich kann der GUI Proxy hinzufügen und Firefox erfolgreich verwenden - bearbeiten - danke! - alilland
Das bringt mich zum nächsten Schritt! Ich habe neue Fehlermeldungen. auf allen Fehlermeldungen im jetzt bekommen 403 verbotene Fehler statt 407 Berechtigungsfehler lol - alilland
Kannst du den Fehler hier einfügen? - Vivek