Frage Geany stürzt beim Start mit segfault ab


Ab heute läuft mein Geany-Editor weder von Shortcut noch vom Terminal aus.

Meine Ubuntu-Version ist 14.04 Trusty Tahr.

Geany Version ist 1.26.

Ich habe auch versucht, die neueste Version 1.27 neu zu installieren, aber immer noch nicht funktioniert.

Wenn ich versuche zu starten geany Von der Kommandozeile gibt es dann einen Fehler:

Segmentation fault (core dumped)

Was könnte möglicherweise das Problem sein? Zuvor war es in Ordnung.


1
2018-05-20 09:57


Ursprung




Antworten:


Dies ist ein Fehler und eine Art Off-Thema hier. Es gibt jedoch 2 Dinge zu tun:

1: Run Geany mit gdb und sende ein Backtrace an Geany Devs. Mach es so

  • Installieren Sie gdb aus dem Repository
  • Run gdb Geany gefolgt von Drücken r zum Laufen
  • Wenn Geany stürzt, tippe bt  und sende es an Geany Devs (z.B. über GitHub) oder melden Sie einen Fehler gegen Ubuntu
    (Wirklich, es ist ein Bug sicher)

2: Wahrscheinlich ist eines der Plugins fehlerhaft oder eine andere Einstellung ist fehlerhaft. Bewegung ~/.config/geany/geany.conf aus dem Weg - z.B. Umbenennen ist ok - und starten Sie Geany. Es sollte mit Standardwerten beginnen. Löschen Sie die alte geany.conf nicht so, wie sie möglicherweise in den Fehlerbericht von Schritt 1 später aufgenommen wurde.


0
2018-05-21 08:31