Frage Wie kann ich Bluetooth beim Systemstart deaktivieren?


Wie kann ich Bluetooth beim Systemstart deaktivieren?


277
2017-10-16 21:02


Ursprung


Ich denke nicht, dass "sollte die natürliche Standardkonfiguration sein", Menschen sind verpflichtet, Bluetooth auf ihren Computern zu verwenden, ohne es einschalten zu müssen (Sie scheinen nicht eine Bluetooth-Maus oder eine Tastatur zu haben, wenn das Ihre waren primäre Eingabegeräte, die Bluetooth beim Booten unterstützen sollen). Ich stimme jedoch zu, dass es eine gute Möglichkeit wäre zu wählen, wie Bluetooth beim Booten aussehen soll. - roadmr
Die normale und natürliche Sache ist es, Sie in den Bluetooth-Einstellungen wählen zu lassen, ob Sie es beim Booten an oder ausschalten wollen. Es ist nicht normal, dass Leute sie jedes Mal ausschalten oder einschalten, wenn sie ihren Computer einschalten. Wir reden davon, Linux zum besten Desktop-System zu machen, nicht das Schlimmste, nicht wahr? - Robert
Wir sind uns einig, dass die Wahl der Menschen die beste Option ist. Sehen Sie hier einige Möglichkeiten, dies zu tun. answers.launchpad.net/ubuntu/+source/bluez/+question/51440 - roadmr
Das ist Fehler # 1073669. - colan
Es ist unglaublich, dass wir in der 14. Ausgabe den Ubuntu-Entwicklern immer noch "Dinge beibringen", wie "die Option, Bluetooth beim Booten ein- oder auszuschalten, sollte für normale Benutzer verfügbar sein und nicht nur für diejenigen, die gerne in endlosen Zeilen suchen öffentlicher Foren ". - Rodrigo


Antworten:


18.04+ Benutzer, die nicht natürlich ein /etc/rc.local haben, müssen eines erstellen und ausführbar machen. Um die Dinge etwas einfacher zu machen, können Sie einfach den folgenden Befehl in ein Terminal einfügen:

sudo install -b -m 755 /dev/stdin /etc/rc.local << EOF
#!/bin/sh
rfkill block bluetooth
exit 0
EOF

Lauf sudoedit /etc/rc.local und füge dies vor Zeile mit hinzu exit 0:

rfkill block bluetooth

Sie sollten Bluetooth weiterhin über das obere Balken-Applet aktivieren können.

Dies sollte funktionieren für die meisten Systeme, aber es sieht so aus, als gäbe es ein paar Bugs, die im ACPI für Thinkpads des Kernels lauern. Wenn Sie ein Thinkpad verwenden, fügen Sie Folgendes hinzu /etc/rc.local:

echo disable > /proc/acpi/ibm/bluetooth

Oder check out ibm-acpi - IBM ThinkPad ACPI Extras Treiber - Einige Berichte schlagen vor, dass ibm-acpi Bluetooth-Steuerung (neben anderen schönen Dingen) enthält. Aber ich habe keine Hardware, daher kann ich diese Behauptungen nicht überprüfen. Viel Glück.


189
2017-08-18 09:00



Für Thinkpads (und nur Thinkpads) funktioniert das: echo disable > /proc/acpi/ibm/bluetooth in /etc/rc.local - Marius Gedminas
rfkill block bluetooth arbeitete für Thinkpad T430u - bmaupin
Beides funktionierte nicht für mich (ThinkPad x201), als ich sie nacheinander in /etc/rc.local. Das rfkill block bluetooth Befehl funktioniert, aber nicht beim Start. Das Flag -x ist aktiviert /etc/rc.local. Ich benutze Xubuntu 13.10. - Kyle Falconer
Auf Ubuntu 15.10 mit systemd Sie brauchen etwas mehr, um die Verwendung des zu reaktivieren etc/rc.local Datei: askubuntu.com/a/696226/34298 - rubo77
Wenn unser rc.local nur eine leere Datei ist, wo sollten wir 'rfkill block bluetooth' hinzufügen? - Sss


Ich habe ein How-To mit einem sauberen "Workaround" gefunden Hier (Archivlink für die Nachwelt)

Eigentlich verändert sich /etc/bluetooth/main.conf war genug für mich.

Aus dem Artikel:

Suche nach dem Eintrag:

InitiallyPowered = true

und ändern Sie den Wert zu:

InitiallyPowered = false

Es war genug für mich, obwohl der Artikel einige andere Schritte beschreibt, die möglicherweise notwendig sind oder nicht.

Auf Ubuntu 17.10 und Ubuntu 18.04 die Option InitiallyPowered wurde ersetzt mit AutoEnable


70
2018-06-25 18:00



funktioniert nicht für Samsung Laptop 530u3b, Bluetooth ist immer nach Neustart und aufwachen - Maxim Kim
Das würde nur funktionieren, wenn ich auch Saeed Zarinfam's Putting-Antwort verwenden würde /etc/init.d/bluetooth stop in rc.local. Es scheint, dass wenn der Dienst startet, es auch das Einschalten für Bluetooth bringt. Ich brauchte beide, um das zur Arbeit zu bringen. (ThinkPad x201, Xubuntu 13.10) - Kyle Falconer
Hat auf thinkpad t420 nicht funktioniert - UpTheCreek
"Suche nach dem Eintrag" ist für diejenigen von uns, die main.conf enthält diesen Parameter oder keinen Kommentar, der den Standardspeicherort angibt. Also, unter dem [Heading] sollen wir es sagen? - underscore_d
In meinem Fall war es AutoEnable = false, aber sowieso +1 für die richtige Lösung von der richtigen Stelle. - Arman Petrosyan


So deaktivieren Sie das Laden des Bluetooth-Treibers beim Start:

sudo $EDITOR /etc/modprobe.d/blacklist.conf

hinzufügen:

blacklist btusb

Es später zu aktivieren sollte nur sein:

sudo modprobe btusb

23
2017-08-18 16:59



Danke dafür, das scheint zu funktionieren, aber ich habe versucht, Befehlszeilen-Sachen nach meiner ursprünglichen Frage zu vermeiden. Sie würden denken, dies wäre so einfach wie ein Kästchen ankreuzen, so dass es daran erinnert, dass ich nicht möchte, dass BT automatisch startet, aber es sieht so aus, als wäre es komplizierter. Mit Ubuntus Bestreben nach schnelleren Boot-Zeiten und dem generellen Fokus auf den Stromverbrauch von Laptops und Netbooks bin ich überrascht, dass dies nie in Angriff genommen wurde. Ich schätze die Hilfe jedoch.
"Führe gedit als root aus und bearbeite /etc/modprobe.d/blacklist.conf" <- ok, ist das weniger Befehlszeile für dich? - maco
Funktioniert gut auf Samsung Q35 mit Ubuntu 13.10, während der 'Rfkill Block Bluetooth' Ansatz nicht funktioniert. Vielen Dank! - user27164
DELL E6410 funktioniert für mich. Gut, das kann ohne Zurücksetzen von unterwegs wieder laufen. - Ruslan Gerasimov
Versuchen Sie nicht, Befehlszeilen zu vermeiden, wenn Sie das Betriebssystem konfigurieren. Ist Strg + Alt + T und ein paar Strg-Umschalt-V (zum Einfügen) zu viel zu fragen? - doug65536


Schritt 1: Gehen Sie zum Terminal und geben Sie den folgenden Befehl ein, um das System zu bearbeiten /etc/rc.local Datei:

gksudo gedit /etc/rc.local

Schritt 2: Fügen Sie die folgende Zeile vor dem exit 0 Linie:

rfkill block bluetooth

16
2018-05-04 20:44



Dies ist ein weicher Block für Bluetooth, ich denke, es ist gleich wie den Dienst ausschalten und funktioniert gut. - Smile.Hunter
@Robert: $ man rfkill: "Deaktivieren Sie das Gerät, das dem angegebenen Index entspricht."Trotz des Namens wird BT nur deaktiviert, probieren Sie einfach den Befehl aus rfkill block bluetooth Auf dem Terminal sollte das Symbol grau erscheinen. - Daniel


Ab Ubuntu 16.04 verwaltet Systemd Startup-Dienste wie Bluetooth ... um das aktuelle Status-Problem in einem Terminal anzuzeigen

sudo systemctl status bluetooth.service 

Um Bluetooth beim Start zu deaktivieren, stelle dies auf

sudo systemctl disable bluetooth.service

dann beim nächsten Neustart Bluetooth ist nicht aktiv ... um Bluetooth-Problem zu aktivieren

sudo systemctl enable bluetooth.service

12
2017-08-01 15:08



Das funktioniert für mich, aber als Nebeneffekt hörte auch das blueman-applet auf zu arbeiten. Es startet, erscheint aber nicht im Anzeigebereich, daher gibt es keine schnelle Möglichkeit, Bluetooth zu aktivieren, nur im Terminal. - Yuri Gor
Zumindest in Xubuntu, wenn Sie auf Blueman klicken, hat es die Option "Bluetooth ausschalten". Ich denke, das ist das, was das OP automatisieren möchte. Ihre Lösung entfernt Blueman ganz, wodurch es schwieriger wird, Bluetooth auf Wunsch wieder zu aktivieren. - Adrian Keister
Setzen Sie sudo systemctl deaktivieren Sie bluetooth.service && sudo systemctl stop bluetooth.service in ein Disable-Skript und chmod 755 darauf. Machen Sie das selbe für sudo systemctl enable bluetooth.service && sudo systemctl starten Sie bluetooth.service in einem Enable-Skript. - Adrian Keister


Geben Sie Folgendes in ein Terminal ein:

sudo gedit /etc/modprobe.d/blacklist.conf

Fügen Sie am Ende der Datei die Zeile hinzu:

blacklist bluetooth

Speichere die Datei und starte neu - Bluetooth sollte jetzt deaktiviert sein.


7
2017-10-16 21:25



Dies funktioniert nicht auf meinem PC ... - Floqqi
@Floqqi: Können Sie es bitte noch einmal versuchen? Ich habe meine Antwort aktualisiert. - Nathan Osman
Habe auf meinem ubuntu 12 thinkpad etwa 20 Dinge probiert, das ist der einzige, der es geschafft hat. - OlivierBlanvillain


Sie können die Dienste, die beim Booten gestartet werden, mit Hilfe von ändern GAMMLER.

Es installieren: sudo apt-get install bum

Lauf: sudo bum

enter image description here 

Deaktivieren Sie das Kontrollkästchen und klicken Sie auf Sich bewerben.


7
2018-05-05 00:09



Danke, Desgua, ich dachte über diese Art von Werkzeugen nach. Ich habe einige in der Vergangenheit benutzt, aber sie sind überholt und das neue Ubuntu mit seiner minimalistischen Obsession kommt mit nichts von der Art. Ist das der einzige, den du kennst oder den du am besten kennst? - Robert
Vielleicht funktioniert es, aber zuerst hat es mich enttäuscht, weil es anfing, das Bluetooth zu zeigen, als nicht zur Bootzeit aktiviert, warum? und wenn rfkill nicht läuft, zeigen das Applet und hciconfig es an. Ich schalte aus und weiter, aber bum fährt fort, den Dienst als ausgeschaltet zu zeigen. Ich habe den Dienst beim Hochfahren aktiviert, aber der Status des Dienstes ist weiterhin falsch. - Robert
Sorry funktioniert nicht auf elementaryOS Freya - Hoang Tran
Ich bekomme viele "Verwendung von nicht initialisierten Wert" Warnungen, wenn es ausgeführt wird. Entschuldigung, ich kann dem nicht vertrauen. - doug65536
Jetzt ist das Paket nicht verfügbar. Es heißt, Bum ist virtuell. - Satya Prakash