Frage versucht, Node js zu installieren, aber es scheint wie in den Quelldateien oder das Paket dort in einem zusätzlichen Raum, so dass Fehler gibt es [doppelt]


Diese Frage hat hier bereits eine Antwort:

versuchen, Node js zu installieren, aber es scheint wie in den Quelldateien oder Paket dort in einem zusätzlichen Raum, so dass Fehler da sind.

$ curl -sL https://deb.nodesource.com/setup_8.x | sudo -E bash -
W: Failed to fetch http://apt.postgresql.org/pub/repos/apt/dists/trusty-­pgdg/main/binary-amd64/Packages  404  Not Found [IP: 204.145.124.244 80]
W: Failed to fetch http://apt.postgresql.org/pub/repos/apt/dists/trusty-­pgdg/main/binary-i386/Packages  404  Not Found [IP: 204.145.124.244 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.

Fehler beim Ausführen des Befehls, Beenden

Sehen Sie, wie mir scheint, haben diese Links zusätzlichen Platz in den Fehler-URLs

http://apt.postgresql.org/pub/repos/apt/dists/trusty- ­pgdg/main/binary-amd64/Packages

sehen trusty- ­pgdg der Raum vorher pgdg Als ich die URL ohne Leerzeichen kopiert habe, konnte ich die Pakete herunterladen.

Was soll ich tun, um das zu lösen?

Als ich es hier eingefügt habe, war der Platz weg, aber ich habe den Screenshot angehängt.


1
2018-06-13 11:56


Ursprung




Antworten:


Wenn Sie installieren möchten node.js Sie sollten es über apt installieren:

sudo apt-get install nodejs

Sie können weitere node.js-Pakete mit folgendem Befehl auflisten:

apt search nodejs

Verwenden des Befehls

nodejs -v

Sie können die installierte Version überprüfen.


0
2018-06-13 13:16



root @ mayank-Vostro-460: ~ # sudo apt-get installieren nodejs ........... Lesen von Paketlisten ... Fertig ......... Aufbau Abhängigkeit Baum .... ....... Statusinformationen lesen ... Fertig ......... nodejs ist bereits die neueste Version ..... 0 aktualisiert, 0 neu installiert, 0 entfernt und 377 nicht aktualisiert. .. root @ mayank-Vostro-460: ~ # node -v ......... Das Programm 'node' kann in folgenden Paketen gefunden werden: ....... * node .... . * nodejs-legacy .... Versuch: apt-get install <ausgewähltes Paket> ... ***** Bedeutet dies, dass NodeJS installiert ist? Wie überprüfe ich die installierte Version? **** - Mayank90
root @ mayank-Vostro-460: ~ # vi http_server.js ------------ root @ mayank-Vostro-460: ~ # cat http_server.js ---------- var http = require ('http'); -------------- http.createServer (Funktion (req, res)) {res.writeHead (200, {'Inhaltstyp': 'text / plain'}); res.end ( 'Hallo Welt \ n');}). Listen (3000, "127.0.0.1"); console.log ('Server läuft unter 127.0.0.1:3000/ '); ---------- root @ mayank-Vostro-460: ~ # Knoten http_server.js ----------------- Das Programm 'node' finden Sie in die folgenden Pakete: -------- * Knoten ---- * nodejs-legacy ----- Versuche: apt-get install <ausgewähltes Paket> --- - Mayank90
Sie können die aktuelle Version mit: nodejs -v nachweisen - abu_bua
@ Mayank90: Könntest du bitte bearbeiten Ihr Beitrag, wenn Sie Informationen hinzufügen möchten? Vor allem Datei- oder Programmausgabe Auflistungen (mit Hilfe der {} Schaltfläche in der Editor-Symbolleiste) wird dort deutlich lesbarer sein; alternativ können Sie ein Pastieservice für längere Einträge und fügen Sie den Link Ihres Pasties in Ihre Frage ein. Insgesamt ist es am besten, alles an einem Ort zu haben. Außerdem können Kommentare aus verschiedenen Gründen gelöscht werden. Vielen Dank. - David Foerster


https://tecadmin.net/install-latest-nodejs-npm-on-ubuntu/

// Schritte 0 ;;;;

//

sudo apt-get installiert curl python-software-properties

Curl -sL https://deb.nodesource.com/setup_8.x | sudo -E bash -

sudo apt-get installieren nodejs

//

// Das wird Dinge installieren, selbst wenn ein Fehler vorhanden ist, kann es gut funktionieren.

// wenn das nicht funktioniert.

// ODER --- Schritt 0 ;;;;;;;

Installieren Sie nodejs direkt aus dem Binary-Datei-Installer von Ubuntu. **https://nodejs.org/de/download/

** Scheckversion ;;;;;;;;;;

Knoten -v

v10.0.0

Wenn oben nicht funktioniert, versuchen Sie, das 2. Terminal zu öffnen und prüfen Sie es 

Knoten -v

wenn es immer noch nicht funktioniert, Schritt 2:::::::::

Probleme beim Suchen des Knotens in ubuntu 14.04 nach der Installation

#welche Nodejs

** In meinem Fall wurde / usr / bin / nodejs angezeigt

** dann Machen Sie einen Link, ändern Sie die Umgebungsvariable oder ändern Sie den Pfad des Knotenbefehls oder etwas

#sudo ln -s / usr / bin / Knotenjs / usr / bin / Knoten

------Log----

root @ mayank-Vostro-460: ~ # welcher Knoten

root @ mayank-Vostro-460: ~ # welcher Knoten

/ usr / bin / nodejs

root @ mayank-Vostro-460: ~ # sudo ln -s / usr / bin / nodejs / usr / bin / node

root @ mayank-Vostro-460: ~ # Knoten -v

v0.10.25

Überprüfen Sie, ob der Knoten funktioniert?

Schritt 4 - Demo Web Server erstellen (optional) dann überprüfe das von https://tecadmin.net/install-latest-nodejs-npm-on-ubuntu/

----------Log----------

root @ mayank-Vostro-460: ~ # vi http_server.js

root @ mayank-Vostro-460: ~ # cat http_server.js

var http = require ('http');

http.createServer (Funktion (req, res) {

res.writeHead (200, {'Content-Type': 'text / plain'});

res.end ('Hallo Welt \ n');

}). listen (3000, "127.0.0.1");

console.log ('Server läuft unter http://127.0.0.1:3000/");

root @ mayank-Vostro-460: ~ # Knoten http_server.js

Das Programm 'node' kann in den folgenden Paketen gefunden werden:

  • Knoten

  • nodejs-Vermächtnis

Versuchen Sie: apt-get install

root @ mayank-Vostro-460: ~ # welcher Knoten

root @ mayank-Vostro-460: ~ # welcher Knoten

/ usr / bin / nodejs

root @ mayank-Vostro-460: ~ # sudo ln -s / usr / bin / nodejs / usr / bin / node

root @ mayank-Vostro-460: ~ # Knoten -v

v0.10.25

root @ mayank-Vostro-460: ~ # Knoten http_server.js

Server läuft um http://127.0.0.1:3000/


in Chrome oder Firefox broweser öffnen ;;;

127.0.0.1:3000/

Ausgabe: Hallo Welt...

So läuft nodejs .........


-2
2018-06-13 13:55



Bitte formatieren Sie Ihre Bearbeitung! - abu_bua
Ich habe es bearbeitet. Es war lange, da ich nur die Dinge zeigen wollte, um dieses Problem zu lösen. - Mayank90