Frage Installation von OpenFOAM 2.3 unter Ubuntu 14.04


Zurzeit gibt es kein Paket für Ubuntu 14.04 Trusty bei http://www.openfoam.org/download/ubuntu.php. Wenn ich versuche, das Paket für 13.10 Saucy zu verwenden aptitude gibt mir einen Fehler, wenn ich es versuche

sudo aptitude install openfoam230 paraviewopenfoam410 

[lange Liste von Abhängigkeiten gekappt]

The following packages have unmet dependencies:
 openfoam230 : Depends: libboost-thread1.53.0 which is a virtual package.
               Depends: libopenmpi1.3 which is a virtual package.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     openfoam230 [Not Installed]  

Bis ein offizielles Paket verfügbar ist, gibt es einen Weg um dies zu erreichen, ohne von der Quelle zu installieren?


0
2018-05-04 13:08


Ursprung


Dies sollte das ungelöste Problem lösen askubuntu.com/questions/140246/ ... - Fat Mind


Antworten:


OpenFoam kann jetzt von apt-get installiert werden http://www.openfoam.org/download/ubuntu.php


1
2018-01-21 10:15





Sie müssen warten, bis sie die vertrauenswürdige Version (14.04) freigeben, wenn Sie apt verwenden möchten, andernfalls können Sie die Quelldatei kompilieren. Sehen Sie diesen Link für Anweisungen: http://www.openfoam.org/download/source.php

Dieser Link enthält auch Informationen zum Installieren aus der Quelldatei http://openfoamwiki.net/index.php/Installation/Linux/OpenFOAM-2.3.0/Ubuntu#Ubuntu_14.04


2
2018-05-05 16:56



Klar, aber ich hatte gehofft, die Bauzeit von ca. 0,5 - 6 Stunden zu vermeiden :) - hertzsprung
Ich versuche auch zu installieren, aber ich habe diese Anweisungen auf der Seite gefunden: openfoam.org/download/ubuntu.php Mein Problem ist, was damit zu tun hat VERS=$. Soll ich schreiben VERS=precise oder einfach precise Anstatt von VERS=$??? - Aradnix