Frage KDE-Apps haben den Ladevorgang beendet und zitieren fehlende libQtSvg


Gestern (und in den vorangegangenen Monaten) konnte ich Konsole ganz gut gebrauchen. Ich habe seitdem nichts absichtlich geändert. Allerdings wird es heute nicht geladen:

[11:06]~$ konsole
konsole: error while loading shared libraries: libQtSvg.so.4: cannot open shared object file: No such file or directory
[11:06]~$ locate libQtSvg.so.4
/usr/lib/x86_64-linux-gnu/libQtSvg.so.4
/usr/lib/x86_64-linux-gnu/libQtSvg.so.4.8
/usr/lib/x86_64-linux-gnu/libQtSvg.so.4.8.6

Ich habe es auch "okular" versucht. Ich benutze keine anderen KDE-Apps, aber ich kann mir vorstellen, dass dies für alle gilt. Es scheint, dass die Bibliothek vorhanden ist, aber nicht gefunden wird. Irgendwelche Ideen, was könnte dies verursachen, oder noch wichtiger, wie es zu beheben?

Es verbindet sich gut mit Dingen im selben Verzeichnis:

[11:18]~$ ldd `which konsole`
        linux-vdso.so.1 =>  (0x00007fff89dfe000)
        libkdeinit4_konsole.so => /usr/lib/kde4/libkdeinit/libkdeinit4_konsole.so (0x00007f6a91580000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f6a91195000)
        libkonsoleprivate.so => /usr/lib/libkonsoleprivate.so (0x00007f6a90e8f000)
        libknotifyconfig.so.4 => /usr/lib/libknotifyconfig.so.4 (0x00007f6a90c7d000)
        libkio.so.5 => /usr/lib/libkio.so.5 (0x00007f6a907d4000)
        libkdeui.so.5 => /usr/lib/libkdeui.so.5 (0x00007f6a9018c000)
        libkdecore.so.5 => /usr/lib/libkdecore.so.5 (0x00007f6a8fccb000)
        libQtCore.so.4 => /usr/lib/x86_64-linux-gnu/libQtCore.so.4 (0x00007f6a8f7e6000)
        libQtGui.so.4 => /usr/lib/x86_64-linux-gnu/libQtGui.so.4 (0x00007f6a8eb32000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f6a8e82e000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f6a917a5000)
        libkpty.so.4 => /usr/lib/libkpty.so.4 (0x00007f6a8e624000)
        libkonq.so.5abi1 => /usr/lib/libkonq.so.5abi1 (0x00007f6a8e3ec000)
        libQtNetwork.so.4 => /usr/lib/x86_64-linux-gnu/libQtNetwork.so.4 (0x00007f6a8e0a4000)
        libQtDBus.so.4 => /usr/lib/x86_64-linux-gnu/libQtDBus.so.4 (0x00007f6a8de29000)
        libphonon.so.4 => /usr/lib/x86_64-linux-gnu/libphonon.so.4 (0x00007f6a8dbb0000)
        libnepomuk.so.4 => /usr/lib/libnepomuk.so.4 (0x00007f6a8d8e5000)
        libQtXml.so.4 => /usr/lib/x86_64-linux-gnu/libQtXml.so.4 (0x00007f6a8d6a0000)
        libQtSvg.so.4 => not found
        libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f6a8d36a000)
        libstreamanalyzer.so.0 => /usr/lib/libstreamanalyzer.so.0 (0x00007f6a8d0ec000)
        libsolid.so.4 => /usr/lib/libsolid.so.4 (0x00007f6a8cdeb000)
        libacl.so.1 => /lib/x86_64-linux-gnu/libacl.so.1 (0x00007f6a8cbe3000)
        libattr.so.1 => /lib/x86_64-linux-gnu/libattr.so.1 (0x00007f6a8c9de000)
        libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f6a8c7d3000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f6a8c4cd000)
        libSM.so.6 => /usr/lib/x86_64-linux-gnu/libSM.so.6 (0x00007f6a8c2c5000)
        libICE.so.6 => /usr/lib/x86_64-linux-gnu/libICE.so.6 (0x00007f6a8c0a8000)
        libattica.so.0.4 => /usr/lib/x86_64-linux-gnu/libattica.so.0.4 (0x00007f6a8bdc5000)
        libQtSvg.so.4 => not found
        libdbusmenu-qt.so.2 => /usr/lib/x86_64-linux-gnu/libdbusmenu-qt.so.2 (0x00007f6a8bb92000)
        libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007f6a8b98c000)
        libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f6a8b773000)
        libbz2.so.1.0 => /lib/x86_64-linux-gnu/libbz2.so.1.0 (0x00007f6a8b562000)
        liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007f6a8b340000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f6a8b122000)
        libdlrestrictions.so.1 => /usr/lib/libdlrestrictions.so.1 (0x00007f6a8af1c000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f6a8ad06000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f6a8ab02000)
        libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f6a8a7f9000)
        librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f6a8a5f1000)
        libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007f6a8a3b5000)
        libaudio.so.2 => /usr/lib/x86_64-linux-gnu/libaudio.so.2 (0x00007f6a8a19c000)
        libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 (0x00007f6a89f76000)
        libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f6a89cd3000)
        libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007f6a89a81000)
        libXi.so.6 => /usr/lib/x86_64-linux-gnu/libXi.so.6 (0x00007f6a89871000)
        libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f6a8965f000)
        libutil.so.1 => /lib/x86_64-linux-gnu/libutil.so.1 (0x00007f6a8945b000)
        libutempter.so.0 => /usr/lib/libutempter.so.0 (0x00007f6a89258000)
        libkparts.so.4 => /usr/lib/libkparts.so.4 (0x00007f6a89004000)
        libkfile.so.4 => /usr/lib/libkfile.so.4 (0x00007f6a88d5e000)
        libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007f6a88b19000)
        libpulse.so.0 => /usr/lib/x86_64-linux-gnu/libpulse.so.0 (0x00007f6a888cf000)
        libpulse-mainloop-glib.so.0 => /usr/lib/x86_64-linux-gnu/libpulse-mainloop-glib.so.0 (0x00007f6a886ca000)
        libsoprano.so.4 => /usr/lib/libsoprano.so.4 (0x00007f6a883e1000)
        libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f6a881c2000)
        libstreams.so.0 => /usr/lib/libstreams.so.0 (0x00007f6a87f8b000)
        libxml2.so.2 => /usr/lib/x86_64-linux-gnu/libxml2.so.2 (0x00007f6a87c24000)
        libudev.so.1 => /lib/x86_64-linux-gnu/libudev.so.1 (0x00007f6a87a13000)
        libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007f6a8780e000)
        libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f6a875cf000)
        libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007f6a873a5000)
        libXt.so.6 => /usr/lib/x86_64-linux-gnu/libXt.so.6 (0x00007f6a8713f000)
        libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f6a86f3a000)
        libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007f6a86d32000)
        libnepomukutils.so.4 => /usr/lib/libnepomukutils.so.4 (0x00007f6a86af7000)
        libjson-c.so.2 => /lib/x86_64-linux-gnu/libjson-c.so.2 (0x00007f6a868ec000)
        libpulsecommon-4.0.so => /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecommon-4.0.so (0x00007f6a86684000)
        libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f6a8647e000)
        libcgmanager.so.0 => /lib/x86_64-linux-gnu/libcgmanager.so.0 (0x00007f6a86262000)
        libnih.so.1 => /lib/x86_64-linux-gnu/libnih.so.1 (0x00007f6a8604a000)
        libnih-dbus.so.1 => /lib/x86_64-linux-gnu/libnih-dbus.so.1 (0x00007f6a85e40000)
        libnepomukquery.so.4 => /usr/lib/libnepomukquery.so.4 (0x00007f6a85bf9000)
        libwrap.so.0 => /lib/x86_64-linux-gnu/libwrap.so.0 (0x00007f6a859ef000)
        libsndfile.so.1 => /usr/lib/x86_64-linux-gnu/libsndfile.so.1 (0x00007f6a85786000)
        libasyncns.so.0 => /usr/lib/x86_64-linux-gnu/libasyncns.so.0 (0x00007f6a85580000)
        libnsl.so.1 => /lib/x86_64-linux-gnu/libnsl.so.1 (0x00007f6a85365000)
        libFLAC.so.8 => /usr/lib/x86_64-linux-gnu/libFLAC.so.8 (0x00007f6a85134000)
        libvorbisenc.so.2 => /usr/lib/x86_64-linux-gnu/libvorbisenc.so.2 (0x00007f6a84c65000)
        libvorbis.so.0 => /usr/lib/x86_64-linux-gnu/libvorbis.so.0 (0x00007f6a84a37000)
        libogg.so.0 => /usr/lib/x86_64-linux-gnu/libogg.so.0 (0x00007f6a8482e000)
        libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007f6a84613000)

0
2017-10-23 10:16


Ursprung




Antworten:


Also, ich habe das behoben. Ein Haufen libQt-Bibliotheken war vermasselt. Keine Ahnung, was es verursacht hat.

Gelöst mit:

sudo apt-get install --reinstall libqt4-svg libqt4-script libqt4-scripttools libqt4-sql libqt4-test

2
2017-10-23 10:26