Frage 3 Monitore mit 2 Videokarten funktionieren nicht


Ich versuche Ubuntu mit 3 Monitoren zu arbeiten. Ich habe 2 Videokarten bekommen

lspci | Grep VGA

20:01:00.0 VGA compatible controller: ATI Technologies Inc RV620 LE [Radeon HD 3450]
25:05:00.0 VGA compatible controller: nVidia Corporation NV44A [GeForce 6200] (rev a1)

Ich habe zwei Monitore an meine ATI-Karte angeschlossen, die an meinen primären PCIe-Steckplatz angeschlossen ist, und einen Monitor an meine nVidia-Karte angeschlossen

Ich hatte es richtig funktioniert mit zwei Monitoren (DVI | VGA) in die ATI-Karte und den nVidia Monitor leer gesteckt. Jetzt habe ich den nVidia-Monitor (DVI) und einen Monitor von der ATI (vga) funktioniert, aber ich kann nicht scheinen, den letzten Monitor auf der ATI (DVI) zu bekommen, irgendetwas zu zeigen. Beide Monitore, die an die ATI-Karten angeschlossen sind, zeigen den Startbildschirm, während der nVidia-Monitor leer ist, und arbeiten bis zu dem Punkt, an dem Sie mit dem Anmeldebildschirm für Ubuntu angezeigt werden, dann wird der DVI-Monitor auf der ATI-Karte leer und der nVidia-Monitor geht an und funktioniert.

Jetzt habe ich zwei Bildschirme, einen auf jeder Karte. Auf den ersten Blick scheint es so, als ob mein Setup "funktionieren" würde - wie das Hintergrundbild aussehen soll. Mein linker Bildschirm ist nur zur Hälfte mit Tapeten bedeckt, während mein mittlerer Monitor vollständig bedeckt ist, und es sieht so aus, als ob das fehlende Viertel meines Hintergrundbildes auf der linken Hälfte meines dritten Monitors rechts rendern sollte ... nicht sicher, ob das tatsächlich der Fall ist bedeutet alles.

So ähnlich, wo X = Tapete

 1   2   3
[ X][XX][X ]

Momentan sehe ich diesen Fehler in meiner Xorg.0.log-Datei, aber ich bin mir nicht sicher, wohin ich von hier aus gehen soll:

[    24.746] (EE) RADEON(2):  reusing fd for second head

Könnte ich mit meiner xorg.conf etwas falsch gemacht haben oder muss ich etwas mehr tun, um dies zum Laufen zu bringen?

/etc/X11/xorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 270.29  (buildmeister@swio-display-x86-rhel47-02.nvid

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      "Screen1" RightOf "Screen0"
    Screen      "Screen2" RightOf "Screen1"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Module"
    Load    "dbe"       # Double-buffering
    Load    "GLcore"    # OpenGL support
    # Load  "dri"       # Direct rednering infrastructure
    Load    "glx"       # OpenGL X protocol interface
    Load    "extmod"    # Misc. required extensions
    # Load  "v4l"       # Video4Linux
    Load    "record"    # X event recorder
    Load    "freetype"  # TrueType font handler
    Load    "type1"     # Adobe Type 1 font handler
EndSection

Section "ServerFlags"
    Option "Xinerama" "true"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Dell0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 76.0
        Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Dell1"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSectiSection "Monitor"
    Identifier     "Dell2"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier  "RD3450"
    Driver      "radeon"
    BusId       "PCI:01:00:0"
    Screen      0
EndSection

Section "Device"
    Identifier  "RD34501"
    Driver      "radeon"
    BusId       "PCI:01:00:0"
    Screen      1
EndSection

Section "Device"
    Identifier     "GF6200"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusId          "PCI:05:00:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "GF6200"
    Monitor        "Dell0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "RD3450"
    Monitor        "Dell1"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen2"
    Device         "RD34501"
    Monitor        "Dell2"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "DRI"
    Mode    0666
EndSection

0
2018-03-15 02:35


Ursprung




Antworten:


In Ihrer xorg.conf ist ein Fehler aufgetreten: EndSectiSection "Monitor"


2
2017-10-30 18:24





Dein 2. "Monitor"Abschnitt (beschriftet "Dell1") ist kaputt. Es gibt eine Zeile, die sagt EndSectiSection.


0
2018-01-28 16:13