Frage Pakete haben unerfüllte Abhängigkeiten - virtual box5.1 mysql-server


Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 mysql-server : Depends: mysql-server-5.7 but it is not going to be installed
 virtualbox-5.1:i386 : Depends: libc6:i386 (>= 2.15) but it is not going to be installed
                       Depends: libcurl3:i386 (>= 7.16.2) but it is not going to be installed
                       Depends: libdevmapper1.02.1:i386 (>= 2:1.02.97) but it is not going to be installed
                       Depends: libgcc1:i386 (>= 1:4.2) but it is not going to be installed
                       Depends: libgl1-mesa-glx:i386 but it is not going to be installed or
                                libgl1:i386
                       Depends: libpng12-0:i386 (>= 1.2.13-4) but it is not going to be installed
                       Depends: libqt5core5a:i386 (>= 5.5.0) but it is not going to be installed
                       Depends: libqt5gui5:i386 (>= 5.3.0) but it is not going to be installed or
                                libqt5gui5-gles:i386 (>= 5.3.0) but it is not going to be installed
                       Depends: libqt5opengl5:i386 (>= 5.0.2) but it is not going to be installed or
                                libqt5opengl5-gles:i386 (>= 5.0.2) but it is not going to be installed
                       Depends: libqt5printsupport5:i386 (>= 5.0.2) but it is not going to be installed
                       Depends: libqt5widgets5:i386 (>= 5.2.0) but it is not going to be installed
                       Depends: libqt5x11extras5:i386 (>= 5.1.0) but it is not going to be installed
                       Depends: libsdl1.2debian:i386 (>= 1.2.11) but it is not going to be installed
                       Depends: libssl1.0.0:i386 (>= 1.0.0) but it is not going to be installed
                       Depends: libstdc++6:i386 (>= 5.2) but it is not going to be installed
                       Depends: libvpx3:i386 (>= 1.5.0) but it is not going to be installed
                       Depends: libx11-6:i386 but it is not going to be installed
                       Depends: libxcb1:i386 but it is not going to be installed
                       Depends: libxcursor1:i386 (> 1.1.2) but it is not going to be installed
                       Depends: libxext6:i386 but it is not going to be installed
                       Depends: libxinerama1:i386 but it is not going to be installed
                       Depends: libxml2:i386 (>= 2.7.4) but it is not going to be installed
                       Depends: libxmu6:i386 but it is not going to be installed
                       Depends: libxt6:i386 but it is not going to be installed
                       Depends: zlib1g:i386 (>= 1:1.1.4) but it is not going to be installed
                       Recommends: libasound2:i386
                       Recommends: libpulse0:i386 but it is not going to be installed
                       Recommends: libsdl-ttf2.0-0:i386 but it is not going to be installed
                       Recommends: linux-headers-generic:i386 but it is not going to be installed or
                                   linux-headers-generic-pae:i386 but it is not installable or
                                   linux-headers-686-pae:i386 but it is not installable or
                                   linux-headers-amd64:i386 but it is not installable or
                                   linux-headers-2.6-686:i386 but it is not installable or
                                   linux-headers-2.6-amd64:i386 but it is not installable or
                                   linux-headers:i386
                       Recommends: linux-image:i386
                       Recommends: gcc:i386 but it is not going to be installed
                       Recommends: binutils:i386 but it is not going to be installed
                       Recommends: pdf-viewer:i386
                       Recommends: libgl1:i386
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

0
2017-09-07 06:36


Ursprung


Dies ist Synaptic, die ich versuchte zu installieren, ähnlich, als ich versuchte, mysql zu installieren, es wirft mich auch Abhängigkeiten Fehler. Bitte hilf mir dabei - Hitesh Hinduja
wie man die virtuelle Box komplett entfernt und neu startet oder einfach nur entfernt und die defekten Pakete repariert - Hitesh Hinduja
Hast du das gemacht? apt-get -f install? Und wir sehen den Befehl, Virtualbox zu installieren! - George Udosen
Ja, ich habe es versucht und es sagt mir "abgestuft, 160 neu installiert, 0 zu entfernen und 62 nicht aktualisiert. 1 nicht vollständig installiert oder entfernt. Benötigen 57.5 MB Archive. Nach diesem Vorgang werden 320 MB zusätzlichen Speicherplatz Wenn Sie fortfahren möchten? [Y / n] y "Dann habe ich" Y "gedrückt, aber es geht nicht weiter - Hitesh Hinduja
OK, mach sudo apt update, dann sudo apt install -f - George Udosen


Antworten:


Von Ihrer Konversation müssen Sie Ihren Repository-Index-Cache mit den folgenden Zeilen aktualisieren und installieren, was erforderlich ist:

sudo apt update
sudo apt install -f

Damit apt sollte in der Lage sein, die erforderlichen Abhängigkeiten zu bekommen.


1
2017-09-07 06:58