Frage Wie installiere ich das RPM-Paket, ohne es in Deb zu konvertieren


Wenn ich versuche, rpm in deb zu konvertieren, erscheinen folgende Warnungen:

warning: libgmt-devel-4.5.9-3.mga4.i586.rpm: Header V3 RSA/SHA1 Signature, key ID 80420f66: NOKEY
warning: libgmt-devel-4.5.9-3.mga4.i586.rpm: Header V3 RSA/SHA1 Signature, key ID 80420f66: NOKEY
warning: libgmt-devel-4.5.9-3.mga4.i586.rpm: Header V3 RSA/SHA1 Signature, key ID 80420f66: NOKEY
warning: libgmt-devel-4.5.9-3.mga4.i586.rpm: Header V3 RSA/SHA1 Signature, key ID 80420f66: NOKEY
warning: libgmt-devel-4.5.9-3.mga4.i586.rpm: Header V3 RSA/SHA1 Signature, key ID 80420f66: NOKEY
warning: libgmt-devel-4.5.9-3.mga4.i586.rpm: Header V3 RSA/SHA1 Signature, key ID 80420f66: NOKEY
warning: libgmt-devel-4.5.9-3.mga4.i586.rpm: Header V3 RSA/SHA1 Signature, key ID 80420f66: NOKEY
warning: libgmt-devel-4.5.9-3.mga4.i586.rpm: Header V3 RSA/SHA1 Signature, key ID 80420f66: NOKEY
warning: libgmt-devel-4.5.9-3.mga4.i586.rpm: Header V3 RSA/SHA1 Signature, key ID 80420f66: NOKEY
warning: libgmt-devel-4.5.9-3.mga4.i586.rpm: Header V3 RSA/SHA1 Signature, key ID 80420f66: NOKEY
warning: libgmt-devel-4.5.9-3.mga4.i586.rpm: Header V3 RSA/SHA1 Signature, key ID 80420f66: NOKEY
warning: libgmt-devel-4.5.9-3.mga4.i586.rpm: Header V3 RSA/SHA1 Signature, key ID 80420f66: NOKEY
warning: libgmt-devel-4.5.9-3.mga4.i586.rpm: Header V3 RSA/SHA1 Signature, key ID 80420f66: NOKEY
warning: libgmt-devel-4.5.9-3.mga4.i586.rpm: Header V3 RSA/SHA1 Signature, key ID 80420f66: NOKEY
warning: libgmt-devel-4.5.9-3.mga4.i586.rpm: Header V3 RSA/SHA1 Signature, key ID 80420f66: NOKEY
warning: libgmt-devel-4.5.9-3.mga4.i586.rpm: Header V3 RSA/SHA1 Signature, key ID 80420f66: NOKEY
warning: libgmt-devel-4.5.9-3.mga4.i586.rpm: Header V3 RSA/SHA1 Signature, key ID 80420f66: NOKEY
libgmt-devel-4.5.9-3.mga4.i586.rpm is for architecture i386 ; the package cannot be built on this system

Wie löst man das?


0
2017-11-03 09:41


Ursprung


Ihr Titel und Ihr Körper teilen nicht dasselbe Problem. Und warum würdest du all diese Schwierigkeiten durchstehen? Sehen packages.ubuntu.com/nl/vivid/libgmt-dev für 4.5.12 oder packages.ubuntu.com/nl/wily/libgmt-dev für 5.1.2 - Rinzwind
Entschuldigung, ich kann dir nicht folgen. Ich habe das Paket "libgmt-devel-4.5.9-3.mga4.i586.rpm" heruntergeladen und ich soll dieses Paket in "/ usr / lib" installieren. Was ist der beste Weg, dies zu tun? Vielen Dank für Ihre Antwort. - GTR
WARUM würdest du Software für -Redhat herunterladen, wenn es Versionen für Ubuntu gibt? Es gibt keinen "besten" Weg, dies zu tun. Es ist nicht logisch, was du tust. - Rinzwind
Ich erhalte folgenden Fehler während der Installation: - GTR
(Datenbank wird gelesen ... 288170 Dateien und Verzeichnisse sind derzeit installiert.) Vorbereiten des Entpackens von libgmt-dev_4.5.12-1_amd64.deb ... Entpacken von libgmt-dev (4.5.12-1) über (4.5.11-1build1) .. .dpkg: Abhängigkeitsprobleme verhindern die Konfiguration von libgmt-dev: libgmt-dev hängt von libgmt4 ab (= 4.5.12-1); Allerdings: Version von libgmt4 auf dem System ist 4.5.11-1build1. dpkg: Fehler beim Verarbeiten des Pakets libgmt-dev (--install): Abhängigkeitsprobleme - unconfigured verlassen Bei der Verarbeitung sind Fehler aufgetreten: libgmt-dev - GTR


Antworten:


Mit einer funktionierenden Internetverbindung, bitte öffnen Sie ein Terminal und tun Sie:

sudo apt-get update
sudo apt-get install libgmt-dev

Das Paket und alle seine Abhängigkeiten im richtigen (.deb) Format werden korrekt installiert.


1
2017-11-03 14:06





Verwenden Sie lieber Ubuntu-Repositories oder wenn Sie wirklich die neueste Version der Software benötigen, die in Ubuntu nicht vorhanden sein kann, repos-up sie aus Quellen.

Einige Pakete können von rpm in deb konvertiert werden, aber ja - es kann einige Probleme beinhalten.


0
2017-11-03 09:49





Es scheint, dass Sie versuchen, ein 32-Bit-Paket (i386) auf einem 64-Bit-System zu erstellen, wie die letzte Protokollzeile vorschlagen:

libgmt-devel-4.5.9-3.mga4.i586.rpm is for architecture i386 ; the package cannot be built on this system

Hast du es mit der 64-Bit-Version des Pakets versucht? (was zu sein scheint lib64gmt-devel-4.5.9-3.mga4.x86_64.rpm)


0
2017-11-03 10:01