Frage Nach dem Entschlüsseln von Partitionen im Startbildschirm werden die installierten proprietären AMD Grafiktreiber aus den Einstellungen, dem Neustart und dem Display immer ausgeschaltet


Ich habe eine Neuinstallation von Ubuntu 13.10 auf meinem System durchgeführt, etwas herumgespielt, bis ich mit dem System vertraut war, und bin dann zum Einstellungsfenster gegangen und habe mich entschieden, die proprietären AMD Grafiktreiber zu installieren (fglrx-updates).

Nach einem Neustart konnte ich nur eine Passphrase eingeben und meine verschlüsselten Partitionen erfolgreich mounten, bevor der Monitor in den Energiesparmodus ging und die Tastatureingabe nicht mehr reagierte.

Ich muss die Änderungen rückgängig machen oder zumindest die Grafiktreiber, die ich installiert habe, erfolgreich installieren.


0
2018-04-08 17:33


Ursprung




Antworten:


Ich habe das Problem behoben und die Ursache dafür war sehr einfach: /boot wurde nicht installiert, als ich die proprietären Treiber installierte!

Sie sehen, ich hatte eine verschlüsselte Installation mit /boot sich auf einem entfernbaren Speicher befinden. Nach dem Antworten zum diese Frage (Wie starte ich Skripte beim Start?), Habe ich mein System eingerichtet, um zu laufen umount /boot direkt vor dem Login-Bildschirm und ich neu gestartet, um sicherzustellen, dass dies zuverlässig funktioniert. Dann habe ich von hier aus die AMD-eigenen Grafiktreiber installiert: Software & Updates window

Nach der Installation und dem Neustart des Systems hatte ich keine Anzeige mehr; der Monitor war im Energiesparmodus, was bedeutete, dass die zuverlässigste Art, dieses Problem zu diagnostizieren, etwas war, das bekanntermaßen funktionierte: eine Live-Ubuntu-Disc und chroot.

Nachdem ich alle erforderlichen Trennwände montiert habe, habe ich chroot in die Installation und lief apt-get remove auf jedem Paket aufgelistet von dpkg -l '*fglrx*'. Von der Ausgabe konnte ich feststellen, dass beim Entfernen einige Dateien in /boot wurden modifiziert und update-initramfs wurde ausgeführt. Ich vermute, dass das wahre Problem gewesen sein könnte /boot während der ersten Installation der proprietären Treiber nicht zugänglich war, lief ich apt-get install fglrx-updates fglrx-amdcccle-updates vor dem Neustart des Systems.

Und es hat funktioniert!

Leute: stellen Sie sicher, dass Sie /boot Partition ist vor dem Installieren oder Entfernen von Software / Updates verfügbar! Du wirst nie wissen wann /boot könnte benötigt werden.


1
2018-04-08 17:33