Frage Was bewirkt, dass eine neu installierte Anwendung beim ersten Start nicht gestartet wird?


Manchmal, wenn ich eine neue Anwendung installiere und ich sie direkt nach der Installation ausführe, bekomme ich für eine Weile den springenden Cursor und eine Schaltfläche in der Task-Manager-Leiste, und dann verschwindet sie einfach und die Anwendung läuft nicht.

Was verursacht das?


0
2017-07-09 01:42


Ursprung




Antworten:


Dies ist wirklich nicht möglich, als Pauschalaussage zu antworten. Aus irgendeinem Grund kann die Anwendung nicht geladen werden. Dies könnte daran liegen, dass eine Abhängigkeit fehlt, noch nicht konfiguriert wurde oder aus einem anderen Grund.

Sie müssen den Namen und die Protokolldateien einer Anwendung hinzufügen, um zu sehen, warum sie nicht gestartet wird. Sie können möglicherweise auch sehen, warum es nicht startet, indem Sie versuchen, es von der Befehlszeile aus zu starten.


1
2017-07-09 02:04



Wie kann es sein, dass Abhängigkeit fehlt? Installiert ein Deb-Paket nicht alle Pakete, von denen es abhängt? Wie unterscheidet sich das Starten von der Befehlszeile? Oder meinst du das als Super User? - M.Sameer
Nun, Sie haben nicht angegeben, was es war oder wo Sie es herbekommen haben. Wenn Sie es nicht von den Repos erhalten haben, dann sind fehlende Abhängigkeiten eine Möglichkeit, da es eine schlechte Verpackung sein könnte. Das Starten von der Befehlszeile würde wahrscheinlich zu dem Terminal den Grund drucken, dass es nicht gestartet wird. - tgm4883
Ja, ich installiere die Anwendungen aus dem Repo und manchmal sogar von der Befehlszeile ausgeführt zeigt keinen Fehler und macht das gleiche Verhalten.In einigen Fällen jedoch als Super-Benutzer das erste Mal löst das Problem und ermöglichen sie normal ausgeführt werden danach. Ich verstehe auch nicht warum. - M.Sameer
Beispiele: Google Picasa 3 und sogar Gimp gestern haben das Gleiche gemacht. - M.Sameer
An diesem Punkt würde ich Syslog überprüfen und sehen, ob dort etwas gedruckt wird. - tgm4883