Frage WI-FI funktioniert nicht (hart blockiert) [duplizieren]


Diese Frage hat hier bereits eine Antwort:

Gestern habe ich Ubuntu 12.04 zum ersten Mal installiert (ich war schon immer ein Windows-Benutzer), als ich im Büro war und ich das Ethernet angeschlossen hatte.

Zuhause verwende ich nur WI-FI. Als ich Ubuntu gestartet habe, habe ich keine Verbindung hergestellt oder versucht, mich mit irgendeinem Netzwerk zu verbinden.

Mit Google habe ich den Befehl gefunden rfkill und das sind die Ergebnisse:

0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

1: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

2: dell-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes

3: dell-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no

Nun, das WI-FI ist durch Hardware blockiert, also habe ich den Befehl ausprobiert rfkill unblock 2 und es hat nicht funktioniert. Da ich selbst mein Broadcom-Modell nicht kannte, fand ich lspci und das Ergebnis für das WI-FI ist:

0e:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

Mein Laptop ist ein Dell Vostro 1520 mit WinXP auch installiert. Danke für die Hilfe!

PS: Es kann auch helfen, wenn ich eintrete System Settings > Network (es kann anders sein, mein Ubuntu ist in Spanisch) "Flugzeugmodus" ist verbunden. Wenn ich versuche, es zu entsperren, geht es an seinen ursprünglichen Platz, nachdem ich das Fenster geschlossen habe und es wieder öffne und wenn ich neu starte.


Update vom Kommentar zu einer Antwort hinzugefügt

Die Broadcom "Additional Drivers" sind aktiviert und aktiviert.


6
2018-06-15 05:40


Ursprung




Antworten:


Broadcom und Ubuntu spielen nicht gut zusammen

Probieren Sie diese Korrekturen aus

Wireless funktioniert nicht mit einem Broadcom BCM4312


4
2018-06-15 05:56



OMG, das ist Geschwindigkeit. Danke, es hat funktioniert! - Fernando
Jedes Mal, wenn ich meinen Computer neu starte, funktioniert es nicht mehr und ich muss die Befehle erneut starten. Gibt es einen Modus, um das zu beheben? - Fernando
Run als Skript beim Start in rc.local? - fleamour


Nachdem ich einige Dinge ausprobiert hatte, löste ich es, indem ich das BIOS zurücksetzte (Lenovo B570).

Wenn Sie den Computer einschalten, drücken Sie F2 um in das BIOS zu gelangen, dann setze es zurück F9 .


3
2018-02-15 14:51



Ich bestätige, BIOS-Reset löst das Problem (Lenovo E430c, Ubuntu 13.10). Die Tasten zum Aufrufen des BIOS können unterschiedlich sein. - Taha Jahangir


Ich fand das und es funktionierte für mich.

So schalten Sie den kabellosen Hardswitch über das Terminal ein:

sudo apt-get remove bcmwl-kernel-source
sudo apt-get install firmware-b43-installer
sudo apt-get install b43-fwcutter

Dann geben Sie diesen Befehl ein, um es zu aktivieren:

cat /etc/modprobe.d/* | egrep '8180|acx|at76|ath|b43|bcm|CX|eth|ipw|irmware|isl| lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3 |rt6|rt7|witch|wl'

Reboot und sehen, ob es an bleibt.


2
2017-07-05 04:26



Das cat ... | egrep ... Befehl gibt nur Informationen aus, es ändert eigentlich nichts. (Sehen man cat und man egrep.) - Eliah Kagan
scheitert mit 14.94 - K7AAY


Zuallererst: Ich bin in einem HP Pavilion dv4-1528la, auf dem Ubuntu 12.04 LTS läuft

Nun, ich muss sagen, dass ich in den letzten 4 Stunden jede mögliche Lösung ausprobiert habe, die ich in jedem Ubuntu-Forum gefunden habe. Und ich habe es endlich geschafft, fand die Lösung in einem geteilt spanisches Forum. Ich hoffe, es ist nicht zu spät, jemandem zu helfen, seinen Weg zu finden.

Also, nach dem Versuch, eine mögliche Kombination mit rfkill im Terminal, mit und ohne sudoIch habe versucht, einige Konfigurationsdateien zu löschen, die ich in anderen "möglichen Antworten" gefunden habe, und im BIOS-Setup nach der Option gesucht, Wireless nicht immer beim Start einzuschalten. Ich habe gegraben und die Antwort gefunden:

Aufgrund eines Fehlers im Linux-Kernel verhält sich rfkill manchmal nicht wie erwartet, und es gibt einige Inkompatibilitäten innerhalb des Linux-Hardware-Controllers und einiger Hardwaregeräte. Lösung empfohlen von dieser Typ ist, Laptop mit einem bootfähigen USB-Stick zu starten und von dort drahtlos zu starten.

Das habe ich gemacht, zum Glück hatte ich den Pendrive, den ich installiert habe Ubuntu 12.04 LTS OS Ich bin jetzt drin, und nach dem Booten konnte ich Wireless direkt über das Menüleisten-Icon starten. Dann ist es nur eine Frage des Ausschaltens, des Entfernens von USB-Stick und dem erneuten Einschalten von der Festplatte. Und es funktioniert wieder, kein Hard-Block mehr.

enter image description here

Pd: Ich rate nur, aber ich denke, was das Problem an erster Stelle ausgelöst hat, ist, dass ich den Laptop mit deaktiviertem Wireless ausgeschaltet habe, und nachdem ich es wieder eingeschaltet hatte, gab es keine Möglichkeit, die Wlan-Hardware zu entsperren, oder zumindest nicht mit meinem Touch-Hardware-Schalter.


0
2018-02-19 05:50





Ich musste einfach den kabellosen Schalter an der Seite meines Laptops drücken, wie ich ihn versehentlich ausgeschaltet hatte. Aber jetzt muss es funktionieren, ich muss auf diesen kleinen Fehler achten. Kostet mich 2 Stunden Suche.


0
2017-07-29 21:14





Broadcom-Hardware erfordert häufig Treiber mit geschlossener Quelle. Haben Sie proprietäre Treiber aktiviert? Gehen Sie dazu zu Systemeinstellungen -> Zusätzliche Treiber

Sind Sie sicher, dass der Hardware-Schalter für Wi-Fi auf Ihrem PC eingeschaltet ist?


-1
2018-06-15 05:53



Es ist tatsächlich eingeschaltet und der Treiber ist aktiviert. - Fernando


echo "options asus_nb_wmi wapf=4" | sudo tee /etc/modprobe.d/asus.conf

Diese Lösung löste das Problem in einem Asus X552C mit einer Broadcom 43225 WLAN-Karte


-2
2018-03-21 10:31



OP hat kein ASUS. - Pilot6