Frage Lästiges Flackern in 16.04 LTS - Chrome


Ich habe ein Upgrade von 4.4.0 auf 4.4.8 und dann 4.5.2 auf Ubuntu 16.04 LTS 64-Bit durchgeführt, und es passiert immer noch.

Bei 4.5.2 ist es noch häufiger und hauptsächlich in Chrome (habe noch nicht Firefox oder Oper versucht). Jedes Mal, wenn ich eine neue Webseite öffne. Irgendeine Möglichkeit, das zu beheben, oder ist es ein Fehler?

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
04:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus XTX [Radeon HD 8890M / R9 M275X/M375X] (rev 81)

Prost.


196
2018-05-03 06:31


Ursprung


Dasselbe erfahre ich auf Ubuntu 14.04.4 - Billal Begueradj
Ich habe auch das gleiche Problem, vor allem während der Verwendung von Facebook. Das ist zu nervig. - sgiri
Versuchen --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers   einige zusätzliche Informationen hier: productforums.google.com/forum/#!topic/chrome/... - Postadelmaga
Googler hier. Dieser Fehler wird im Chromium Issue Tracker unter verfolgt # 606152 - Flackern auf Intel mit One-Copy Uploads. - Dan Dascalescu
Ich wechselte zum HWE-Stack (Kernel 4.8 und X-7.7). Es hat den Flickring gestoppt. Es gibt ein Problem mit i915 (Intel HD Grafiktreiber) in der Kernel 4.4-Serie. - Manoj Sawai


Antworten:


Nach einigen Recherchen fand ich eine Lösung für dieses Problem. Es funktioniert jetzt für mich.

Ich habe die Hardwarebeschleunigung für meinen Browser deaktiviert

Settings > Advance Settings > System > uncheck the hardware acceleration

Hoffe, das funktioniert auf Ihrer Maschine.


ich benutze google-chrome-stable Version 50.0.2661.94 (64-bit) auf Ubuntu 16.04

-----BEARBEITEN----

Wenn Sie Scroll-Lag und Bildschirmabriss feststellen. Tun Sie wie von vorgeschlagen Amos Folarin im Kommentar unten:

Gehe zu: chrome://flags/#smooth-scrolling und Aktivieren Sie es.


186
2018-05-05 17:54



Ich habe das ausprobiert, behebt das Problem, aber mein Scrolling Lag und der Bildschirm reißen. - Mookey
Dies sollte wirklich nicht akzeptiert werden, da es keine Lösung ist, es ist definitiv ein Workaround. - theV0ID
Dies hat keinen Einfluss auf das Flackern für mich. - DavidJ
Diese Lösung funktionierte bei meinem XPS13 9343, das Flackern hörte definitiv auf oder ist nicht spürbar. Ich probierte auch die andere hier vorgeschlagene Lösung chrome: // flags / # enable-gpu-rasterization auf 'Force-enabled for all layers', aber das hat nicht funktioniert, nur die Hardwarebeschleunigung in Chrome zu deaktivieren schien zu funktionieren. Aber stimme @ theV0ID zu, dass es keine Idee ist. - Amos Folarin
Versuchen Sie auch, chrome: // flags / # smooth-scrolling für reibungsloses Scrollen zu aktivieren. Ich benutze XPS13 + Ubuntu16.04 funktioniert gut mit Hardware-Option deaktiviert - Amos Folarin


Ich hatte das gleiche Problem, die GPU-Rasterung auf "Für alle Ebenen erzwingbar aktivieren" scheint endlich zu funktionieren:

Chrome Flags: GPU rasterization


158
2017-08-08 07:52



Quicklink: chrome: // flags / # enable-gpu-Rasterisierung - JohannesNE
hat auch für mich gearbeitet. - Sufiyan Ghori
Es funktioniert nicht mehr, das Flimmern ist zurück, ich denke nach dem Upgrade auf Chrome Version 53.0.2785.92 (64-Bit) - Omid
Dadurch wird das Flackern drastisch reduziert, aber es ist immer noch im Google Inbox vorhanden (momentan der einzige Ort, an dem ich es sehe). - TiGR
Funktioniert, aber jetzt wird nur die linke obere Ecke einiger Bilder angezeigt. Was es für mich war, war chrome: // flags / # ignore-gpu-blacklist - Jasny - Arnold Daniels


Öffnen Sie ein Terminal und geben Sie folgenden Befehl ein:

sudo nano /usr/share/applications/chromium-browser.desktop

und scrolle nach unten, bis du zu dieser Zeile kommst:

Exec= chromium-browser

Fügen Sie dann diese zwei Parameter hinzu

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

Drücken Sie Strg + O zum Speichern und Strg + X zum Beenden.

Dann geben Sie diesen Befehl ein:

sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

und füge diese Zeilen hinzu

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

Drücken Sie Strg + O und dann Strg + X.

Öffnen Sie Chromium und schreiben Sie in die Adressleiste: chrome://flags/ und gib ein.

  • Aktivieren-Nullkopie
  • Aktivieren Sie Software-Rendering-Liste überschreiben
  • Aktivieren Sie 2D-List-Canvas anzeigen

Öffnen Sie abschließend die Chrome-Einstellungen und klicken Sie auf:

  • Verwenden Sie die Hardwarebeschleunigung, wenn verfügbar

38
2017-07-27 08:10



Arbeitete an meinem Dell XPS 15 95050 Intel® Core i7-6700HQ CPU @ 2.60GHz Intel® HD Graphics 530 (Skylake GT2). - Prydie
In meinem Fall (nachdem ich mehrere Lösungen ausprobiert habe) habe ich einfach die von Ihnen erwähnten Flags aktiviert (zero-copy, Override Software Rendering List, Display 2D List Canvas) und es scheint, es (auf Intel HD Graphics) repariert zu haben. - Nahuel
Die beiden Befehlszeilenschalter (Workarounds deaktivieren / native GPU - Speicherpuffer aktivieren) scheinen nicht mehr zu funktionieren, aber das Erstellen der 20-intel.conf Datei funktionierte für mich! Auch aktiviert gpu Rasterisierung (nicht sicher, ob es wichtig ist). - terabaud
Die einzige Lösung für mich. Vielen Dank - Darkside
Einfach hinzufügen 20-intel.conf arbeitete für mich - musste nichts anderes tun. - Vadi


Ich habe es wie folgt festgelegt:

sudo apt-get purge xserver-xorg-video-intel

dann neu starten. Dies ist darauf zurückzuführen, dass Intel-Treiber in modesetting verschoben wurden. Für weitere Informationen siehe dieser Kommentar im Chrom-Bug-Thread.


37
2017-08-19 14:25



Ich ging die chrome flags Route und ging dann diese Route statt und setzte die Flags auf die Standardeinstellungen zurück und löschte das Intel-Zeug. So weit, ist es gut. - Sethen
Vielen Dank. Ich habe einen Intel NUC, der ein paar Jahre alt ist und ein paar Updates durchgemacht hat. Es ist am 16.04.2, aber Ihr Vorschlag fand Pakete zu löschen. Es blinkt nicht mehr (mein HDMI-Video blinkt nach einigen Updates mit ca. 1 oder 2 Hz; ich dachte, es hätte nach acht Jahren einen Hardwarefehler ergeben). - Tim Richardson
Diese Antwort sollte viel höher sein! - Galgalesh
Das ist es? Es funktioniert einwandfrei !!! Total unterschätzte Antwort. Vielen Dank Kumpel! - uloco
Vielen Dank! Das hat das Problem für mich behoben. Ihre Antwort sollte ein paar Punkte höher sein als sie ist. - Anthony D.


Keine dieser Antworten schien mir zu helfen. Was ich am Ende gemacht habe scheint es repariert zu haben (Meine Referenz war diese Seite http://www.bang-olufsen.com/ was flackerte wie CRAZY und jetzt funktioniert es reibungslos) ist das:

1.- Navigiert zu chrome://gpu/. Das ist, was es gezeigt hat:

enter image description here

2.- Ich habe versucht, die Probleme nacheinander zu beheben. In meinem Fall hat das Aktivieren dieser Flags einige von ihnen behoben: GPU rasterization, Override software rendering list. Dann zeigte es sich so:

enter image description here

3.- Ich habe den Desktop-Launcher bearbeitet und die Parameter hinzugefügt --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers.

4.- Danach werden keine Probleme mehr erkannt, alles zeigt sich als "hardwarebeschleunigt" und vor allem kein Flimmern mehr:

enter image description here

Wenn Sie zuerst die Parameter zum Launcher hinzufügen, sollte die Liste der Probleme kürzer sein und es wird wahrscheinlich einfacher sein, herauszufinden, welche Flags Ihnen bei den verbleibenden Problemen helfen.


24
2017-09-14 12:29



Dies ist eine gute Referenz. Ich habe es verwendet, um mein Problem mit Firefox zu lösen, wo es einfach gelöst wurde, indem Sie in den erweiterten Einstellungen das Kontrollkästchen "Hardwarebeschleunigung verwenden" deaktivieren. - Bach
Das hat das Flackern für mich reduziert, aber es passiert immer noch oft ... - addison


Mit Chrome Version 51.0.2704.103 (64-Bit) die Flags

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

arbeite nicht mehr.

Der beste Weg, um zu Chrome 50 (Version 50.0.2661.86 (64-Bit)) zurückzukehren, ist hier eine Anleitung, wie Sie zurücktreten können: Wie erniedrige ich Google Chrome? 

Wichtig ist, dass wir Druck auf Google ausüben, um dieses Problem zu beheben, für den Fehler in Chromium und auf der Google-Produktseite zu stimmen:

https://bugs.chromium.org/p/chromium/issues/detail?id=606152

https://productforums.google.com/forum/#!topic/chrome/CtKF2BiskT8;context-place=forum/chrome


7
2018-06-19 08:02



Funktioniert nicht für mich. - ComBin
@ComBin: Hast du versucht, zurück zu v50 zu gehen und die Flags benutzt? Folgen Sie jedoch dem Link zum Chrom-Bug, es gibt viele verschiedene Lösungsvorschläge, um diese aktuellen Versionen von Chrom / -ium zum Laufen zu bringen. - user157697
ich will nicht v50, danke. Ich bin der beste Weg, um es zu beheben, siehe meine Antwort unten. - ComBin
Aha, im Chrom-Bug meinten die Jungs, dass dies massive Leistungsprobleme hätte. Allerdings werde ich einige Vorschläge von den Chromwanzen ausprobieren, wenn ich die Zeit habe, soweit ich verstanden habe Chrom ist nur das Symptom nicht die Ursache. Ich werde Sie auf dem Laufenden halten, wenn ich etwas besseres / anderes finde. Prost. - user157697


chrome://flags/ > GPU rasterization > Enable,

Das hat endlich für mich funktioniert! Fanden Sie es am Ende dieses Google Formulars! https://productforums.google.com/forum/#!msg/chrome/CtKF2BiskT8/dLXKfU2XAQAJ


5
2017-10-16 20:44