Frage Internet funktioniert nach einiger Zeit nicht mehr [geschlossen]


Nachdem ich mich bei Ubuntu eingeloggt habe, funktioniert das Internet für einige Zeit (für ungefähr 45 Minuten oder so) gut, aber dann hört es plötzlich auf zu arbeiten. Ich bin jetzt am 14.04 und habe ein ähnliches Problem in 13.10.

Ich bin mit Wifi verbunden, aber ich habe das gleiche Problem, wenn Sie mit einem Ethernet-Kabel verbunden sind.

Bitte fragen Sie mich nach Details, die bei der Diagnose helfen können.

Ich bekomme ein Dialogfeld mit der Meldung "Ein Systemproblem ist aufgetreten" und das Internet stürzt ab.

Von /var/log/syslog -

cat /var/log/syslog | grep NetworkManager | grep error
Apr 10 01:50:55 <machine-name> NetworkManager[832]: <warn> error monitoring device for netlink events: No buffer space available
Apr 10 02:06:36 <machine-name> NetworkManager[760]: <error> [1397113596.497261] [nm-dns-dnsmasq.c:400] update(): dnsmasq owner not found on bus: Could not get owner of name 'org.freedesktop.NetworkManager.dnsmasq': no such name

Von dmesg | grep -e eth0 -e IPv -e dns -e DNS -

dmesg | grep -e eth0 -e IPv -e dns -e DNS
[    0.920865] Key type dns_resolver registered
[    0.976650] r8169 0000:03:00.0 eth0: RTL8168evl/8111evl at 0xffffc90000c2a000, 18:67:b0:27:02:c6, XID 0c900800 IRQ 42
[    0.976652] r8169 0000:03:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[   23.017231] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   34.125468] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   34.125715] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   34.672505] r8169 0000:03:00.0 eth0: link down
[   34.672562] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   34.672927] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   41.473249] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

6
2018-04-10 06:35


Ursprung


Siehst du nichts in / var / log / syslog? - alci
@alci Bitte sehen Sie diese Pastebin - pastebin.com/AYwq3wv9 Ich denke, das Problem ist <info> (wlan0): IP6 addrconf timed out or failed. - theharshest
@alci Überprüfen Sie auch den aktualisierten Inhalt in dem Beitrag von /var/log/syslog - theharshest
@ david6 kann ich nach irgendeinem Schlüsselwort in dmesg grep, das mir helfen würde, das Problem zu finden? - theharshest
Hier ist ein ähnliches Problem (mit dem gleichen Netzwerkadapter r8169): bbs.archlinux.org/viewtopic.php?id=117717 und auch hier ubuntuforums.org/archive/index.php/t-1766962.html . Starten Sie Windows gleichzeitig? Scheint dann ist die Karte in problematischem Zustand verlassen ... - alci


Antworten:


Ich denke, der Treiber, den Sie verwenden, ist fehlerhaft

Überprüfen Sie zusätzliche Treiber und installieren Sie den besten verfügbaren Treiber. Wenn dies das Problem hervorragend löst. wahrscheinlich hast du das schon gemacht? Ich sehe, dass Ihr kabelloser Chip als RTL8168evl / 8111evl gemeldet wird. Ich glaube nicht, dass dies richtig ist, da Realtek dieses Modell nicht zu machen scheint. Identifizieren Sie den Wireless-Chip entweder durch Rücksprache mit dem Hersteller Ihres Laptops oder durch Sichtprüfung.

Laden Sie den richtigen Linux-Treiber herunter http://www.realtek.com/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=21&Level=4&Conn=3

kompilieren und installieren gemäß den Anweisungen des Herstellers.


2
2018-04-27 22:50





Dies könnte auch das Problem beheben.

Dies ist ein sehr, sehr nerviger Bug! Was muss aussortiert werden ...

Öffnen Sie den Terminator und geben Sie die folgenden Zeilen ein:

sudo modprobe ath5k nohwcrypt
sudo sh -c "echo 'options ath5k nohwcrypt' >/etc/modprobe.d/custom-wireless.conf"
sudo apt-get remove libnss-mdns

0
2017-07-29 00:33