Frage Mausrad scrollt in umgekehrter Richtung


Mausrad scrollt in umgekehrter Richtung. ich ging in Systemeinstellungen> Maus & Touchpad> Natürliches ScrollenAber egal welche Option ich wähle, es scrollt immer noch in der für mich falschen Richtung.

Ich habe einige andere Schritte gemacht, wie die Edition .map* Datei in meinem Home-Verzeichnis, aber es hat auch nicht funktioniert.

Ich habe den gesamten Laptop neu gestartet, also könnte etwas daran hängen bleiben, aber nein, es bleibt in der anderen Richtung scrollen.


5
2018-04-01 14:32


Ursprung


Ubuntus Einstellung "Natural Scrolling" scheint zur Zeit, um das Verhalten des Touchpads nur zuverlässig zu beeinflussen. Um "Natural Scrolling" auf das Mausrad anzuwenden (oder um diese Einstellung zu entfernen, wenn jemand sie vorher auf Ihrem Laptop angewendet hat), verweise ich Sie darauf verwandte Fragebesonders die Antwort von D. Charles Pyle zur Verfügung gestellt. - theDrake


Antworten:


Sie müssen xinput verwenden, um Natural Scrolling zu deaktivieren.

Offenes Terminal:

~$ xinput list

Die Ausgabe sollte etwa so aussehen:

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳         USB Keyboard                      id=10   [slave  pointer  (2)]
⎜   ↳ ImPS/2 BYD TouchPad                       id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳         USB Keyboard                      id=9    [slave  keyboard (3)]
    ↳         USB Keyboard                      id=12   [slave  keyboard (3)]

Schau, TouchPad ID = 11.

~$ xinput list-props 11

Die Ausgabe sollte etwa so aussehen:

Device 'ImPS/2 BYD TouchPad':
    Device Enabled (135):   1
    Coordinate Transformation Matrix (137): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Accel Speed (274): 0.000000
    libinput Accel Speed Default (275): 0.000000
    libinput Accel Profiles Available (276):    1, 1
    libinput Accel Profile Enabled (277):   1, 0
    libinput Accel Profile Enabled Default (278):   1, 0
    libinput Natural Scrolling Enabled (271):   1
    libinput Natural Scrolling Enabled Default (272):   0
    libinput Send Events Modes Available (255): 1, 0
    libinput Send Events Mode Enabled (256):    0, 0
    libinput Send Events Mode Enabled Default (257):    0, 0
    libinput Left Handed Enabled (279): 0
    libinput Left Handed Enabled Default (280): 0
    libinput Scroll Methods Available (281):    0, 0, 1
...

Schauen Sie sich das an, libinput Natural Scrolling Enabled (271): 1.

Sie müssen es auf 0 setzen.

xinput set-prop 11 271 0

8
2017-08-22 17:37



Arbeitete an Gnome 16.10. Leider überlebt es einen Neustart nicht und die Geräte- und Eigenschaften-IDs ändern sich. Ich habe auch "Enabled Default" auf "0", aber es schaltet sich trotzdem wieder ein. - robsn
Hinzufügen xinput set-prop 11 271 0 zu .bashrc. - Grisotto
Leider funktioniert das nicht so id kann sich beim Neustart ändern. Manchmal ist es id 10, manchmal id 11. - robsn


Diese Antwort basiert weitgehend auf die Antwort von Grisotto Das funktioniert, überlebt aber keine Neustarts auf meiner Maschine.

Dies automatisiert den Prozess nahezu:

Holen Sie sich den Namen Ihres Zeigegeräts:

$ xinput list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ VirtualBox mouse integration              id=9    [slave  pointer  (2)]
⎜   ↳ ImExPS/2 BYD TouchPad                     id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Sleep Button                              id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]

In meinem Fall ist es ImExPS/2 BYD TouchPad obwohl es eine Maus ist. Als nächstes erhalten Sie die Eigenschaft ID von libinput Natural Scrolling Enabled:

$ xinput list-props 11  # use the id or the name of the pointer device
Device 'ImExPS/2 BYD TouchPad':
    Device Enabled (119):   1
    Coordinate Transformation Matrix (121): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Accel Speed (271): 0.000000
    libinput Accel Speed Default (272): 0.000000
    libinput Accel Profiles Available (273):    1, 1
    libinput Accel Profile Enabled (274):   1, 0
    libinput Accel Profile Enabled Default (275):   1, 0
    libinput Natural Scrolling Enabled (261):   0
    libinput Natural Scrolling Enabled Default (262):   0
    libinput Send Events Modes Available (241): 1, 0
    [snip]

Hier ist es 261. Verwenden Sie nun den Namen Ihres Zeigegeräts (da sich die ID bei Neustarts ändern kann) und die Eigenschaften-ID (bleibt gleich) und setzen Sie diese Zeilen in Ihre ~/.bashrc. In meinem Fall ist es:

device=$(xinput list --id-only 'ImExPS/2 BYD TouchPad')
xinput set-prop $device 261 0

Ich muss immer noch ein Terminal bei jedem Boot als mein öffnen und schließen .bashrcwird beim Booten nicht gelesen und funktioniert nicht .profile aber das sind nur drei Klicks.


1
2017-12-07 13:19



Ich habe meine Xinput-Befehle zu ~ / .xinitrc Datei hinzugefügt. Es wird gelesen, wenn Sie sich bei Ihrer xsession anmelden (zB von Ihrem xdm-Bildschirm). Bitte überprüfen Sie "man xinit" und finden Sie XINITRC für weitere Informationen. - MattAPiroglu


In meinem Fall gab es keine Natural Scrolling Einstellung, aber stattdessen a Evdev Scrolling Distance.

Zuerst: Finde das Gerät:

xinput list

Da sich dies bei jedem Boot ändert (siehe Antwort von robsn), hole die ID nach Name und speichere diese in eine var:

device=$(xinput list --id-only 'Logitech USB Laser Mouse')

Überprüfen Sie, ob Sie wirklich Eigentum haben Edev Scrolling Distance:

xinput list-props $device

Und dann setze es mit:

xinput set-prop $device "Edev Scrolling Distance" -1 1 1

Um dies bei jedem Start zu ermöglichen, fügen Sie den Befehl hinzu device= und set-prop Befehle an Ihre ~/.xsessionrc Datei.


1
2018-01-25 05:50





Deaktivieren Sie das natürliche Scrollen. Deaktivieren Sie das Scrollen mit zwei Fingern.


0
2018-04-01 14:51





Ich benutzte xinput, um die Richtung des Rades auch umzukehren. Die Eigenschaft der Radrichtung in meinem PC ist Evdev Scrolling Distance (272). Außerdem müssen Sie möglicherweise Nautilus beenden und Nautilus neu starten:

    nautilus -q
    nautilus -n

um diese Änderung zu speichern.


0
2018-02-21 02:21





Diese Antwort ist eine Automatisierung der Methode von Robsn so dass es bei jedem Booten durchgeführt wird.

Holen Sie sich den Namen Ihres Zeigegeräts:

$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB Optical Mouse                id=9    [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                        id=13   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=14   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ CHICONY HP Basic USB Keyboard             id=10   [slave  keyboard (3)]
    ↳ HP HD Webcam                              id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ HP Wireless hotkeys                       id=15   [slave  keyboard (3)]
    ↳ HP WMI hotkeys                            id=16   [slave  keyboard (3)]

In meinem Fall "Logitech USB Optical Mouse".

Erstellen Sie dann eine Datei namens natural_scrolling.sh in Ihrem Pfad:

#!/bin/bash

device=$(xinput list --id-only 'Logitech USB Optical Mouse'); 
xinput set-prop $device 295 1

exit 0;

(Ersetzen Sie Logitech USB Optical Mouse durch Ihren Mausnamen).

Fügen Sie der Datei Ausführungsberechtigung hinzu. Öffnen Sie anschließend die Startprogramme, und erstellen Sie einen neuen Eintrag, wenn die Zeile "command" auf diese Datei zeigt.

Dies ermöglicht automatisch das natürliche Scrollen für mich.

(Hinweis: Wenn Sie Ubuntu-Tweak verwenden, DISABLE natürlichen Scrollen dort, da es scheint, mit dieser Methode zu kollidieren - ich hatte es aktiviert und es verursacht einige Anwendungen, um den anderen Weg zu scrollen).


0
2018-04-21 16:32





Danke für die Erwähnung von Natural Scroll, Ubuntu Tweaks hat einen Schalter für das, (dass ich drückte, vorausgesetzt es würde das Scrollen weicher oder etwas machen) Niemals würde diese Funktion mit diesem Namen annehmen.

Auch für die Leute, die das lesen, die diese Option über die GUI schalten wollen. Sie können Ubuntu Tweaks installieren und die Option unter Tweaks> Verschiedenes> Natural Scrolling finden.

Diese Seite hat ein .deb für Ubuntu Tweaks. http://ubuntuhandbook.org/index.php/2016/05/install-ubuntu-tweak-in-ubuntu-16-04/


0
2017-07-31 07:40