Frage Das Home-Verzeichnis konnte nicht geöffnet werden


Thunar gibt einen Fehler zurück, wenn ich versuche, mein Home-Verzeichnis zu öffnen:

Fehler beim Öffnen des Verzeichnisses "matt". Fehler beim Angeben der Datei   '/home/matt/.gvfs': Transportendpunkt ist nicht verbunden.

Gibt es eine Möglichkeit, das ohne Neustart zu beheben? Dieser Fehler scheint beim Abmelden und erneutem Anmelden ausgelöst zu werden, wenn mehrere Benutzer angemeldet sind.


5
2018-01-10 01:51


Ursprung




Antworten:


Es gibt einen Fehlerbericht hier:

https://bugs.launchpad.net/ubuntu/+source/thunar/+bug/754618

Sie können versuchen, das Verzeichnis oder einen Neustart zu deaktivieren.

sudo umount ~matt/.gvfs

8
2018-01-10 01:57



Ich werde auch ein paar Mal pro Jahr in diesen Fehler geraten. Das umount hat nicht für mich gearbeitet; Alles was passiert, ist, dass beim Neustart von Thunar der Fehler weg ist, aber mein Home-Verzeichnis sieht leer aus. Hinzugefügt am Edit: Ich öffnete ein neues Thunar-Fenster und ging direkt in ein Unterverzeichnis meines Home-Verzeichnisses, das sichtbar war. Dann bis zum Home-Verzeichnis, das jetzt sichtbar war. Also die umount hat funktioniert, aber nicht sofort. Seltsam. - Teemu Leisti


Ich habe das gleiche Problem mit Xubuntu 12.04 LTS Vanille (Xfce 4.8) und auch mit Xubuntu 12.04 mit Xfce auf 4.10 aktualisiert; beide mit Home-Ordner verschlüsselt

Dies ist ein Fehler, da ich von Gnome und Unity Ressourcen verbrauchende und Nautilus Bug abstürzt Ubuntu 12.04 LTS weglaufen

Nachdem ich über den Bug gelesen habe, dass Xfce .gvfs beim Abmelden nicht ausmist, habe ich herausgefunden, dass es beim Login automatisch ausgehängt werden kann, wie ich es manuell gemacht habe.

Das habe ich gemacht und bisher funktioniert es:

Ich habe eine Datei mit Leafpad in meinem Home-Verzeichnis erstellt: .umountgvfs.sh

hat das folgende Skript zum Aushängen von .gvfs platziert

#!/bin/bash
/bin/fusermount -zu "$HOME/.gvfs"

Im Terminal gab es eine Ausführungsgenehmigung

chmod 777 .umountgvfs.sh

Dann habe ich eine Autostart-Anwendung erstellt und das entsprechende Skript unter: Konfiguration -> Konfigurationsverwaltung -> Sitzungsstart -> Autostart-Anwendungen ausgewählt

Name: umountgvfs Kommentar: Skript zum Unmounten von .gvfs beim Anmelden Befehl: /home/YOURUSER/.umountgvfs.sh

Da dies die Probleme meistens löste, aber nicht immer, vermutete ich, dass das Skript vor der Zeit aufgerufen wurde, also fügte ich einen Schlafbefehl hinzu (bash -c "sleep 5; command") wobei 5 die Sekunden ist, die das Skript verzögert bei der Anmeldung, im Terminal:

leafpad /home/YOURUSER/.config/autostart/umountgvfs

und editiert in der Exec-Zeile, die folgendes hinzufügt: bash -c "sleep 5;"

[Desktop Entry]
Encoding=UTF-8
Version=0.9.4
Type=Application
Name=umountgvfs
Comment=script to unmount .gvfs on login
Exec=bash -c "sleep 5; /home/YOURUSER/.umountgvfs.sh"
OnlyShowIn=XFCE;
StartupNotify=false
Terminal=false
Hidden=false

Ersetzen Sie YOURUSER durch Ihren Benutzernamen.

Zusätzliche Ressourcen:

Das Skript verzögern: http://ubuntuforums.org/showthread.php?t=1119945

hoffe das hilft


2
2018-01-22 01:43