Frage GLib-GIO-Message und Gtk-WARNING auf Ubuntu 16.04


Ich versuche, ein Python-Skript auf meinem Ubuntu 16.04 auszuführen. Ich habe folgende Nachricht erhalten:

GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

(python:14505): Gtk-WARNING **: GModule (/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-ibus.so) initialization check failed: GLib version too old (micro mismatch)

(python:14505): Gtk-WARNING **: Loading IM context type 'ibus' failed

(python:14505): Gtk-WARNING **: GModule (/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-ibus.so) initialization check failed: GLib version too old (micro mismatch)

(python:14505): Gtk-WARNING **: Loading IM context type 'ibus' failed

(python:14505): Gtk-WARNING **: GModule (/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-ibus.so) initialization check failed: GLib version too old (micro mismatch)

(python:14505): Gtk-WARNING **: Loading IM context type 'ibus' failed

Es scheint den Code nicht zu beeinflussen, aber ich frage mich, warum ich plötzlich diese Fehlermeldung habe. Jemand hat eine Idee, welche Vorsorgeuntersuchungen ich machen sollte?


5
2017-08-02 11:57


Ursprung


Soweit ich weiß, sind dies Warnungennicht Fehler und passiert mit jedem GUI-Programm, das Sie vom Terminal aus starten. - grooveplex
Diese Warnungen sollten immer noch betrachtet werden. Nur weil sie auf der Kommandozeile nicht bedeutungslos sind. Es scheint, dass die Versionen von python-gobject, die in 16.04 enthalten sind, nicht mit den Versionen von GLib übereinstimmen. - andlabs
Was passiert, wenn du rennst? pastie.org/10937021? Verwenden Sie ibus für alternative Eingabemethoden? (Offene Frage.) - andlabs
Nach einigem Feedback kann ich an dieser Stelle nur vorschlagen, einen Fehlerbericht auf Launchpad zu schreiben. Viel Glück. - andlabs
Dasselbe Problem ist heute Morgen auf meinem Ubuntu 16.04-System passiert. Keine alternativen Eingabemethoden, soweit ich weiß. Der mit @andlabs verbundene Pastie läuft nicht auf meinem System - ich habe keinen GTK installiert. - Gabriel


Antworten: