Frage Tastatursperre in IntelliJ IDEA unter Ubuntu 14.04


Könntest du mir mit der Hölle eines seltsamen Problems helfen? Ich benutze Intellij IDEA 13 auf Ubuntu 14.04, und von Zeit zu Zeit sperrt meine Tastatur komplett (yep, komplett, es geht nicht um Shortcuts) in IDEA. Ich kann in IDEA immer noch mit meiner Maus alles machen, was ich will, auch kann ich die Tastatur überall sonst außer IDEA benutzen. Und es kann nur durch einen Neustart von IDEA behoben werden.

Kann jemand bitte einen Hinweis geben?


165
2017-07-24 06:58


Ursprung


Kann es sein, dass Ihre Tastatur einfach von einem Feld in IntelliJ erfasst wird? Ist es eine zufällige Sache oder löst es etwas spezifisch aus? - Ruraj
Ich glaube nicht, dass ein Feld so eine Tastatur erfassen kann, aber ich werde es beim nächsten Mal genauer prüfen. Und es scheint eine zufällige Sache zu sein. - Treble Snake
Mein Kollege und ich erleben genau dasselbe (dasselbe OS und IntelliJ 13.1.4). Ich muss IntelliJ alle paar Stunden neu starten (ich kann Alt-F4 benutzen) - extrem nervig. Ich finde es auch völlig zufällig. Das letzte Mal war ich gerade dabei, eine HTML-Datei zu bearbeiten. Nicht beim Drücken einer Tastenkombination. - Halle Knast
Ich hatte zwei Instanzen von IntelliJ und beide froren. Ich weiß nicht, ob es relevant ist, aber wenn ich die IDE schließe, dauert das Abtrennen eines laufenden Anwendungsservers normalerweise sehr kurze Zeit. Nach einem Einfrieren muss ich das abbrechen, weil es nicht zu beenden scheint. - Halle Knast
Dies ist ein Java-Problem, das andere Java Swing-GUI einschließlich der SOAP-Benutzeroberfläche betrifft. "ibus-daemon -rd" behebt das Problem ebenfalls - rjdkolb


Antworten:


Da ist ein ein offenes Problem in Jetbrains Sie verfolgen für Intellij Idee das empfehlen zwei Lösungen:

  1. Die Tastatureingabe kann durch einen Neustart des IBus-Daemons von einer Konsole aus entsperrt werden:

    ibus-daemon -rd
    
  2. IBus kann für IDEA deaktiviert werden, indem env deaktiviert wird. variable XMODIFIERS, aber die Fähigkeit, nationale Charaktere in IDEA einzugeben, geht verloren:

    XMODIFIERS="" idea.sh
    

Ich habe die zweite benutzt und mein Problem behoben.


206
2017-10-18 16:50



> "ibus-daemon -rd" von einer Konsole. Das hat funktioniert! Großartig - vielen Dank!) - Treble Snake
6 Monate später wird Option 1 nicht mehr empfohlen, da dies zu einem JVM-Absturz führen kann: / - mike
Was meinst du mit nationalen Charakteren, @Mike, es funktionierte für mich heute am 2. Juni - Abderrahmane TAHRI JOUTI
"ibus-daemon -rd" - Ich überlege ernsthaft, das auf meinen Arm zu tätowieren. - Balázs Mária Németh
Letzte Aktualisierung des Problems (17. Juni 2015) empfiehlt zu export IBUS_ENABLE_SYNC_MODE=1 - Nacho Coloma


Ich konnte es mit dem, was ich gefunden habe, lösen Hier das fügt im Grunde hinzu export XMODIFIERS="" auf idea.sh


14
2018-03-05 16:45



scheint hier zu arbeiten! - Marc Hauptmann


Für ein permanente Lösung, das  01.10.2015 Update zum Thema empfiehlt zu:

Entweder IBus auf Version 1.5.11 upgraden oder hinzufügen export IBUS_ENABLE_SYNC_MODE=1 zu deinem ~/.profile, dann starte eine Sitzung neu.

Alternativ können Sie IBus bei deaktivieren System Settings | Language Support | Keyboard input method.

IDEA 15 zeigt eine Warnung an, wenn eine inkompatible Version von IBus verwendet wird.


5
2017-11-30 11:53





Ich habe es ausprobiert und es funktioniert so weit, aber ich werde es aktualisieren, wenn es wieder einfriert. Ich habe auf youtube einen Vorschlag gesehen, der vorschlägt, iBus abzuschalten, was sich vor allem dadurch zu stören scheint, dass man die Tastenkombination Strg + Leerzeichen benutzt, um die Spracheinstellungen zu ändern. Sie können das tun, indem Sie gehen zu:

Sprachunterstützung> Tastatur-Eingabemethoden-System> Keine

enter image description here

**** UPDATE *****

Nach einiger Zeit lief diese Technik immer noch nicht, da ich ständig fror. Ich denke, ich werde mich jetzt an die folgende Problemumgehung halten, um ibus neu zu starten, was ein wenig unbequem ist, aber was können Sie tun?

ins Terminal gehen

Art:

ibus-daemon -rd

1
2018-04-05 00:33



Vielen Dank, ibus-daemon -rd ist was ich gesucht habe. - Lambart