Frage Wie kann ich Adobe AIR installieren?


Ich bin ein starker Benutzer bestimmter Anwendungen, die auf AIR basieren.

Es scheint, dass AIR die Unterstützung für Linux eingestellt hat. Selbst die älteren Versionen in den Adobe AIR-Archiven scheinen nur 32-Bit-Linux-Distributionen zu unterstützen, und ich bin derzeit auf 64 Bit.

Gibt es sogar eine geringe Möglichkeit, dass ich unter diesen Bedingungen AIR laufen lassen könnte? Wenn ja, können Sie mir bitte sagen, wo ich eine detaillierte Schritt-für-Schritt-Installation dafür bekommen kann?


153
2017-12-13 14:51


Ursprung


Beachten Sie, dass Adobe die Unterstützung für AIR unter Linux beendet hat. Adobe bewegt sich auch weg von Legacy-Technologien wie Flash und AIR in HTML5, was die Zukunft ist. - Anonymous
Ich habe Adobe Air aus der .deb-Datei in oneric installiert - Tachyons


Antworten:


Ich brauche Air für etwa drei Programme - YNAB, LongTailPro, Xtend:

  1. Laden Sie die neueste Version Air 2.6.0 für Linux auf Ihren Desktop herunter:

  2. Strg + Alt + T zum Öffnen des Terminals

  3. sudo apt-get install ia32-libs  - (32bit Müll, wenn Sie dies in x64 Ubuntu ausführen möchten; wenn Sie Probleme haben, sehen Sie "Hängt davon ab: ia32-libs-multiarch, aber es ist nicht installierbar" - Lösung)

  4. cd Desktop (ändern Sie Richtung zu Desktop dir.)

  5. chmod +x AdobeAIRInstaller.bin (Modus wechseln - Berechtigung ausführen ja)

  6. ./AdobeAIRInstaller.bin (Nachdem Sie die Adobe Air-Lizenz akzeptiert haben, werden Sie nach Ihrem Passwort gefragt; es muss root-zugreifbar sein, um es zu installieren)

Vielleicht bekommst du nach dem letzten Befehl einen Fehler?

Entschuldigung, ein Fehler ist aufgetreten. Adobe AIR konnte nicht installiert werden. Installieren Sie entweder Gnome Keyring oder KDE KWallet, bevor Sie Adobe AIR installieren.

Dies kann behoben werden:

  • Geben Sie in einem Terminal (Standardverknüpfung: Strg + Alt + T) Folgendes ein:

    locate libgnome-keyring.so
    
  • Das ist mein Ergebnis (Sie könnten anders sein):

    /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0
    /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0
    
  • Wie unten von @jmendeth empfohlen, ist es am einfachsten, dem Installationsprogramm mitzuteilen, wo diese Dateien zu finden sind: LD_LIBRARY_PATH:

    • Für 32-Bit Ubuntu (getestet am 12.04):

      LD_LIBRARY_PATH=/usr/lib/i386-linux-gnu ./AdobeAIRInstaller.bin
      
    • Für 64-Bit-Ubuntu wäre die Befehlszeile wahrscheinlich:

      LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu ./AdobeAIRInstaller.bin
      

Wenn der LD_LIBRARY_PATH-Trick nicht funktioniert, können Sie Folgendes versuchen:

  • Erstellen Sie eine symbolische Verknüpfung zu Ihren Standortstrings, die Sie mit den vorherigen Befehlen gefunden haben:

    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
    
  • Verwenden Sie folgende Befehle für 32-Bit-Systeme:

    sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
    sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
    
  • Wiederholen Sie dann die Schritte 4 und 6 (5 überspringen, da sich die Berechtigung zum Ausführen der Datei nicht geändert hat).

  • Entfernen Sie symbolische Links nach der Installation von Adobe AIR 2.6.0:

    sudo rm /usr/lib/libgnome-keyring.so.0
    sudo rm /usr/lib/libgnome-keyring.so.0.2.0
    

Referenz:


225
2018-04-09 02:26



Groß! Es ist installiert. Wenn ich jetzt nur ein AIR-Paket installieren kann ... - BrianXP7
Respektiert AIR nicht LD_LIBRARY_PATH? Frage nur' - Alba Mendez
Ich habe ein Konto erstellt, um dieses +1 zu erhöhen - Paul Bellora
Ich kann dir unmöglich genug geben. - Jonah
Es funktioniert nicht auf Xubuntu 13.10 für mich. sudo apt-get install ia32-libs Das Paket ia32-libs ist nicht verfügbar, wird aber von einem anderen Paket verwendet. Dies kann bedeuten, dass das Paket fehlt, veraltet ist oder nur von einer anderen Quelle verfügbar ist. Die folgenden Pakete ersetzen sie jedoch: lib32asound2 lib32z1 lib32ncurses5 lib32bz2-1.0 ./AdobeAIRInstaller.bin /tmp/air.kmEATV/setup: Fehler beim Laden von gemeinsam genutzten Bibliotheken: libgtk-x11-2.0.so.0: Gemeinsame Objektdatei kann nicht geöffnet werden: Nein solche Datei oder Verzeichnis - Slava Fomin II


Ubuntu 13.10, 14.04, 15.04 und 15.10 (64 bit)

  1. Installieren Sie i386-Bibliotheken, die für die erfolgreiche Installation und Ausführung von Adobe Air- und Air-Anwendungen erforderlich sind.

    sudo apt-get install libxt6:i386 libnspr4-0d:i386 libgtk2.0-0:i386 libstdc++6:i386 libnss3-1d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libcanberra-gtk-module:i386 gtk2-engines-murrine:i386
    
  2. Installieren libgnome-keyring0:i386 Paket.

    sudo apt-get install libgnome-keyring0:i386
    
  3. Erstellen Sie symbolische Links zu gnome-keyring, damit Adobe Air es sehen kann.

    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
    
    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0 
    
  4. Laden Sie das Adobe Air-Installationsprogramm von Hier.

  5. Gib die Ausführungsberechtigung und führe dann diese .bin-Datei aus.

    sudo chmod +x AdobeAIRInstaller.bin
    sudo ./AdobeAIRInstaller.bin
    

Quelle

Hinweis für Ubuntu 16.04 (64 Bit)

Installieren Sie das Paket für Ubuntu 16.04 und höher libnss-mdns:i386 anstelle des Pakets lib32nss-mdns. Dies wird das Problem "Paket nicht gefunden Fehler" in Bezug auf das Paket lösen.


43
2018-03-28 23:36



Dieser funktioniert auch für 14.04 - adosaiguas
Gut zu wissen .. Ich werde meine Antwort aktualisieren. - Avinash Raj
Dies funktioniert auch für 15.04 (64bit). Vielen Dank. - Dmitry Wojciechowski
Funktioniert auch für 15.10 (ich benutze Entwicklungsversion) - Yana Agun Siswanto
16.04, hat einen Fehler, dass lib32nss-mdns fehlte. Wenn das Installationsprogramm geöffnet wurde Gtk-Message: Failed to load module "overlay-scrollbar" Gtk-Message: Failed to load module "gail" Gtk-Message: Failed to load module "atk-bridge". Scheint korrekt installiert zu sein. Aber die App, für die ich AIR benötigt habe, benötigt eine neuere Version: / - raphael


Alternativ können Sie eine vordefinierte .deb installieren

Es gibt Air 2.6 (zuletzt unterstützt von Linux) Hier für beide Architekturen (Beide verwenden 32 Bit darunter, aber zumindest funktioniert es). Dank an Prusswan um es aufzuzeigen.

Stellen Sie sicher, dass Sie über 32-Bit-Bibliotheken verfügen, die benötigt werden:

sudo apt-get install ia32-libs

Ich habe den AMD64 (adobeair_2.6.0.19170_amd64.deb) heruntergeladen und auf meinem Computer installiert (am64 mit Precise Pangolin 12.04)

sudo dpkg -i adobeair_2.6.0.19170_amd64.deb

Dann habe ich die Anwendung installiert, die Adobe Air von Anfang an benötigt hat und es hat funktioniert.

Update für Ubuntu 13: 10+,

Wenn ich diese Technik versuche, bekomme ich "Package ia32-libs-gtk ist nicht installiert"

Ich habe nachgeschlagen das Paket und habe versucht, diese Abhängigkeiten und andere verwandte Pakete zu installieren, an die ich direkt denken kann:

sudo apt-get install gtk2-engines:i386 libart-2.0-2:i386 libcairo2:i386 libcanberra-gtk0:i386 libdatrie1:i386 libgail-common:i386 libgconf2-4:i386 libgtk2.0-0:i386 liblua5.1-0:i386 libpango1.0-0:i386 libpixman-1-0:i386 libqt4-network:i386 libqt4-test:i386 libqtcore4:i386 libthai0:i386 libbonobo2-0:i386 libglade2-0:i386 libgnomecanvas2-0:i386 libidl0:i386 liborbit2:i386 libwmf0.2-7:i386 gtk2-engines-murrine:i386

Aber das funktionierte weder für die Deb oder Original Binär.


18
2018-05-29 19:56



Ich habe das Internet hoch und niedrig durchsucht und Ihr Installationslink ist der einzige, der funktioniert hat. Hinweis für zukünftige Besucher: Wenn Sie die AdobeAIRInstaller.bin verwenden und eine Gtk WARNING **: cannot open display: Fehler, versuch dies! - eleanor.mal
Das ist viel einfacher als jeffhendricks.net/?p=68 - realgt
Ich habe ein bisschen tiefer als Nora gegraben und die Antwort bezüglich des Problems "Kann nicht geöffnet" gefunden. Problem ist, dass der root-Benutzer nicht mit dem X-Display in Ubuntu verbinden kann (mit Standardeinstellungen), aber wir müssen unser Installationsprogramm als root (fail-design) ausführen. Installieren Sie zuerst sux (switchuser mit X-Anmeldeinformationen). Erlaube dem Root-Benutzer, sich mit dem X-Display zu verbinden. Aktuelle Anzeigeeinstellungen abrufen Dann benutze sux, um zum root-Benutzer zu wechseln. Führen Sie das Installationsprogramm mit den Anzeigeeinstellungen aus. 1. sudo apt-get install sux 2. /usr/bin/xhost + 3. echo $DISPLAY (Verwenden Sie dies in Schritt 5) 4. sudo sux - 5. DISPLAY=:0.0 ./AdobeAIRInstaller.bin - Nicholi


Ubuntu 14.04 - 32 und 64 Bit - Einfache .deb-Installation

Aufgrund der Funktionsweise von Multiarch können Sie einfach die i386 .deb-Datei auf neueren 64-Bit-Ubuntu installieren und automatisch die richtigen Abhängigkeiten installieren. (Auch das 64 Bit .deb ist nur das 32bit neu gepatcht mit einer Abhängigkeit von ia32-libs)

  1. Laden Sie die 32 Bit (ja sogar für Ihr 64 Bit Ubuntu) Deb herunter: http://update.devolo.com/linux/apt/pool/main/a/adobeair/adobeair_2.6.0.19170-devolo1_i386.deb (Danke an Yuvilios Antwort) Das 64-Bit-Paket auf der gleichen Website ist eine neu gepackte Version des 32-Bit, Sie werden Probleme haben, wenn Sie stattdessen das 64-Bit-Paket verwenden, verwenden Sie das 32-Bit-Paket für 32 und 64-Bit-Systeme Ubuntu 13.10.

  2. Öffnen Sie im Software-Center, klicken Sie auf Installieren

    enter image description here Ignoriere die Warnung über die Paketqualität


Alternativ, wenn Sie ein Steam-Spiel haben, das Air benötigt, installieren und starten Sie dieses Spiel und es wird Air beim ersten Start des Spiels installieren.

Beispielspiele, die Air verwenden:

  • Verteidiger Quest
  • Anodyne (wird verwirrt, wenn du bereits Air installiert hast, renn sudo apt-get remove adobeair und versuche das Spiel-Installationsprogramm erneut, da es mit Air kommt)

Ich habe diese während einer gefunden Wöchentlicher Humble-Verkauf um einige Open-Source-Projekte zu unterstützen.


13
2018-03-30 11:46





Schritt 1: Holen Sie sich etwas Luft Laden Sie als Nächstes die Adobe Air .bin-Datei herunter (direkter Link hier).

Schritt 2: Installation

Öffnen Sie ein Terminal (Anwendungen> Zubehör> Terminal) und navigieren Sie zu Ihrem Downloads-Ordner (oder dem Ordner, in dem Sie die .bin-Datei gespeichert haben).

* cd Download/

Wir müssen die .bin-Datei die Berechtigung zur Installation haben, also geben Sie den folgenden Befehl sorgfältig ein: -

* chmod +x AdobeAIRInstaller.bin

Jetzt können wir es installieren:

* ./AdobeAIRInstaller.bin

Die Installation sollte jedoch zip sein und, wenn alles in Ordnung ist, erscheint ein neuer Menüeintrag unter "Anwendungen> Zubehör" mit dem Titel "Adobe Air Application Installer".


6
2018-01-10 04:14



Unter Ubuntu 13.10 x64 funktioniert das nicht - Paul Gregoire


... nach einigen Schwierigkeiten und nach vielen Suchen in diesem Forum haben Google und andere Seiten es geschafft. Zuerst möchte ich der Community danken, die mir mehr Ehrgeiz gegeben hat, dies zu tun, als mich dazu zu bringen, AdobeAir zu installieren.

Das ganze Problem war das Paket ia32-libs(Das Paket ia32-libs war ein Hack, um 32-Bit-Pakete auf einer 64-Bit-Installation zu installieren. Seit Ubuntu Version 11.10 (Oneiric) wurde Multi Arch hinzugefügt. Eines der Ziele ist das Entfernen des ia32-libs-Pakets) ... das Paket, das Canonical beschlossen hat, die Unterstützung dafür zu beenden.

Alles was ich tun musste um es zu installieren ia32-libs Paket sollte dieses Repo hinzufügen:

1- "Deb http://archive.ubuntu.com/ubuntu/ raring main restricted universum multiversumpackage Quelle''

Ich befolgte die Schritte von diesem schnellen und einfachen Tutorial:

http://wiki.phoenixviewer.com/ia32-libs-in-ubuntu-13-10

2- dann diese Seite, die mich zu diesem netten führt Schritte zum Installieren von Adobe Air für 64-Bit-Systeme

www.thepowerbase.com/2013/06/how-to-install-adobe-air-in-ubuntu-13-04/

-----------------Dokumentation, die ich verwendet habe:---------------

www.askubuntu.com/questions/87447/how-can-i-install-adobe-air
helpx.adobe.com/air/kb/archived-air-sdk-version.html
www.wiki.phoenixviewer.com/ia32-libs-in-ubuntu-13-10
www.ubuntuforums.org/showthread.php?t=2181649
www.askubuntu.com/questions/91815/how-to-install-software-or-upgrade-from-old-    unsupported-release  

P.S. --- wie von Alvar erwähnt, Adobe Air für Linux wird nicht mehr unterstützt ---


4
2017-11-06 09:08



Überprüfen Sie diesen Link. Es hat gut funktioniert. tkalin.com/blog_posts/... - Michael Mikowski
@MichaelMikowski Dein Link hat mir geholfen. Die obigen Links hatten keine Lösung der manuellen Coping-Bibliothek, die nicht installiert werden konnte. Danach habe ich AdobeAir installiert. - ubuntico


Leider, viele Jahre später "Adobe AIR für Linux wird nicht mehr unterstützt." folgend, was adobe Seite sagt. Unter Verwendung des "AIR-Archivs" ist es möglich, nicht unterstützte Versionen zu erhalten, die Version 2.6.0 ist die aktuellste Version. Wenn Sie ein Programm installieren müssen, für das eine neuere Version erforderlich ist, können Sie mit einem Windows-Gast zum Feld "Virtual" wechseln.

Die empfohlenen Schritte für Ubuntu 16.10:

für 32-Bit-Maschine

wget -O adobe-air_i386.deb http://drive.noobslab.com/data/apps/AdobeAir/adobeair_2.6.0.2_i386.deb
sudo dpkg -i adobe-air_i386.deb
sudo apt-get install -f && rm adobe-air_i386.deb

für 64-Bit-Maschine

wget -O adobe-air_amd64.deb http://drive.noobslab.com/data/apps/AdobeAir/adobeair_2.6.0.2_amd64.deb
sudo dpkg -i adobe-air_amd64.deb
sudo apt-get install -f && rm adobe-air_amd64.deb

Die empfohlenen Schritte für Ubuntu 16.04 / 14.04 / 12.04 / Linux Mint 18/17/13 (beide aus Hier):

wget -O adobe-air.sh http://drive.noobslab.com/data/apps/AdobeAir/adobe-air.sh
chmod +x adobe-air.sh;sudo ./adobe-air.sh

1
2018-03-30 17:53





Ich habe Ubuntu 14.04 64-Bit. Die einzige Möglichkeit, Adobe Air für mich zu installieren, bestand darin, dem ersten Teil davon zu folgen Anweisungen zur Installation von Balsamiq auf Ubuntu, was ich zuerst versuchte.

Eine kurze Zusammenfassung dieser Anweisungen: - Herunterladen Dieses Adobe Air-Installationsprogramm - Installation des 32-Bit libgtk-Pakets (aber ich übersprang diesen Schritt; es funktionierte nicht für mich, und schien nicht notwendig) - Erstellen von symbolischen Links zu zwei libgnome-keyring-Dateien - Das Adobe Air-Installationsprogramm ausführbar machen und es mit sudo ausführen


0
2018-01-29 22:46