Frage Verbindung zu einer Kabelverbindung nicht möglich


Ich installierte Ubuntu 13.04 während Windows 7 Dual-Boot. Ich habe eine lokale verdrahtete Kabelverbindung, die mit Windows 7 gut funktioniert, aber im Falle von Ubuntu funktioniert es nicht. Ich versuche eine Verbindung herzustellen Netzwerkverbindungen und IP4-Einstellungen, in der Option Methode. Ich verwende das Handbuch und gebe alle Adressen ein, die mein Internet Service Provider mir gegeben hat, aber wann immer ich das speichern möchte Sparen... Schaltfläche ausgegraut. Ich habe einige Daten zu diesem Thema gesammelt. mit,

lspci -nnk | grep -iEA3 "(network|wireless|ethernet)"

es zeigt,

03:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
    Subsystem: AzureWave AW-NB037H 802.11bgn Wireless Half-size Mini PCIe Card [AR9002WB-1NGCD] [1a3b:2c37]
    Kernel driver in use: ath9k
04:00.0 USB controller [0c03]: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller [1b21:1042]
    Subsystem: ASUSTeK Computer Inc. Device [1043:1059]
--
05:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet [1969:1083] (rev c0)
    Subsystem: ASUSTeK Computer Inc. Device [1043:1851]
    Kernel driver in use: atl1c

und

sudo ifconfig

es zeigt,

eth0      Link encap:Ethernet  HWaddr c8:60:00:43:c7:82  
          inet6 addr: fe80::ca60:ff:fe43:c782/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:985 errors:0 dropped:16 overruns:0 frame:0
          TX packets:32 errors:0 dropped:0 overruns:0 carrier:1
          collisions:0 txqueuelen:1000 
          RX bytes:71604 (71.6 KB)  TX bytes:6652 (6.6 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:144 errors:0 dropped:0 overruns:0 frame:0
          TX packets:144 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:11744 (11.7 KB)  TX bytes:11744 (11.7 KB)

wlan0     Link encap:Ethernet  HWaddr 00:08:ca:f0:51:5a  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Kann mir jemand vorschlagen, wie ich das beheben und eine Verbindung zu meiner Kabelverbindung herstellen kann?


4
2017-08-08 10:48


Ursprung


Sie verwenden statische IP oder haben einen DHCP-Dienst. - Gaurav Sharma


Antworten:


Anscheinend haben Sie keine IPv4-Adresse. Um dies zu setzen:

Öffnen Sie zuerst das Terminal und geben Sie Folgendes ein:

sudo nano /etc/network/interfaces

Dies öffnet eine Datei, geben Sie Folgendes in die Datei ein:

auto eth0
iface eth0 inet static
    address 192.168.1.100
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    gateway 192.168.1.1

(Geben Sie stattdessen Ihre eigenen IP-Adressen ein.) Wenn Sie keine statische IP-Adresse wünschen, geben Sie einfach die folgenden Zeilen in die Datei ein:

auto eth0
iface eth0 inet dhcp

Speichern Sie die Datei (CTL + X, Y, Enter) und starten Sie den Netzwerkdienst neu:

sudo service network-manager restart

Hoffe das hilft.


1
2017-08-08 13:48





Ich hatte das gleiche Problem. Dann habe ich herausgefunden, dass einige Einstellungen in Windows Internetverbindungen in Ubuntu verbieten können. Ich habe Wake-On-LAN in Power Management in Windows 8 deaktiviert, und jetzt funktioniert es in Ubuntu.


3
2018-05-23 06:47





Ich stieß auch auf einem Dual-Boot nach dem Upgrade von Windows 7 auf Windows 10. Ich hatte das Problem, dass Ubuntu nicht eine NTFS-Partition mounten konnte, die von beiden Betriebssystemen geteilt werden sollte. (Ref Fehler beim Zugriff auf die Windows 8.1 NTFS-Partition von Ubuntu 13.10, auch nach dem Deaktivieren des schnellen Starts )

Ich habe Fast Startup in Win10 ausgeschaltet. Dadurch wurde die gemeinsame Partition repariert und gleichzeitig das Problem mit der Ethernet-Verbindung gelöst. Ich bin mir nicht sicher, warum sie verwandt sind, aber es hat für mich funktioniert, also ist es vielleicht einen Versuch wert.


0
2017-12-05 02:21





Nur für den Fall, dass jemand Dual-Boot mit Windows starten und dieses Problem auftritt, schalten Sie den Computer nicht um oder starten Sie ihn neu, um in anderen Betriebssystemen zu booten. Es gibt ein Problem mit dem Windows-Netzwerkadapter beim Herunterfahren, Sie können es weiter untersuchen, aber falls Sie nach einer schnellen Lösung suchen, führen Sie das oben erwähnte Hochfahren aus.


0
2018-06-12 13:55