Frage Wie man eingetippte URLs vom Browserverlauf in Firefox entfernt?


Ich weiß, dass ich besuchte Seiten aus der Historie via entfernen kann Geschichte → Zeige alle Geschichteund markieren Sie einfach die unerwünschten Einträge und drücken Sie die Löschen Schlüssel. Aber das scheint nicht die URLs zu entfernen, die ich beim Aufruf dieser Seiten in die Adresszeile eingegeben habe. Daher werden sie immer noch verwendet, um die URLs vorherzusagen, die ich später eingeben möchte. Insbesondere bei Sites, die häufig besucht werden (wie hier im StackExchange-Netzwerk), wird die Liste der vorgeschlagenen URLs durcheinander gebracht.

Gibt es eine Möglichkeit, die "eingegebenen URLs" vollständig aus dem Browserverlauf zu entfernen? Vorzuziehen mit ein paar einfachen Klicks für den Endbenutzer - aber ich hätte nichts dagegen, dies über die Kommandozeile zu tun, wenn nötig (z. B. die sqlite-Datenbanken von Firefox direkt zu modifizieren).

Bearbeiten: Dank an Dans Antwort ein Teil meines Problems wird erklärt - und ich fand heraus, dass ich es vermisste, es vollständig zu beschreiben. Bis ich Dans Erklärungen gelesen hatte, sah ich einige Details nicht.

Also sagen wir, dass ich besucht habe http://readwrite.com/somearticle und http://readwrite.com/otherarticle. Und natürlich viele andere Seiten mit einem "r" irgendwo in ihrer URL. Jetzt tippe ich in eine leere URL ein "r". Sofort füllt die automatische Vervollständigung das mit "readwrite.com" aus (nicht eine der vollständigen URLs) und das Drop-Down-Menü zeigt eine Reihe anderer Seiten (aber keine von readwrite.com).

  • Dans erste Methode funktioniert nicht, da die automatisch vervollständigte Zeichenfolge nicht im Dropdown-Menü enthalten ist
  • Dans zweiter Vorschlag (automatische Abschaltung ausschalten) ist für mich keine Option, ich möchte nur einige spezifische "Vorschläge" loswerden
  • Ich habe kein passendes Lesezeichen (um genauer zu sein: keine für readwrite.com)

Wie kann man diesen "readwrite.com" Vorschlag loswerden? Ich habe die gesamte Geschichte überprüft und sichergestellt, dass kein Eintrag mehr vorhanden ist. Ich habe auch meine Lesezeichen überprüft, auch keine Spuren.


4
2018-04-01 17:28


Ursprung




Antworten:


Wenn Sie eine URL in die Adressleiste eingegeben haben und das Autocomplete-Popup sichtbar ist, markieren Sie eine URL in der Liste und drücken Sie Löschen. Dadurch wird verhindert, dass diese URL erneut für eine Abfrage vorgeschlagen wird. Wenn viele ähnliche URLs entfernt werden sollen, müssen Sie möglicherweise das letzte Zeichen zurücksetzen und es erneut eingeben, um die Liste zu aktualisieren.

Hinweis: Dies funktioniert nicht bei Lesezeichen-URLs. Schlagen Löschen Entfernt sie aus der Liste, während sie geöffnet ist, aber das Lesezeichen wird beim nächsten Mal, wenn Sie eine ähnliche URL eingeben, erneut vorgeschlagen. Wenn dir das ein Problem bereitet: auf der Optionen Dialog, auf der Privatsphäre Tab, gibt es eine Option, um es nur aus der Geschichte vorschlagen, nicht Lesezeichen.

Es gibt auch eine andere Art von Autovervollständigung, bei der ein Domänenname in der Adressleiste selbst (nicht in der Autocomplete-Liste) während der Eingabe angezeigt wird. Es vervollständigt nur den Domainnamen, nicht die gesamte URL, so dass es nicht zu viele Vervollständigungen für stackoverflow.com"Problem, das du beschreibst.

Die Vorschläge stammen aus derselben Liste, wenn Sie also alle Autocomplete-Elemente für eine Domäne löschen und Sie haben keine Lesezeichen für diese Domain, es schlägt auch keine Inline-Domain vor. Dies kann sehr schwierig zu arrangieren sein, wie in Ihrem Beispiel, wenn Sie "rea" eingeben und es schließt readwrite.com aber die Liste ist voll von Seiten über "reanimation ". In diesem Fall müssen Sie es vervollständigen readwrite.com durch Drücken Ende (nicht  Eingeben) und rücken Sie dann das letzte Zeichen zurück, um die Liste zu aktualisieren. Dann nur die readwrite.com Einträge werden in der Liste angezeigt und Sie können sie auf die gleiche Weise löschen. Wenn viele Einträge vorhanden sind, müssen Sie möglicherweise die Rücktaste drücken m um die Liste zu aktualisieren.

Sie können nur die Inline-Autocomplete-Funktion deaktivieren, indem Sie auf klicken about:config und Einstellung browser.urlbar.autoFill zu falsch. Diese Einstellung wirkt sich nicht auf die Dropdown-Liste der Vorschläge aus, sondern nur auf den integrierten Vorschlag.


4
2018-04-01 17:37



Danke, Dan! Aber das scheint nicht immer zu funktionieren. Ich habe z.B. "readwrite.com" irgendwo in der Geschichte. Sobald ich anfange "r" einzugeben, ist das die vorgeschlagene URL. Aber es ist nicht in der Dropdown-Liste enthalten. So wie man es löscht, wenn ich es nicht auswählen kann? Ich habe versucht, es vollständig in der Adressleiste zu markieren und drücke dann 'Löschen'. Aber das scheint es nicht zu entfernen: Wenn ich das nächste Mal r (auch auf einem anderen Tab) tippe, wird es wieder angezeigt. Wenn ich einfach "Enter" drücke (also die Seite geöffnet ist), wird es nicht mehr vorgeschlagen (auch nach dem Schließen des Tabs, ugh!) - Izzy
Aha. Ich fügte meiner Antwort weitere Informationen hinzu. - Dan Hulme
Vielen Dank, das beschreibt, was ich gerade erlebt habe. Ich frage mich immer noch, wie ich kein "readwrite.com" -Lesezeichen hatte (aber natürlich eine bestimmte Seite dort besucht habe), wie man alle Einträge für diese Domain loswird, ohne die automatische Vervollständigung vollständig zu deaktivieren. Ich dachte, den Vorschlag zu öffnen und dann den Inhalt der URL zu löschen, tat es; aber als ich das für die zweite "r" Domain gemacht habe, war readwrite.com zurück. Also muss ich vielleicht meine Frage aktualisieren, um das ganze Dilemma besser zu erklären ... +1 in der Zwischenzeit :) - Izzy
+1 für die Erwähnung der Domain-Autocomplete, die in der Dropdown-Liste fehlt! - lenz
So ist es soll arbeiten. Leider ist Firefox fehlerhaft (Fehler # 932036). Tatsächlich funktioniert das Entfernen der Domänenautokomplettierung für mich nicht, selbst wenn End und dann Backspace gedrückt wird (es wird nie ein Dropdown angezeigt) und ich habe keine Verlaufs-, Lesezeichen- oder Dropdown-Elemente aus dieser Domain. Die Lösung von @Izzy hat funktioniert (für mich war es in der moz_hosts Tabelle), und die radikalere Lösung des Löschens der places.sqlite Datei scheint auch zu funktionieren. - jmiserez


Da alle über die Standardoberfläche von Firefox erreichbaren Dinge fehlzuschlagen schienen, entschied ich mich für den "Deep Dive" -Ansatz. Also habe ich das installiert SQLite-Manager Plugin, öffnete die places.sqlite Datei aus meinem Firefox-Benutzerprofil-Verzeichnis (Menü: Datenbank → Datenbank verbinden), und überprüfte die moz_places Tabelle (wählen Sie es im linken Bereich von SQLite-Manager) über die Suchfunktion (im großen rechten Fensterbereich: Tab Durchsuchen und suchen, dort die Schaltfläche "Suchen" für die "anstößige" URL. Die entsprechende SQL-Anweisung (für die Führen Sie SQL aus Tab) wäre gewesen:

SELECT * FROM moz_places WHERE url LIKE '%readwrite.com%';

Für Benutzer, die den grafischen Weg bevorzugen:

Screenshot
Screenshot des Suchfilters (zum Vergrößern auf das Bild klicken)

Wie sich herausstellte, gab es genau einen Treffer mit einer vollständigen URL, die beim Filtern des Browserverlaufs / der Lesezeichen nicht angezeigt wurde! Also habe ich mir die Freiheit genommen, diesen Rekord zu löschen, und habe meine URL wieder ausprobiert: Ja, so sieht das Problem aus! Aber warum so schwer, Mozilla?

BEARBEITEN: Denken Sie daran, dass Sie, wenn Sie direkt im Herzen operieren, "die Katze töten" könnten. Seien Sie vorsichtig, wenn Sie die Datenbanken von Firefox direkt ändern - oder Sie könnten inkonsistente Lesezeichen oder Schlimmeres bekommen! Prüfen Sie immer vor dem Löschen, zum Beispiel.


4
2018-04-02 19:54



Ich fand, dass die URL in meinem Fall aus der Tabelle moz_hosts kam, also wäre die Abfrage SELECT * FROM moz_hosts WHERE host LIKE '%readwrite.com%';. Der Fehlerbericht ist hier: bugzilla.mozilla.org/show_bug.cgi?id=932036 - jmiserez


Problem

Dies ist insbesondere ein Fehler in Firefox Fehler # 932036.

Das Antwort von Dan Hulme beschreibt, wie Firefox funktionieren soll. Leider funktioniert das nicht immer, selbst wenn End und dann Backspace gedrückt wird (kein Dropdown wird angezeigt). Auch wenn Sie keine Verlaufs-, Lesezeichen- oder Dropdown-Elemente aus dieser Domäne haben, schlägt die automatische Vervollständigung weiterhin Domänen vor, die Sie in der Vergangenheit besucht haben.

Der Grund dafür ist, dass in einigen Fällen URLs nicht aus dem Internet entfernt werden places.sqlite Datei in Ihrem Firefox-Profilverzeichnis, auch wenn Sie den vollständigen Verlauf löschen.

Lösung

Laut dem oben verlinkten Fehlerbericht bedeutet dies, dass Ihre places.sqlite Die Datenbank ist beschädigt. Der empfohlene Ansatz besteht darin, die Datei places.sqlite insgesamt zu löschen. Dies sollte verhindern, dass der Fehler in der Zukunft erneut auftritt.

  1. Dies wird dazu führen, dass Sie Ihren gesamten Browserverlauf verlieren, seien Sie also vorsichtig!

  2. Beenden Sie Firefox

  3. Dann, löschen (oder besser noch verschieben Sie es irgendwo sicher) places.sqlite. Die Datei befindet sich normalerweise bei ~/.mozilla/firefox/<randomnumbers>.default/places.sqlite

  4. Entfernen Sie auch die places.sqlite-shm und places.sqlite-wal Dateien.

Deine Lesezeichen sollten immer noch da sein, aber deine Geschichte wird weg sein. Die Lesezeichen werden von der letzten automatischen Sicherung wiederhergestellt, die Firefox erstellt hat (in der bookmarkbackups Ordner), so dass sehr neue Ergänzungen verloren gehen. Wenn Sie Angst haben, neu hinzugefügte Lesezeichen zu verlieren, empfehle ich, Ihre Lesezeichen vorher zu exportieren.

Von http://kb.mozillazine.org/Places.sqlite#Deleting:

Wenn Sie vermuten, dass die Datei beschädigt ist, löscht das Löschen von "places.sqlite" Ihren Browserverlauf und eine neue, leere Datei wird automatisch erstellt. In Firefox 3 und SeaMonkey 2.1 und höher wird places.sqlite mit der neuesten JSON-Datei aus dem Lesezeichenordner erstellt. Wenn kein JSON-Backup vorhanden ist, werden die Lesezeichen aus der Datei "bookmarks.html" importiert, sofern sie gefunden wird.

Nicht empfohlen (siehe Fehlerbericht)

Wenn Sie ein Risiko eingehen möchten, können Sie auch die places.sqlite Datei direkt. Beachten Sie, dass bei diesem Ansatz der Fehler wahrscheinlich erneut auftritt. Das heißt, Sie können das verwenden SQLite-Manager Plugin empfohlen von der Antwort von Izzy um das zu bearbeiten moz_places und moz_hosts Tabelle und entfernen Sie die Einträge manuell mit den URLs.

Sie können wie folgt nach den URLs suchen (ersetzen Sie example.com wie folgt):

SELECT * FROM moz_places WHERE url LIKE '%example.com%';

und

SELECT * FROM moz_hosts WHERE url LIKE '%example.com%';

0
2018-06-15 19:22





Ich hatte das gleiche nervige Problem, jedes Mal, wenn ich anfange zu tippen ww ..... dann erscheinen die gespeicherten Webadressen ... nicht ernst, aber sehr sehr nervig. Ich benutze Firefox.

Ich ging auf die Firefox-Website und schaute in HILFE, das habe ich schließlich gelöst.

  • Geben Sie in der URL-Leiste Folgendes ein: Über: config (und vergewissern Sie sich, vorsichtig zu sein!)
  • locate: Browser.urlbar.default.behaviour (dieser Wert ist wahrscheinlich 0)
  • Doppelklicken Sie auf diese Schaltfläche, um sie zu ändern und die Werte von 0 bis 33 zu ändern.
  • Schließen Sie diese Seite Dein Problem sollte gelöst werden, es hat für mich getan.

Danke Firefox!


-2
2018-05-19 19:19



Kannst du erklären, wie "33" das richtige Verhalten verursacht? Denn das scheint 32 + 1 zu sein, was getippt + Geschichte ist. - Nattgew
Danke für die Erklärung, @Nattgew - ich wollte gerade fragen, ob das nicht "42" statt lesen sollte;) // user283259: Noch offene Frage an mich, wie man diese Zahl berechnet, damit es nur die URLs startet, die ich will loswerden. Bei meiner Frage ging es nicht darum, die automatische Vervollständigung generell zu deaktivieren, sondern nur, um mehrere URLs zu entfernen, die nicht darin enthalten sind (Zitat aus der Frage: Die automatische Vervollständigung auszuschalten ist für mich keine Option). Passt Ihre Antwort dazu? Und wenn ja, wie? - Izzy


Ich habe die Lösung gefunden Hier (Dangowans Antwort)

Ich hoffe es funktioniert für dich

ps .: Entschuldigung mein armes Englisch :(


-2
2018-02-01 06:17



Danke für deine Antwort, Jacques - aber ich möchte den automatischen Vorschlag nicht komplett deaktivieren. Mein Ziel war es nur, einige URLs von hier aufzunehmen. - Izzy