Frage Kann ich 12.04 verwenden, um Ubuntu Phone-Apps zu erstellen?


Kann ich 12.04 verwenden, um Ubuntu Phone-Apps zu erstellen? Das Beispiel zeigt 12.10.


4
2018-02-21 04:42


Ursprung




Antworten:


Ja.

Bedarf

Das Beispiel, das bei Ubuntu App Developer bereitgestellt wird listet die Anforderungen für:

  1. Betriebssystem - Ubuntu (12.04 und höher ist wegen der unten genannten PPAs erforderlich)

  2. Qt5 und Ubuntu QML Toolkit verfügbar von den folgenden PPAs. Beide PPAs bieten Pakete für Precise (12.04) und höher.

  3. Ein Code - Editor (Präferenz für Qt-Ersteller Install qtcreator - obwohl Sie den Editor Ihrer Wahl verwenden können

Terminalbefehle

Wenn Sie die folgenden Befehle ausführen, sollten Sie alles installieren, was Sie brauchen:

sudo add-apt-repository ppa:canonical-qt5-edgers/qt5-proper
sudo add-apt-repository ppa:ubuntu-sdk-team/ppa
sudo apt-get update && sudo apt-get install ubuntu-sdk notepad-qml

Wenn Sie auch Qt Creator installieren möchten:

sudo apt-get install qtcreator

Beachten Sie, wenn Sie bereits Qt4 haben oder wenn Sie dies in Zukunft verwenden möchten

Es ist gut zu Lesen Sie den folgenden Hinweis von PPA:

  1. Qt4 und Qt5 können vollständig mit der Migration auf die neue Version gemeinsam installiert werden qtchooser Werkzeug. [Anmerkung: am 12.04 LTS noch nicht gleichzeitig Qt4 / Qt5 Entwicklungs-Executables, aber Bibliotheken sind in Ordnung]. Der vorherige Debian / Ubuntu-Ansatz beruhte auf dem Umbenennen von Binärdateien und der Verwendung von Alternativen. Wenn Sie gegen Qt5 verpacken, fügen Sie eine Abhängigkeit hinzu qt5-default zusätzlich zu anderen Abhängigkeiten. Für Qt4 verwenden qt4-default. Installieren qt5-default auch auf Ihrem Computer, um Qt5 als Standardkonfiguration zu haben. Sehen man qtchooser für mehr Informationen.

  2. Wenn Sie ältere Qt4 / Qt5-Pakete mit falschen / höheren Versionsnummern oder einem anderen Konflikt haben, können Sie eine der folgenden Varianten verwenden, um die Versionen in diesem Repository zu erzwingen, sofern die anderen PPAs deaktiviert sind:

    Sie können dasselbe auch verwenden, um auch zu ursprünglichen Archivversionen zurückzukehren, bevor Sie das tun sollten sudo dpkg -P qt5-default qtchooser.


4
2018-02-21 08:32