Frage Wie installiere ich mpeg-4 aac und h.264 Decoder auf Ubuntu 10.10? [geschlossen]


Ich versuche ein Video abzuspielen, für das die oben genannten Plugins erforderlich sind. Ich habe hier ein paar Antworten zu diesem Thema angeschaut, aber es hat das Problem für mich nicht gelöst.

Was ich bis jetzt versucht habe:

  1. sudo apt-get install ubuntu-restricted-extras  ... Aber dieser hat einige Probleme und lässt einige Pakete nicht runterladen ... also wird die ganze Sache nicht komplett heruntergeladen.

  2. ich habe es versucht sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu $(lsb_release -sc) main universe restricted multiverse"  um die obigen Repositories zur Download-Seite von ubuntu's source.list hinzuzufügen, aber es hat nicht geholfen.

Wer weiß, was kann ich sonst noch versuchen?


4
2018-01-02 08:45


Ursprung


Ubuntu 10.10 wird nicht mehr unterstützt, bitte verwenden Sie die neueste Version 12.10 oder 12.04 LTS. - Uri Herrera
Schwierig, Unterstützung für eine nicht unterstützte Version zu erhalten. - Nick Thom
@UriHerrera - Meinst du eine Neuinstallation von ubuntu 12.10 / 12.04 LTS oder meinst du, ich muss die Codec-Pakete für ubuntus 12.x-Versionen bekommen? Ich brauche Hilfe im späteren Fall, da ich nicht sicher bin, wo / wie man sie herunterlädt ... - user481913
Aktualisieren Sie Ihr Betriebssystem und installieren Sie das ubuntu-restricted-extras Paket. - Uri Herrera
@UriHerrera Kann ich das Update nur ausführen, um das Betriebssystem zu aktualisieren, oder benötigt es eine neue Installation? - user481913


Antworten:


Sie müssen herunterladen Codecs. Um das proprietäre zu installieren Codecs Geben Sie Folgendes in ein Terminalfenster ein.

sudo apt-get install gstreamer0.10-pitfdll gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse

Sobald Sie diese installiert haben Codecs Sie können fast jedes Audio / Video-Format abspielen.

Ich empfehle Ihnen auch, auf 12.04 LTS zu aktualisieren.


4
2018-01-02 09:42



Alle von ihnen enthalten in der ubuntu-restricted-extras Paket ..., hast du das auf Maverick getestet? Hat das bei Maverick funktioniert? - Uri Herrera
Ja, es hat auf Maverick funktioniert. - Mukund
@Mukund - Ich habe den Befehl für die 32-Bit-Version versucht, jedoch habe ich folgende Fehler festgestellt. 1) Es gibt Probleme und -y wurde ohne --force-yes verwendet. Also habe ich -y mit --force-yes ersetzt und es erneut versucht ... Dieses Mal gibt es Probleme beim Herunterladen bestimmter Pakete, d. 2 2) Fehler beim Abrufen archiv.ubuntu.com/ubuntu/pool/multiverse/g/...  404 Not Found [IP: xxx.xxx.xxx.xxx 80] Versuchen Sie, apt-get update oder --fix-missing auszuführen. Also was als nächstes? - user481913