Frage Installieren von Ubuntu mit Fake RAID 1


Ich hatte:

  • Software:

    Dual-Boot mit
    • Windows XP
    • Ubuntu 10.04 LTS x32

  • Hardware
    • Fake RAID 1 (Spiegelung) mit 2x1 TB:

Partition 1 - Windows
Partition 2 - SWAP
Partition 3 - / (Wurzel)
Partition 4 - Erweitert
Partition 5 - / Zuhause
Partition 6 - / Daten

arek@domek:/var/log/installer$ sudo fdisk -l

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000de1b9

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63   524297339   262148638+   7  HPFS/NTFS/exFAT
/dev/sda2       524297340   528506369     2104515   82  Linux swap / Solaris
/dev/sda3       528506370   570468149    20980890   83  Linux
/dev/sda4       570468150  1953118439   691325145    5  Extended
/dev/sda5       570468213   675340469    52436128+  83  Linux
/dev/sda6       675340533  1953118439   638888953+  83  Linux

Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000de1b9

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          63   524297339   262148638+   7  HPFS/NTFS/exFAT
/dev/sdb2       524297340   528506369     2104515   82  Linux swap / Solaris
/dev/sdb3       528506370   570468149    20980890   83  Linux
/dev/sdb4       570468150  1953118439   691325145    5  Extended
/dev/sdb5       570468213   675340469    52436128+  83  Linux
/dev/sdb6       675340533  1953118439   638888953+  83  Linux

arek@domek:/var/log/installer$ ls -l /dev/mapper/
total 0
crw------- 1 root root 10, 236 Oct  7 20:17 control
lrwxrwxrwx 1 root root       7 Oct  7 20:17 pdc_jhjbcaha -> ../dm-0
lrwxrwxrwx 1 root root       7 Oct  7 20:17 pdc_jhjbcaha1 -> ../dm-1
lrwxrwxrwx 1 root root       7 Oct  7 20:17 pdc_jhjbcaha2 -> ../dm-2
lrwxrwxrwx 1 root root       7 Oct  7 20:17 pdc_jhjbcaha3 -> ../dm-3
lrwxrwxrwx 1 root root       7 Oct  7 20:17 pdc_jhjbcaha4 -> ../dm-4
lrwxrwxrwx 1 root root       7 Oct  7 20:17 pdc_jhjbcaha5 -> ../dm-5
lrwxrwxrwx 1 root root       7 Oct  7 20:17 pdc_jhjbcaha6 -> ../dm-6



Ich möchte vom 10.04 x32 bis 12.04 x64 FRESH-Installation verwenden.


4
2017-10-07 21:14


Ursprung




Antworten:


Also, installiere Ubuntu 12.04.1 x64 LTS mit alternativer CD.   

  Während der Installation habe ich die manuelle Partitionierung ausgewählt   zu:
   - Verwenden und formatieren / (root)
   - Verwenden und formatieren SWAP
   - Verwenden und halten Sie Daten auf / home
   - Verwenden und halten Sie Daten zu / Daten
 
 
 Nachdem ich "Continue" geklickt habe, erhalte ich Fehler beim Erstellen und Formatieren der SWAP-Partition.

 Ich gehe mit Alt + F2 (?) Zum Terminal und drücke Enter.
 ich   entdeckt, dass es sichtbare RAID als einzige Festplatte mit NO gab   Partitionen.
 Etwas wie das:

arek@domek:/var/log/installer$ ls -l /dev/mapper/
lrwxrwxrwx 1 root root 7 Oct  7 20:17 /dev/mapper/pdc_jhjbcaha -> ../dm-0


arek@domek:/var/log/installer$ ls -l /dev/dm*
brw-rw---- 1 root disk 252, 0 Oct  7 20:17 /dev/dm-0


 
 Also habe ich auf die Konsole Alt + F3 (?) Gewechselt und Fehler wie   unten:

Oct  7 14:02:45 check-missing-firmware: /dev/.udev/firmware-missing does not exist, skipping
Oct  7 14:02:45 check-missing-firmware: /run/udev/firmware-missing does not exist, skipping
Oct  7 14:02:45 check-missing-firmware: no missing firmware in /dev/.udev/firmware-missing /run/udev/firmware-missing
Oct  7 14:02:45 anna-install: Installing dmraid-udeb
Oct  7 14:02:45 anna[12599]: DEBUG: retrieving dmraid-udeb 1.0.0.rc16-4.1ubuntu8
Oct  7 14:02:49 anna[12599]: DEBUG: retrieving libdmraid1.0.0.rc16-udeb 1.0.0.rc16-4.1ubuntu8
Oct  7 14:02:49 anna[12599]: DEBUG: retrieving kpartx-udeb 0.4.9-3ubuntu5
Oct  7 14:02:49 disk-detect: Serial ATA RAID disk(s) detected.
Oct  7 14:02:55 disk-detect: Enabling dmraid support.
Oct  7 14:02:55 disk-detect: RAID set "pdc_jhjbcaha" was activated
Oct  7 14:02:55 HERE --> dmraid-activate: ERROR: Cannot retrieve RAID set information for pdc_jhjbcaha 
Oct  7 14:02:56 check-missing-firmware: /dev/.udev/firmware-missing does not exist, skipping
Oct  7 14:02:56 check-missing-firmware: /run/udev/firmware-missing does not exist, skipping
Oct  7 14:02:56 check-missing-firmware: no missing firmware in /dev/.udev/firmware-missing /run/udev/firmware-missing
Oct  7 14:02:57 main-menu[428]: DEBUG: resolver (libnewt0.52): package doesn't exist (ignored)
Oct  7 14:02:57 main-menu[428]: DEBUG: resolver (ext2-modules): package doesn't exist (ignored)
Oct  7 14:02:57 main-menu[428]: INFO: Menu item 'partman-base' selected
Oct  7 14:02:57 kernel: [  316.512999] NTFS driver 2.1.30 [Flags: R/O MODULE].
Oct  7 14:02:57 kernel: [  316.523221] Btrfs loaded
Oct  7 14:02:57 kernel: [  316.534781] JFS: nTxBlock = 8192, nTxLock = 65536
Oct  7 14:02:57 kernel: [  316.554749] SGI XFS with ACLs, security attributes, realtime, large block/inode numbers, no debug enabled
Oct  7 14:02:57 kernel: [  316.555336] SGI XFS Quota Management subsystem
Oct  7 14:02:58 md-devices: mdadm: No arrays found in config file or automatically
Oct  7 14:02:58 partman:   No matching physical volumes found
Oct  7 14:02:58 partman:   No volume groups found
Oct  7 14:02:58 partman:   Reading all physical volumes.  This may take a while...
Oct  7 14:02:58 partman-lvm:   No volume groups found
Oct  7 14:02:58 partman: Error running 'tune2fs -l /dev/mapper/pdc_jhjbcaha'
Oct  7 14:02:58 partman: Error running 'tune2fs -l /dev/mapper/pdc_jhjbcaha'
Oct  7 14:02:58 partman: Error running 'tune2fs -l /dev/mapper/pdc_jhjbcaha'
Oct  7 14:06:11 HERE --> partman: mkswap: can't open '/dev/mapper/pdc_jhjbcaha2': No such file or directory
Oct  7 14:07:28 init: starting pid 401, tty '/dev/tty2': '-/bin/sh'
Oct  7 14:15:00 net/hw-detect.hotplug: Detected hotpluggable network interface eth0
Oct  7 14:15:00 net/hw-detect.hotplug: Detected hotpluggable network interface lo


 Wie Sie sehen können, gibt es 2 Fehler

Oct  7 14:02:55 dmraid-activate: ERROR: Cannot retrieve RAID set information for pdc_jhjbcaha


 und

Oct  7 14:06:11 partman: mkswap: can't open '/dev/mapper/pdc_jhjbcaha2': No such file or directory


Ich schaute ins Internet und versuchte, den Befehl "dmraid -ay" auszuführen und zu bekommen   so ähnlich:


dmraid -ay
/dev/mapper/pdc_jhjbcaha -> Already activated
/dev/mapper/pdc_jhjbcaha1 -> Successfully activated
/dev/mapper/pdc_jhjbcaha2 -> Successfully activated
/dev/mapper/pdc_jhjbcaha3 -> Successfully activated
/dev/mapper/pdc_jhjbcaha4 -> Successfully activated
/dev/mapper/pdc_jhjbcaha5 -> Successfully activated
/dev/mapper/pdc_jhjbcaha6 -> Successfully activated


 

Dann kehrte ich mit Alt + F1 (?) Zum Installer zurück und klickte auf "Zurück" zu   Zurück zum Partitionierungsmenü. Ich tat NICHT ändere alles nur   wieder "Continue" gewählt und alles läuft reibungslos.

Ich hoffe, das wird jemandem helfen.

Arkadius


3
2017-10-24 00:01





"Eigentlich ist es nicht möglich, eine neue Ubuntu-Installation mit mdadm einzurichten   faltraid (versucht 12.04 und 12.10 alpha 2 alternative cd): nur dmraid ist   angeboten. "per:

https://lists.ubuntu.com/archives/foundations-bugs/2012-July/103906.html

https://bugs.launchpad.net/ubuntu/+source/mdadm/+bug/1028677

Ab dem 23. Oktober 2012 wird der Bug weiterhin bestätigt und nicht behoben.


1