Frage Unbefestigte Abhängigkeiten in Ubuntu 12.04?


The following packages have unmet dependencies:
       gstreamer0.10-ffmpeg: Depends: libavcodec-extra-53 (>= 4:0.7-1) but    4:0.7.2.1ubuntu2 is to be installed
                         Depends: libavformat-extra-53 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                         Depends: libavutil-extra-51 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                         Depends: libc6 (>= 2.7) but 2.15-0ubuntu10 is to be installed
                         Depends: libglib2.0-0 (>= 2.24.0) but 2.32.3-0ubuntu1 is to be installed
                         Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu0.1 is to be installed
                         Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                         Depends: liborc-0.4-0 (>= 1:0.4.14) but 1:0.4.16-1ubuntu2 is to be installed
                         Depends: libpostproc-extra-52 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                         Depends: libswscale-extra-2 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed gstreamer0.10-ffmpeg:i386:    Depends: libavcodec-extra-53 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to   be installed
                              Depends: libavformat-extra-53 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                              Depends: libavutil-extra-51 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                              Depends: libc6 (>= 2.7) but 2.15-0ubuntu10 is to be installed
                              Depends: libglib2.0-0 (>= 2.24.0) but 2.32.3-0ubuntu1 is to be installed
                              Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu0.1 is to be installed
                              Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                              Depends: liborc-0.4-0 (>= 1:0.4.14) but 1:0.4.16-1ubuntu2 is to be installed
                              Depends: libpostproc-extra-52 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                              Depends: libswscale-extra-2 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed



       Package dependencies cannot be resolved
       This error could be caused by required additional software packages    which are missing or not installable. Furthermore there could be a    conflict between software packages which are not allowed to be    installed at the same time.

Ich habe versucht, jeder Anweisung zu folgen Hier und es hat mir immer noch nicht geholfen.

Was ist das Problem und wie behebe ich es?

Bearbeiten:
Mein Problem ist, dass ich das Gstreamer ffmpeg Video Plug-in nicht installieren kann Codecs zum Abspielen von .mpeg-, .divx-, .mpeg4-, .ac3-, .wmv- und .asf-Dateien


4
2017-08-18 16:13


Ursprung


Bitte versuchen Sie ein sudo apt-get update zuerst, und dann sehen, ob Sie immer noch diesen Fehler bekommen. - ish
Außerdem hätte es geholfen, wenn Sie erwähnt hätten, was Sie installieren möchten - doug
Ich habe kein Problem mit update .. Was mein Problem ist, kann ich installieren Gstreamer ffmpeg Video-Plugin-Codecs mpeg, divx, mpeg4, ac3, wmv und Asf-Dateien zu spielen - santosamaru


Antworten:


Sie scheinen sehr veraltete Bibliotheken zu verwenden, zum Beispiel "libavcodec-extra-53 (> = 4: 0.7-1), aber 4: 0.7.2.1ubuntu2 ist zu installieren. "Diese Version wurde am 12.12.2011 am 26.12.2011 veröffentlicht und wurde mehrfach abgelöst.

Die aktuelle Version 12.04 ist 4: 0.8.3ubuntu0.12.04.1) präzise-Sicherheit

Also offene Softwarequellen, software-properties-gtk und stellen Sie sicher, dass unter Ubuntu Software die 1. 4 sind geprüft & unter Updates die erste. 2 werden überprüft

Dann aktualisieren Sie Ihre Quellen und sehen Sie


4
2017-08-18 17:05



Ich tue, was Sie sagen, aber es gibt immer noch die gleichen unerfüllten Abhängigkeiten? - santosamaru
Könnten Sie Softwarequellen öffnen, wechseln Sie zu main server, der Lauf sudo apt-get clean && sudo apt-get update. Veröffentlichen Sie die Ergebnisse in ubuntu pastebin & verlinke deine Frage - doug
Für mich funktioniert das nicht ..: / - Pithikos
Der Mian-Server-Trick hat funktioniert, ich weiß nicht, warum die anderen Server nicht regelmäßig updaten. Ich benutzte einen PK-Server und versuchte das Problem 2 Tage lang zu lösen. Setze es auf den Hauptserver und es hat funktioniert. - S. A. Malik