Frage Wie installiere ich eine bestimmte GCC-Version?


Ich möchte eine ältere Version von installieren gcc auf meiner Ubuntu Lucid-Maschine. Besonders interessiert mich 2.95.3 oder 3.0.2.

Gibt es ein Repository zum Herunterladen dieses Pakets mit dem apt-get Befehl?


4
2018-06-20 20:49


Ursprung




Antworten:


  1. Geben Sie ein Diese Internetseite und wählen Sie den Spiegel zu Ihrer Bequemlichkeit.

  2. Dann wählen Sie Alt-Veröffentlichungen und dann gcc2  (für 2.95) oder gcc3  (für 3.0). Sie sollten jetzt ein paar Versionen von gcc komprimiert sehen.

  3. Jetzt sollten Sie auf den gewünschten Eintrag klicken und der Download wird gestartet.

  4. Schließlich müssen Sie kompilieren und installieren von der Quelle.


4
2018-06-20 21:02



Das ist gcc-3.4. Das funktioniert nicht für mich. Ich brauche gcc 3.0 oder 2.9. - aminfar
Ich bin mir nicht sicher, ob gcc-3.3 funktioniert. Ich habe es mit gcc-3.4 versucht und es ist fehlgeschlagen. Die Bedienungsanleitung sagt Version 2.95.2, 2.95.3 oder 3.0.2. - aminfar
Die erste Fehlermeldung mit gcc-3.4: Tools / bit_vector.h: 140: Fehler: ISO C ++ verbietet die Deklaration von ostream' with no type Tools/bit_vector.h:140: error: Ostream 'ist weder Funktion noch Elementfunktion; kann nicht als Freund deklariert werden Es gibt auch Fehler in anderen Dateien. - aminfar
Ich habe meine Antwort aktualisiert. Sie sollten jetzt in der Lage sein, die von Ihnen angeforderte Version herunterzuladen. - Lucio