Frage Über Terminal kann nichts installiert werden - apt-get -f install


Ich bekomme das, wenn ich versuche, irgendetwas mit dem Terminal zu installieren:

    You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 gimp : Depends: libgimp2.0 (<= 2.6.12-z) but 2.8.0-1ubuntu0ppa3~precise is to be installed
        Depends: gimp-data (<= 2.6.12-z) but 2.8.0-1ubuntu0ppa3~precise is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Ich habe mich im grub-Wiederherstellungsmodus der Root-Gruppe hinzugefügt. Dann tat es sudo apt-get -f install und habe das:

Errors were encountered while processing:
 /var/cache/apt/archives/gimp_2.8.0-1ubuntu0ppa3~precise_amd64.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)

4
2018-05-07 23:06


Ursprung


Zwei Dinge: Hast du tatsächlich versucht zu laufen? sudo apt-get -f install wie es heißt, und hast du kürzlich ein PPA hinzugefügt, um GIMP 2.8 zu versuchen? - Marius


Antworten:


Okay, von dem, was ich sagen kann, ist Ihr Problem, dass Sie ein PPA hinzugefügt haben, um zu versuchen, auf die neueste Version von GIMP zu aktualisieren, und es hat nicht geklappt. Ich denke, die beste Option für jetzt ist, die PPA zu entfernen, damit Sie Ihre Fähigkeit zurückbekommen, Software zu installieren.

Öffnen Sie den Update Manager und klicken Sie auf Settings. Dadurch gelangen Sie zum Softwarequellen-Manager, zu dem Sie mehr lesen können Hier. Wechseln Sie zur Registerkarte "Andere Software" und deaktivieren Sie alle PPAs, die Sie zu GIMP hinzugefügt haben.

Öffnen Sie dann ein Terminal und geben Sie diese Befehle einzeln ein (möglicherweise müssen Sie zuvor den dritten Befehl ausführen) sudo apt-get remove gimp wenn es scheitert):

sudo apt-get update
sudo apt-get remove gimp
sudo apt-get -f
sudo apt-get upgrade

GIMP wird deinstalliert, aber es sollte Ihr System wieder funktionieren lassen. Sie sollten auch in der Lage sein, die Standardversion von GIMP aus den Repositories neu zu installieren.


2
2018-05-08 00:22



Ich möchte nur darauf hinweisen, dass Gimp 2.8 sehr einfach aus der Quelle zu bauen ist. gregorystrike.com/2012/05/03/ ... - gecko
@gecko Danke, ich hatte gehofft, dass jemand einen solchen Guide posten würde, denn ich wollte selbst 2.8 auschecken. - Marius


Versuche dies:

sudo apt-get build-dep <yourapp>

2
2018-01-27 18:25



build-dep wird verwendet, um Build-Abhängigkeiten zu installieren. Könnten Sie erläutern, warum und wie dies das Problem des OP lösen würde? - Andrea Corbellini
Da das Problem in Abhängigkeiten besteht und die Baumstruktur wahrscheinlich beschädigt ist oder irgendeinen Fehler hat, hat sudo apt-get -f install in meinem Fall das Problem nicht gelöst. - Carlos_Mena
Dies löste ein ähnliches Problem hier. Die Ursache? Einige Pakete, die mit dpkg -i installiert wurden. - valk