Frage Wie ändere ich die PXE-Konfiguration in MAAS?


Ich benutze MAAS, während der Inbetriebnahme Schritt, ich habe einen vollständigen Fehler auf dem Bildschirm

timeout: killing /sbin/modprobe -bv pci

Ich untersuchte ein wenig und anscheinend ist es ein acpi Problem. Also habe ich versucht, einen Parameter zu dieser Datei /var/lib/tftpboot/pxelinux.cfg/default zu ändern und hinzuzufügen.

Ich habe diese Optionen standardmäßig hinzugefügt

APPEND noacpi noapm pci=noacpi lba acpi=off apm=off

Aber jedes Mal, wenn ich den maas-pserv neu starte, wird die Datei neu generiert.

Wie man das überwindet?

Vielen Dank!

EDIT1: Ich habe das in den Schustern gesehen

Thu May  3 15:27:56 2012 - INFO | generating GPXE/PXE configuration files
Thu May  3 15:27:56 2012 - WARNING | warning: kernel option length exceeds 255
Thu May  3 15:27:56 2012 - INFO | generating: /var/lib/tftpboot/pxelinux.cfg/01-00-1d-09-f0-4b-c2

Aber Generierung von welcher Standarddatei? Es gibt so viele Dateien in / etc / cobbler / pxe


4
2018-05-03 13:33


Ursprung




Antworten:


Sie können die PXE-Konfigurationsdatei in / von MAAS nicht technisch ändern. Sie müssen es manuell bearbeiten. Jedes Mal, wenn Sie einen Knoten zu MAAS hinzufügen, wird eine PXE-Konfigurationsdatei für eine der MAC-Adressen des Knotens erstellt. In Ihrem Fall müssten Sie basierend auf Ihren Protokollen die folgende Datei bearbeiten:

/var/lib/tftpboot/pxelinux.cfg/01-00-1d-09-f0-4b-c2

Und füge hinzu

noacpi noapm pci=noacpi lba acpi=off apm=off

zum append Linie. Es sollte ungefähr so ​​aussehen:

append initrd=/images/precise-i386/initrd.gz  locale=  locale=en_US priority=critical text  auto url=http://192.168.122.1/cblr/svc/op/ks/system/node-1577c5ae-957c-11e1-9a87-58946bf1d72c hostname=node-01001s09f04bc2 domain=local suite=precise noacpi noapm pci=noacpi lba acpi=off apm=off

Hoffe das hilft!


4
2018-05-18 14:26