Frage Die Installation von gnome-shell gibt mir gnome 2 statt 3


Ich habe gerade ubuntu 12.04 installiert und wollte die gnome 3 Shell verwenden, laut Diese Seite es war nur eine Frage der Installation der Gnome-Shell, da gnome 3 bereits Teil von ubuntu 12.04 ist

So tat ich sudo apt-get install gnome-shell und abgemeldet, ausgewählter Gnom und eingeloggt und ich schaute Gnome 2 anstatt 3 an. Was ist schief gelaufen?


4
2018-04-22 11:52


Ursprung


Wenn GNOME 3 denkt, dass Ihr System nicht dazu in der Lage ist, wird es zu einem GNOME 2-Setup degradiert ("Fallback-Modus"). - geekosaur
Könnten Sie bitte ein Terminal öffnen und die Ausgabe von gnome-shell --replace? (Öffnen Sie eine andere und tippen Sie unity --replace um Unity zurück zu bekommen, wenn du mit dem Testen fertig bist.) - zpletan


Antworten:


Gnome-Shell benötigt ein gewisses Maß an 3D-Hardware-Beschleunigung.

Es muss keine spezielle Hardware sein - integrierte Grafiken sollten in fast allen Fällen in Ordnung sein. Aber 3D-Beschleunigung muss funktionieren.

Der Window-Manager von Gnome 3, murmel, ist ein Compositing-Window-Manager, der OpenGL-beschleunigt ist.

Wenn gnome-shell nicht erkennt, dass Sie die richtigen Fähigkeiten haben, wird es in einen "Fallback-Modus" geladen, was bedeutet, dass es ein altes Panel wie Gnome 2 lädt und keinen Compositing Window Manager verwendet.

Ubuntu hat hilfreiche Möglichkeiten, proprietäre Treiber für Grafiken zu installieren - hast du diese ausprobiert?


2
2018-04-22 12:34





Was der OP sieht, ist der "alte Gnom 3". Gnome 3.4 verwendet llvmpipe, um ältere Hardware zu unterstützen.

Hier ist wie Gnome-Shell jetzt im Fallback-Modus aussieht (Screenshot ist mit einem Intel GMA500 mit dem PSB_gfx-Treiber, der nur 2D ist).

gnome-shell

Seit meinem Post heute sind die neusten Versionen von gnome-shell und llvmpipe noch nicht vollständig nach Ubuntu oder einem PPA portiert worden.

Es gibt ein PPA für llvmpipe, aber da llvmpipe in der schnellen Entwicklung ist, ist es momentan besser, es aus der Quelle (git) zu erstellen.

Sehen Wie installiere ich LLVMpipe?


2
2018-04-22 12:57





Ich hatte das gleiche Problem. Wenn Sie eine ATI Radeon-Grafikkarte wie mich verwenden, könnte dies die Lösung sein:

http://onubuntu.blogspot.ca/2011/10/manual-removing-fglrx-from-ubuntu.html

Hier ist ein Kopieren / Einfügen der wichtigen Bits:

~$ sudo apt-get purge xorg-driver-fglrx
~$ sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri
~$ sudo dpkg-reconfigure xserver-xorg
~$ sudo apt-get install --reinstall xserver-xorg-core

0
2018-05-02 21:59





Dieser Thread hat mich gerade gerettet, danke! Ganze Geschichte:

Neuinstallation von Linux Mint 13 (Maya) auf einem Lenovo Thinkpad T520 mit diesem Treiber: 01: 00.0 VGA-kompatibler Controller: NVIDIA Corporation GF119M [Quadro NVS 4200M] (rev A1)

Ich habe Gnome-Shell mit 3D-Arbeiten.

$ sudo apt-get install gnome-shell gnome-session gnome-tweak-tool

Ich wechsle zu Nvidia (ich bin ein Trottel für Schmerzen): [http://forums.linuxmint.com/viewtopic.php?f=59&t=154932][1]

Dies funktioniert gut für meinen externen Monitor, aber schlaucht mein Laptop-Display vollständig. Aus vielleicht den falschen Gründen entscheide ich mich dafür, zu nouveau zurückzukehren

$ sudo apt-get purge nvidia*
$ sudo apt-get install xserver-xorg-video-nouveau xserver-xorg-video-all
$ sudo rm /etc/modprobe.d/nvidia-installer-disable-nouveau.conf

Das lässt mich ohne openGL, also Gnome geht in 2D-Fallback-Modus. Ich verifiziere dies, indem ich die gnome-shell --replace ausführe:

$ gnome-shell --replace
...
Xlib:  extension "GLX" missing on display ":0.0".
...

Befolgen Sie die Schritte zur Neuinstallation / Konfiguration von glx von oben:

$ sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri
$ sudo dpkg-reconfigure xserver-xorg
$ sudo apt-get install --reinstall xserver-xorg-core
$ sudo reboot

Und ich war wieder im Geschäft!


0
2018-04-10 08:10