Frage Tintenfisch 3 Installationsfehler


Ich versuche, Tintenfisch mit Befehl zu installieren

sudo apt-get install squid

aber ich bekomme folgenden Fehler -

betgbs@proxy-server:~$ sudo apt-get install squid
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package squid

Ich habe auch versucht, Apache2 und viele andere Software zu installieren, aber den gleichen Fehler zu bekommen. Die Installation ist ordnungsgemäß und das System funktioniert einwandfrei. Bitte hilf mir, den Squid 3.1.19 auf meinem Ubuntu-System zu installieren. Vielen Dank


4
2018-02-07 07:46


Ursprung




Antworten:


Zwei Probleme:

  1. Es hört sich an, als ob in Ihren Paketlisten eine große Anzahl von Paketen fehlt, die da sein sollten. Dies könnte ein vorübergehendes Problem sein, das Sie beheben können, indem Sie es ausführen sudo apt-get update (oder klicken Sie auf das Symbol Check Schaltfläche im Update Manager), oder es könnte bedeuten, dass Ihre Paketquellen nicht korrekt konfiguriert sind. Wenn es ein Problem mit Paketquellen ist, würde ich vorschlagen, auszuwählen Settings... vom Update Manager und Überprüfen der Ubuntu Software und Updates Registerkarten.

  2. Das squid Paket enthält Squid 2.x. Wenn Sie Squid 3.x installieren möchten, installieren Sie das squid3 Paket stattdessen. Wenn Sie Ubuntu 11.10 ausführen, erhalten Sie Version 3.1.14.


4
2018-02-07 10:45