Frage Software-Center-Update-Manager erhalten beide Segmentierungsfehler


Ich benutze Ubuntu 11.10. Nach dem Upgrade würden weder das Software-Center noch der Update-Manager laufen. Ich bekomme ein Segmentierungsfehler wenn von der Konsole gestartet. ich kann sudo apt-get update ohne Problem, aber das Upgrade funktioniert nicht, auch nicht die Installation eines Pakets, d.h.sudo apt-get upgrade oder sudo apt-get install emacs gibt einfach die Eingabeaufforderung zurück und nichts passiert.

Exakter : software-center gibt dies: 2012-01-30 16:07:17,144 - softwarecenter.ui.gtk3.em - INFO - EM's: 17 15 21 Segmentation fault Dann passiert nichts anderes. Mit update-manager: Segmentation fault Ein Fenster blinkt und geht sofort weg. Mit sudo apt-get install emacs und sudo apt-get upgrade nichts passiert mit einem dieser beiden Befehle. sudo apt-get upgrade funktioniert aber gut


4
2018-01-30 13:29


Ursprung


Könnten Sie bitte die genaue Fehlermeldung zu Ihrer Frage hinzufügen? - Nitin Venkatesh
Exakter : $ software-center gibt dies: 2012-01-30 16:07:17,144 - softwarecenter.ui.gtk3.em - INFO - EM's: 17 15 21 Segmentation fault Dann passiert nichts anderes. Mit $ update-manager Segmentation fault Ein Fenster blinkt und geht sofort weg. Mit $ sudo apt-get install emacs und $ sudo apt-get upgrade nichts passiert mit keinem dieser beiden letzten Befehle. (das $sudo apt-get upgrade funktioniert gut) François - François


Antworten:


Gemäß Dieser Thread in den Ubuntu-Foren  (für die die Lösung ursprünglich gefunden wurde Dieser Thread):

Frage:

Wenn ich auf System> Administration> Update Manager klicke, erscheint es (ausgegraut) und das kleine Fenster "Startup Update Manager" erscheint, aber wenn der Balken halb gefüllt ist, verschwindet er.

Antworten:

Laut einem Forum-Thread aus dem Archiv, http://ubuntuforums.org/showthread.php?t=19563, Sie sollten in der Lage sein, das Problem zu beheben, indem Sie den folgenden Befehl von einem Terminal aus ausgeben:

sudo rm /var/cache/apt/*.bin

4
2018-01-30 18:42



Das hat perfekt funktioniert. Vielen Dank. - François
Herzlich willkommen :) - Nitin Venkatesh
Just hatte das gleiche Problem, aber / var / cache / apt hat keine * .bin Dateien drin. Irgendwelche anderen Vorschläge? - Peter Flynn