Frage dpkg-deb: error: subprocess paste wurde durch das Signal abgebrochen (Broken pipe)


Die Option Software up to date Option lädt automatisch den upgarde für GIMP herunter. aber während der Installation gibt es mir den Fehler. wie man dasselbe aufwertet


Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  gimp
Suggested packages:
  gimp-help-en gimp-help libgimp-perl gimp-gap gimp-console
The following packages will be upgraded:
  gimp
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/4,388 kB of archives.
After this operation, 324 kB disk space will be freed.
Do you want to continue [Y/n]? Y
(Reading database ... 151157 files and directories currently installed.)
Preparing to replace gimp 2.6.11-2ubuntu4 (using .../gimp_2.7.4-2011102201~oo_amd64.deb) ...
Unpacking replacement gimp ...
dpkg: error processing /var/cache/apt/archives/gimp_2.7.4-2011102201~oo_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/gimp/2.0/plug-ins/file-xmc', which is also in package gimp-plugin-registry 3.5.4-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/gimp_2.7.4-2011102201~oo_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


4
2017-11-16 18:30


Ursprung




Antworten:


Wenn Sie ein benutzerdefiniertes PPA für Gimp verwenden, entfernen Sie es.

Entfernen Sie das Paket gimp-plugin-registry und gimp

sudo apt-get remove gimp-plugin-registry gimp

Pakete reparieren

sudo apt-get -f

Aktualisieren Sie das Gimp-Paket

sudo apt-get update && sudo apt-get upgrade
sudo apt-get install gimp gimp-plugin-registry

Installieren gimp-plugin-registry und gimp

sudo apt-get install gimp-plugin-registry gimp

2
2017-11-16 19:09



--------------------------------- Ich habe versucht, das Paket zu entfernen, aber es scheint, dass alles voneinander abhängig ist Ich werde folgen Fehler beim Lesen von Paketlisten ... Fertig Erstellen von Abhängigkeitsstrukturen Lesen von Statusinformationen ... Fertig Sie können 'apt-get -f install' ausführen, um diese zu korrigieren: Die folgenden Pakete haben noch nicht abgeschlossene Abhängigkeiten: gimp: Hängt davon ab: libgimp2.0 ( <= 2.6.11-z) aber 2.7.4-2011102201 ~ oo wird installiert Hängt ab: gimp-data (<= 2.6.11-z) aber 2.7.4-2011102201 ~ oo soll installiert werden E: Nicht erfüllte Abhängigkeiten . Versuchen Sie 'apt-get -f install' ohne Pakete (oder geben Sie eine Lösung an). - Manish Varia
Beim Ausführen von apt-get -f install bekomme ich wieder den gleichen Fehler. - Manish Varia
Haben Sie irgendwelche Gimp PPA's im Moment aktiv? - Bruno Pereira
Nö .. Ich hatte es gerade vorgestern installiert .. !! heute neu gestartet mein Rechner und dann Software up-to-date sagte, dass Updates verfügbar sind installieren Sie die so habe ich gerade installiert .. - Manish Varia
versuche, beide Pakete zu entfernen, zu aktualisieren und zu reparieren und dann zu installieren. - Bruno Pereira


Das gimp enthält die Datei /usr/lib/gimp/2.0/plug-ins/file-xmc das ist bereits installiert durch das Paket gimp-plugin-registry. Da eine Datei nur aus einem Paket bestehen kann, können nicht beide Pakete installiert sein.

Gemessen an der Versionsnummer stammt Ihr Gimp-Paket (aber nicht gimp-plugin-registry) von einer inoffiziellen Paketquelle. Sie sollten also entweder versuchen, ein Paket zu finden gimp-plugin-registry Das funktioniert mit diesem Gimp-Paket oder kehrt zum offiziellen Gimp-Paket zurück.


1
2017-11-16 19:06



Ich habe versucht, das Paket zu entfernen, aber es scheint alles voneinander abhängig Ich bin Getting Error Building Dependency Tree Lesen von Statusinformationen ... Fertig Möglicherweise möchten Sie 'apt-get -f install' ausführen, um diese zu korrigieren: Die folgenden Pakete haben nicht behoben Abhängigkeiten: gimp: Hängt ab: libgimp2.0 (<= 2.6.11-z) aber 2.7.4-2011102201 ~ oo wird installiert Hängt ab: gimp-data (<= 2.6.11-z) aber 2.7.4-2011102201 ~ oo soll installiert werden E: Nicht erfüllte Abhängigkeiten. Versuchen Sie 'apt-get -f install' ohne Pakete (oder geben Sie eine Lösung an). auf dem laufenden apt-get -f install -> Zurück zu Platz 1, der gleiche Fehler - Manish Varia


dpkg: error processing /var/cache/apt/archives/gimp_2.7.4-2011102201~oo_amd64.deb (--unpack):
trying to überschreiben '/usr/lib/gimp/2.0/plug-ins/file-xmc', which is also in package gimp-plugin-registry 3.5.4-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

Ok, das ist eine allgemeine Antwort, eher das Problem von OP.

Diese Nachricht zeigt an, dass ein Paket versucht, eine Datei zu überschreiben, die in einer anderen Datei enthalten ist. Die sicherste Lösung ist das Entfernen eines der beiden Pakete. In diesem Beispiel könnte es entweder sein gimp oder gimp-plugin-registry.

Dies ist normalerweise auf das Hinzufügen von nicht so gut gepflegten PPAs zurückzuführen, da diese Probleme durch Bots in den Haupt-Repositories behoben werden.


1
2017-12-18 13:12