Frage Die gespeicherte openVPN-Konfigurationsdatei kann nicht in Ubuntu 16.04 LTS importiert werden


Ich versuche einen zu importieren .ovpn Datei vom Netzwerkmanager. Hier sind die Schritte, denen ich folge.

Network Manager → VPN-Verbindungen → VPN konfigurieren

Dies öffnet den Dialog Netzwerkverbindungen. Dann,

Hinzufügen → importierte gespeicherte VPN-Konfiguration → wählen .ovpn Datei

Dies sollte meine laden .ovpn Konfiguration, aber stattdessen bekomme ich eine prompte Aussage

FEHLER: Plugin unterstützt keine Importfähigkeit.

Ich kann immer noch VPN mit dem Befehl verwenden

sudo openvpn --config ~/openvpn/xxx.conf

Ist das ein Fehler, der geklärt werden muss?


25
2018-04-22 06:29


Ursprung


Ich hatte ein ähnliches Problem beim Importieren der .ovpn-Datei auf einer der 2 32-Bit-Installationen, die ich gestern auf Lubuntu 16.04 aktualisiert habe. Ich konnte die Config manuell eingeben und es zur Arbeit bringen. Das Rätselhafte an mir ist, warum es an einem System gescheitert ist und nicht am anderen. - Organic Marble


Antworten:


Beim Auskommentieren der folgenden Zeile konnte ich die VPN-Konfiguration erfolgreich importieren:

route remote_host 255.255.255.255 net_gateway default

Andere haben berichtet, dass das Auskommentieren oder Entfernen dieser Linie auch für sie funktioniert Fehler # 606365 in Launchpad, obwohl dies ein gültiges Argument ist.

Obwohl ich erfolgreich eine Verbindung zum VPN herstellen kann, kann ich keinen Host über das VPN erreichen. Beim Versuch, diese Werte manuell über die Netzwerk-Manager-GUI festzulegen, sehe ich, dass nur numerische IP-Adressen akzeptiert werden. Stringwerte wie Remote-Host oder net_gateway kann nicht über die GUI eingegeben werden.

Ich hatte auch Erfolg beim Importieren der gleichen .OVPN-Datei ohne irgendeine Änderung in Fedora 23, Windows 10 (unter Verwendung von Viskosität), OS X El Capitan (unter Verwendung von Viskosität) und früheren Versionen von Ubuntu. Irgendetwas ist definitiv in 16.04 gebrochen.


16
2017-08-24 02:22



entferne "route remote_host 255.255.255.255 net_gateway default" gehe dann zu IPv4 settings => routes => Wähle die Option "Benutze diese Verbindung nur für Ressourcen in ihrem Netzwerk" => drücke OK => Speichern. Jetzt können Sie VPN verbinden und auf den Remote-Host zugreifen. - Guille Acosta
Danke, aber das hat nicht für mich funktioniert. Ich konnte erfolgreich eine Verbindung mit dem VPN herstellen, aber ich konnte nicht über die VPN-Verbindung auf Hosts zugreifen. - Karthic Raghupathi
Arbeitete für mich auf Fedora 26 - Heinrich Ulbricht


Ich weiß, dass dies eine alte Frage ist, aber da ich immer noch keine (einfache) Antwort finden konnte, möchte ich anderen (und zukünftigen) helfen.

Benutze das

sudo nmcli connection import type openvpn file FILE_NAME

Versehentlich ersetzen Sie FILE_NAME durch den vollständigen Pfad zu Ihrem Dateinamen

Dadurch erfahren Sie genau, was mit der Datei nicht stimmt und welche Zeilen Sie bearbeiten / löschen sollten.

Nachdem Sie die Datei mit den Empfehlungen des Befehls bearbeitet haben. Sie können die Datei importieren.


12
2017-12-30 14:10



Vielen Dank. Diese Methode ermöglicht es, das Problem zu verstehen. Es zeigt Fehlermeldungen an. In meinem Fall sind Fehler aus veralteten Optionen in der .ovpn-Datei aufgetreten. - PRIHLOP
Ich habe viele Methoden ausprobiert, aber keiner von ihnen hat funktioniert. Mit diesem Befehl habe ich festgestellt, wo der Fehler ist. Vielen Dank! - Agustin Baez


hat für mich gearbeitet:

sudo apt install network-manager-openvpn-gnome

8
2018-06-14 09:41



So erinnere ich mich an die Konfiguration von OpenVPN gespeicherten Konfigurationen (exportiert aus anderen Anwendungen) in früheren Versionen von Ubuntu (12.04, 14.04). Ich bin mir nicht sicher, ob ich dieses Paket in diesen Fällen installieren musste. Wie auch immer, danke für den Tipp! - nicorellius
Das hat auch auf Kali funktioniert - Abiral
Funktioniert auf Ubuntu 17.10 ... Denken Sie daran, Einstellungen zu schließen und erneut zu öffnen. - jdc91
Arbeiten in Ubuntu 18.04. Ich habe eine Datei von einem Router (archer60) mit der Erweiterung .ovpn exportiert und konnte die Schlüssel und die Einstellungen nicht importieren, um das VPN zu aktivieren. Durch die Installation dieses Pakets wurde das Problem behoben. - Alessandro D'lncal


Das Importieren von .ovpn-Profilen in den Netzwerk-Manager wurde kürzlich verbessert, aber es gibt immer noch Fehler und irreführende Fehlermeldungen. Manchmal können Sie die .ovpn-Datei erfolgreich importieren, indem Sie eine einzelne Zeile entfernen, die die Importprozedur unterbricht. In meinem Fall habe ich die Leitung entfernt float 1 aus meiner .ovpn Datei und die Datei wurde erfolgreich importiert.


2
2018-05-04 20:40



Ich denke, wir sollten diese möglichen Lösungen in einer Wiki-Antwort sammeln, weil sie kann oder kann nicht funktionieren und es hat keinen Sinn, die Stackoverflow-Rate von jemandem zu senken, weil eine bestimmte Problemumgehung nicht funktioniert hat - Rudolf Olah


Ich habe das gleiche Problem. Es sieht aus wie ein Fehler, nach diesem Link: https://bugs.launchpad.net/ubuntu/+source/network-manager-openvpn/+bug/606365


1
2018-04-26 03:36



Ich denke nicht, dass es genau derselbe Fehler ist. Die Problemumgehung (# 14) in dem von Ihnen freigegebenen Fehlerlink gilt nicht für mich. Die vorgeschlagene Problemumgehung besteht darin, separate Schlüssel- und Zertifikatdateien anstelle von Tags in der ovpn-Datei zu verwenden. Meine ovpn-Datei enthält bereits keine Tags. Zertifikat und Schlüssel befinden sich ebenfalls in separaten Dateien. - saitiku
Siehe die Lösung # 77: bugs.launchpad.net/ubuntu/+source/network-manager-openvpn/+bug/... - jgomo3


Für mich (Ubuntu 16.04.1 LTS), entfernen Sie den Abschnitt <extra-certs>  hat funktioniert.

Hier ist die ovpn-Datei, die von einem Tunnelanbieter generiert wird.

setenv USERNAME "user@provider.xx"
client
dev tun
remote host 1194 udp
remote host 1194 udp
remote host 443 tcp
remote host 1194 udp
remote host 1194 udp
remote host 1194 udp
remote host 1194 udp
remote host 1194 udp
remote-cert-tls server
comp-lzo no
auth SHA1
nobind
verb 3
sndbuf 0
rcvbuf 0
socket-flags TCP_NODELAY

<ca>
-----BEGIN CERTIFICATE-----
-----END CERTIFICATE-----
-----BEGIN CERTIFICATE-----
-----END CERTIFICATE-----
</ca>

<cert>
-----BEGIN CERTIFICATE-----
-----END CERTIFICATE-----
</cert>

<extra-certs>
-----BEGIN CERTIFICATE-----
-----END CERTIFICATE-----
</extra-certs>

<key>
-----BEGIN RSA PRIVATE KEY-----
-----END RSA PRIVATE KEY-----
</key>

key-direction 1
<tls-auth>
-----BEGIN OpenVPN Static key V1-----
-----END OpenVPN Static key V1-----
</tls-auth>
## -----BEGIN RSA SIGNATURE-----
## DIGEST:SHA1WithRSA
## -----END RSA SIGNATURE-----
## -----BEGIN CERTIFICATE-----
## -----END CERTIFICATE-----
## -----BEGIN CERTIFICATE-----
## -----END CERTIFICATE-----
## -----BEGIN CERTIFICATE-----
## -----END CERTIFICATE-----

1
2017-08-19 17:31



Ich habe dieses Feld nicht in meiner Datei. Können Sie Ihre Dateistruktur mit uns teilen? - saitiku
Sicher. Antwort bearbeitet. - malaise
Ich habe keinen extra-certs-Bereich in meiner Datei und es schlägt immer noch fehl. - Rudolf Olah


Es funktioniert :) von https://zorrovpn.com/howto/openvpn/ubuntu?lang=de

Öffnen Sie die .ovpn-Datei mit einem Texteditor.

Und ändere Zeilen, die aussehen

remote 11.2.2.2 443 tcp-client

zu

remote 11.2.2.2
port 443
proto tcp-client

Speichern Sie dann die .ovpn-Datei und versuchen Sie erneut, die VPN-Verbindung zu importieren.


1
2017-08-24 08:40



das funktioniert nicht für mich. - Rudolf Olah
wiederholte Antwort: askubuntu.com/a/812486/9330 - igorsantos07


  1. Öffnen Sie Ihre .ovpn-Datei mit einem beliebigen Editor
  2. füge am Anfang dieser Zeile # hinzu, um es zu kommentieren

    route remote_host 255.255.255.255 net_gateway default

  3. Gehen Sie zu IPv4-Einstellungen> Routen> Aktivieren Sie die Option "Diese Verbindung nur für Ressourcen in ihrem Netzwerk verwenden"> drücken Sie OK> Speichern

Erledigt!

Dies ist nur eine Zusammenfassung dessen, was bei Ubuntu 16.04 für mich funktioniert hat, basierend auf den anderen Antworten und Kommentaren hier.


1
2017-08-15 10:41



Scheint nicht mein Problem zu beheben. Aber ich suche nach einer Lösung. - jfmessier
Arbeitete für mich auf Fedora 26 - Heinrich Ulbricht


Ich habe herausgefunden, dass sich das ändert

remote REMOTE_SERVER 12345

mit

remote REMOTE_SERVER
port 12345

Das Problem wurde behoben.


0
2018-05-12 11:23



Meine Datei hat dies bereits. Ich bekomme immer noch den beschriebenen Fehler. - saitiku


In meinem Fall verursachte der folgende Gegenstand das Problem:

float 1

Nach dem Auskommen hat es geklappt:

#float 1

0