Frage pptpd VPN: Kein Internetzugang nach dem Verbinden


Ich habe die Anweisungen in dieses Tutorial um einen VPN-Server einzurichten, damit ich mich damit verbinden und virtuell von einem anderen Ort aus im Internet surfen kann. Soweit von Windows entfernt, kann ich mich mit ihm verbinden, aber es gibt keinen Internetzugang.

Die IP-Adressen, die ich in der Conf-Datei verwendet habe, sind genau dieselben wie im Tutorial

localip 192.168.0.1
remoteip 192.168.0.100-200

Dasselbe gilt für den DNS, der 8.8.8.8 lautet.

(Alles, was Sie über das, was ich getan habe, wissen müssen, ist bereits in diesem Link)

Was denkst du könnte das Problem sein?


3
2017-07-07 22:56


Ursprung


Post netstat -rn nachdem du dich in VPN eingeloggt hast - meccooll
@meccooll: Sorry für meinen vorherigen Kommentar, dass netstat wie ein Zauber funktioniert hat. Ich bin jetzt durch, aber HTTPS Webseiten werden nicht geöffnet, der Browser sagt SSL Connection Problem, haben Sie eine Idee? - Transcendent


Antworten:


Wenn Ihr Hauptzweck der Einrichtung des VPN-Servers der Zugriff auf die Website ist, muss der Datenverkehr von der öffentlichen Netzwerkschnittstelle des VPN-Servers weitergeleitet werden. Aktivieren Sie daher die Portweiterleitung, indem Sie die Datei sysctl.conf bearbeiten. Ich nehme an, dass "net.ipv4.ip_forward" in der Datei /etc/sysctl.conf kommentiert ist:

nano /etc/sysctl.conf

Fügen Sie die folgende Zeile hinzu oder suchen Sie sie und kommentieren Sie sie aus

net.ipv4.ip_forward=1

Speichern, schließen Sie die Datei und führen Sie den folgenden Befehl aus, damit die Änderungen wirksam werden.

sysctl -p

Die folgenden iptables-Firewallregeln erlauben Port 1723, GRE und führen NAT aus

iptables -I INPUT -p tcp --dport 1723 -m state --state NEW -j ACCEPT
iptables -I INPUT -p gre -j ACCEPT
iptables -t nat -I POSTROUTING -o eth0 -j MASQUERADE

Ersetzen Sie in der letzten Regel "eth0" durch die Schnittstelle, die auf Ihrem VPN-Server mit dem Internet verbunden ist. Schließlich ist die folgende Regel erforderlich, um sicherzustellen, dass Websites ordnungsgemäß geladen werden

iptables -I FORWARD -p tcp --tcp-flags SYN,RST SYN -s 172.20.1.0/24 -j TCPMSS  --clamp-mss-to-pmtu

Ersetzen Sie 172.20.1.0/24 durch den IP-Adressbereich, der in der Option "remoteip" in der Datei /etc/pptpd.conf verwendet wird. Diese Firewall-Regel wird verwendet, um sicherzustellen, dass ein geeigneter MTU-Wert verwendet wird, um eine Fragmentierung zu verhindern.

Ich hoffe, es könnte helfen.


8
2017-07-17 09:46



Immer noch kein HTTP / S-Zugriff, aber damit kann ich mich zumindest mit Geräten im Zielnetz verbinden. Vielen Dank! - timelmer
Du bist ein Lebensretter. - Iman Akbari


Der folgende Befehl löste mein Problem (Kein Internet) mit PPTPD unter Ubuntu 14.x

iptables -I INPUT -p tcp --dport 1723 -m state --state NEW -j ACCEPT
iptables -I INPUT -p gre -j ACCEPT
iptables -t nat -I POSTROUTING -o eth0 -j MASQUERADE
iptables -I FORWARD -p tcp --tcp-flags SYN,RST SYN -s 10.0.0.0/24 -j TCPMSS  --clamp-mss-to-pmtu
sudo iptables-save

sudo iptables -P FORWARD ACCEPT
sudo iptables -P OUTPUT ACCEPT
sudo iptables-save

Bitte beachten Sie: Ich habe diesen IP-Adressbereich 10.0.0.0/24 in meinem verwendet /etc/pptpd.conf Verwenden Sie den Bereich, der Ihrer Konfiguration entspricht.


3
2018-02-18 18:35



Das hat für mich funktioniert! - Arya