Frage "Das Paket ist in einem sehr schlechten inkonsistenten Zustand - Sie sollten es vor der Konfiguration neu installieren."


Kürzlich habe ich die neue Version von 13.04 bis 13.10 Ubuntu installiert und dabei auch ein Video angeschaut. Nun, rate mal, was passiert ist, mein Desktop ist für 4 Minuten abgestürzt und dann, als ich wieder Zugang zum Desktop hatte, schien alles durcheinander zu sein wie Boxsymbole wo Charaktere sein sollten.

Ich weiß, dass es eine schlechte Idee war, aber ich beschloss, den Installationsprozess neu zu starten, und jetzt bin ich mit diesem Fehler festgefahren.

dpkg: error processing unity-lens-photos (--configure):
package is in a very bad inconsistent state - you should reinstall it before attempting configuration.

Errors were encountered while processing: untity-lens-photos
e: subprocess /usr/bin/dpkg returned an error code (1).

Und es erscheint ziemlich oft, wenn ich versuche, etwas zu aktualisieren oder etwas zu installieren. Dies war, nachdem ich den Rest meiner Dateien aktualisiert hatte. Ich habe viele Dinge ausprobiert und viele Threads gelesen. Ich bin jetzt wirklich verloren, bitte hilf mir.

Außerdem habe ich keinen Zugang zu einem Panel und ich probiere gerade alles im Terminal aus. Versuche, ein Gnome-Panel zu installieren, wurden durch den Fehler gestoppt.


3
2018-01-22 18:47


Ursprung




Antworten:


Paket ist in einem sehr schlechten inkonsistenten Zustand - Sie sollten es erneut installieren, bevor Sie die Konfiguration versuchen.

Das Problem ist einfach zu beheben. Installieren Sie das Paket einfach neu:

sudo apt-get --reinstall install unity-lens-photos

12
2018-01-22 18:55





Versuche zu entfernen untity-lens-photos Paket durch Ausführen des folgenden Befehls,

sudo dpkg -r untity-lens-photos

Und dann neu installieren, indem Sie

sudo apt-get install untity-lens-photos

-1
2018-01-22 18:55