Frage Wifi funktioniert nicht nach dem Suspend nach dem Upgrade von 16.04


Diese spezielle Version von "funktioniert nicht nach dem Aussetzen" kam nach dem Upgrade auf 16.04. Es scheint, dass das Upgrade ein Wicd-Applet enthält (hinzugefügt zu Metacity Classic Gnome Taskleiste neben dem normalen Netzwerksymbol), aber nach einem Suspend scheint es nicht zu funktionieren. EIN sudo service network-manager restart dupliziert dieses Problem. Es dauert einen kompletten Neustart, um Wifi wieder in Gang zu bringen. Irgendwelche Ideen warum?


133
2018-04-23 11:42


Ursprung


Hast du einen Fehler im Launchpad für das Problem eingereicht ??? - apos
bugs.launchpad.net/ubuntu/+source/wpasupplicant/+bug/1556357 - Alberto Salvia Novella
Sieht so aus, als ob dieses Problem existiert seit Ubuntu 14. - Dan Dascalescu
Das ist mir unter 14.04 LTS nie passiert. Das Upgrade auf 16.04 LTS ist so großartig, dass ich es behalten werde, aber es vergisst immer mein WLAN-Passwort. - SDsolar
Das ist mir unter 14.04 LTS nie passiert. Das Upgrade auf 16.04 LTS ist so großartig, dass ich es behalten werde, aber es vergisst immer mein WLAN-Passwort. Der Service läuft klar; nur dass es das Passwort vergisst und keine Verbindung herstellt. Ich habe dies gepostet: askubuntu.com/questions/934958/ ... - und ich möchte mich nicht mit Blacklisting oder irgendetwas anderem beschäftigen. - SDsolar


Antworten:


16.04 läuft auf systemd. Versuche Folgendes:

sudo systemctl restart network-manager.service

Wenn dies funktioniert, können Sie ein Skript erstellen, um es zu automatisieren.

Öffnen Sie ein Terminal und geben Sie Folgendes ein:

sudo nano /etc/systemd/system/wifi-resume.service Fügen Sie das Skript mit einem Rechtsklick ein. Beenden Sie mit STRG + X und drücken Sie Y, um zu speichern. Jetzt um es zu aktivieren: sudo systemctl enable wifi-resume.service

Skript:

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Hoffe das hilft. Es funktioniert auf meinem Laptop.


161
2018-04-23 13:17



Ich würde sagen, kümmern Sie sich nicht um Neuinstallation dafür. Ich habe eine saubere Installation durchgeführt und ich stoße auf dieses Problem am 16.04. Hatte nie ein Problem mit 14.04. - Michael Martin-Smucker
Manchmal funktioniert es und manchmal nicht :( - tokam
@mikeymop Ich habe das auch gedacht. Ich weiß, dass einige Teile des Systems noch Starthilfe verwenden, so dass etwas ausgelöst werden kann. Seit 16.10 ist voll systemd und hat den Fehler nicht, Sie könnten richtig sein. - Joakim Koed
Wie kann ich das entfernen, das wird auf meinem System nicht funktionieren - buzhidao
Skript funktioniert nicht für mich. "Wifi Disabled" wird in meinen Netzwerken angezeigt, ich habe den realtek RTL8723be Treiber - Arshad


@ 147pm Hast du das jemals funktioniert?

Ich fand ein ähnliches Problem, obwohl ich auf Kubuntu 16.10 (KDE-basiert, nicht Gnome) und mit einem HP ProBook Laptop bin. Und anders als du war es nicht mein Wifi, der nach dem Suspend / Wakeup starb, sondern mein Ethernet-Port. Trotzdem frage ich mich, ob sie verwandt sind.

Ich sehe auch, dass du das Problem unter KDE nicht hast. Aber ich würde gerne wissen, ob die untenstehende Lösung unter Gnome hilft, da die Lösung nicht auf Fenstermanager, Desktop-Umgebung oder Applets basiert.

Zuerst, um zu bestätigen, dass der Netzwerk-Manager-Dienst neu gestartet wird.

$ sudo systemctl restart network-manager.service

hat nicht für mich gearbeitet.

Allerdings habe ich eine Antwort gefunden, die dank Buzhidaos Frage und Infos funktioniert hat Nach dem Suspend kann keine Internetverbindung hergestellt werden und GAD3R's Kommentar dort.

Unter Verwendung ihrer Informationen fand ich, dass die erste Untersuchung, welche Ethernet-Hardware und Treiber / Modul ich ausführe und dann das Modul entferne und neu installiere, funktionierte für mich (obwohl es nicht für bushhidao war):

W-lan:

$ lspci -knn | grep Net -A2

Ethernet:

$ lspci -knn | grep Ether -A2

Die zweite von diesen (Ethernet) war, was ich benutzte, und ich fand:

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
        Subsystem: Hewlett-Packard Company RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [103c:1944]
        Kernel driver in use: r8169
        Kernel modules: r8169

Also habe ich den 'r8169' Treiber neu installiert:

$ sudo rmmod r8169 && sudo modprobe r8169

und voila! Das hat funktioniert. Mein Ethernet-Port / Verbindung kam lebend zurück (nach Suspend / Wakeup), ohne neu booten zu müssen.

(Ich hatte auch kein Realtek Wifi-Gerät, aber ein Qualcomm Atheros (mod: ath9k), das vielleicht erklärt, warum Wifi für mich nach dem Aufwachen weiter funktionierte.)

Wie Sie aus meinem Kommentar zu diesem anderen Beitrag sehen können, habe ich mich gefragt, ob das Problem das gemeinsame Element zwischen Buzhidao und mir selbst ist: Realtek Semiconductor-Geräte. Auch wenn sie unterschiedliche Module verwenden, teilen sie möglicherweise einen gemeinsamen Code? Oder sogar anders behandelt werden durch den neueren Kernel-Code in irgendeiner Weise?

Haben Sie selbst ein Realtek-basiertes WLAN-Gerät? (mit lspci oben)? Haben Sie Glück, das Modul neu zu installieren (rmmod / modprobe oben)?

Wie auch immer, nur ein Schuss in die Dunkelheit. Wenn Sie eine mögliche Antwort gefunden haben, lassen Sie es uns wissen! Danke.


8
2018-03-16 22:40



Ich habe auch ein RTL8111 / 8168/8411 Ethernet und sudo rmmod r8169 && sudo modprobe r8169 Problem gelöst. - lenooh
Gleiches Problem unter Debian 9 mit KDE. Neuinstallation wie oben behoben. Danke vielmals. - sumitkm
Mein Computer * hat auch ein RTL8111 / 8168/8411 Ethernet-Gerät und sudo rmmod r8169 && sudo modprobe r81691 endlich das Problem für mich behoben. Hatte dieses Problem nicht vor der Kernel-Version 4.16. (* Debian 10 mit GNOME, Kernel 4.16 und proprietäre Firmware von Realtek) - ossbuntu


So starten Sie NetworkManager nach dem Fortsetzen in einer Umgebung ohne Neustart automatisch neu sudo Zugriff, erstellen Sie ein Skript in /etc/pm/sleep.d (beliebiger Name), setzen Sie das ausführbare Bit über chmod +x, und fügen Sie den folgenden Inhalt ein:

case "${1}" in
    resume|thaw)
        # systemctl restart network-manager.service
        service NetworkManager restart
;;
esac

Für mich, die service Linie hat funktioniert, aber systemctl könnte besser für dich arbeiten.

Quelle: https://askubuntu.com/a/92235/30266.


6
2017-11-05 07:50



Das service NetworkManager restart hat für mich gearbeitet, aber die Platzierung des Skripts hat nicht funktioniert (am 16.04). Ich musste das Skript nach verschieben /lib/systemd/system-sleep/script-name-here. In diesem Fall ist das erste Argument für das Skript [pre | post], also musste ich die Case-Anweisung auf ändern case "${1}" in ... post) .... Ich habe auch die innere Aussage eingepackt case "${2}" in ... suspend) .... - Chester
Sollte sein /lib/systemd/system-sleep/ für 15.04+ - qwr


Für mich scheint es zufällig zu sein, aber manchmal trennt das Wifi nur, wenn ich verbunden bin, oder zeigt keine Netzwerke, wenn ich nicht bin. Manchmal scheint es, wenn ich meinen Laptop in den Schlafmodus setze, aber nicht immer.

Eine Kombination dieser Funktionen bringt es normalerweise ohne Neustart wieder in Gang:

  • sudo iwlist $(ifconfig | grep -Po '^w\w+') scan
  • sudo service network-manager stop; sleep 5; sudo service network-manager start
    • Einfach anrufen restart hier scheint nie für mich zu arbeiten. Es sieht so aus, als ob es versucht, es zu starten, bevor es fertig ist, es zu schließen, deshalb habe ich mehr Glück, dazwischen zu pausieren stop und start.
  • WLAN in der Benutzeroberfläche deaktivieren warte ein paar Sekunden; schalte es wieder an

Keines davon scheint durchgängig zu funktionieren, aber ich habe sie in der Reihenfolge des wahrscheinlichsten zuerst aufgeführt.


2
2017-12-20 16:07





Arbeitsmethode auf Ubuntu 16.04:

Erstellen Sie den Service: sudo nano /lib/systemd/system/wifi-resume.service

Der Dienst ruft das Programm von:
/etc/init.d/network-manager

Fügen Sie den Code ein:

#/lib/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart network-manager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target 

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Aktivieren Sie dann den Dienst:

sudo systemctl enable /lib/systemd/system/wifi-resume.service

Dies erzeugt die symbolischen Links in den angegebenen [Install] -Verzeichnissen von / etc / systemd / system und aktiviert den Dienst

Danach können Sie den Status überprüfen mit: systemctl status wifi-resume.service


2
2018-01-23 00:59





Ich hatte das gleiche Problem mit Bluetooth: Nach dem Aussetzen meiner Bluetooth-Maus funktionierte nicht. Also habe ich die Lösung von oben abgeleitet:

sudo nano /etc/systemd/system/bluetooth-resume.service

hat den neuen Dienst aktiviert

sudo systemctl enable bluetooth-resume.service

und bearbeitet den Dienst

#/etc/systemd/system/bluetooth-resume.service
#sudo systemctl enable bluetooth-resume.service
[Unit]
Description=Restart bluethooth at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart bluetooth.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Ich habe auch versucht zu bearbeiten ...

sudo nano /etc/bluetooth/main.conf

und verändert

AutoEnable=true

ABER das funktionierte NICHT für das "resume Problem" und hatte keinerlei Auswirkungen auf neue Bluetooth Geräte!


1
2017-08-31 11:11





Ich hatte das gleiche Problem auf meinem Laptop Dell Inspiron 15R mit Ubuntu 16.04. Für mich hat gearbeitet Das Skript berichtete über die zweite Antwort.

Nachdem ich das Skript installiert hatte, probierte ich die Aufhebung mit dem Befehl im oberen rechten Menü und schloss sogar die Lippe, um das Problem zu lösen.

Ich muss sagen, dass das Problem in seinem Verhalten abwechselt (das heißt, manchmal hat es vor der Installation des Skripts funktioniert).


1
2018-01-18 14:58





Für mich war die Lösung zu laufen

nmcli nm sleep false

in einem Terminal


0
2018-04-08 11:01





Ich hatte das gleiche Problem, das nach dem Aussetzen zurück zu meinem Hauptwifi verbindet. Versuchte die verschiedenen anderen vorgeschlagenen Antworten, die gelegentlich aber nicht immer funktionieren würden.

Letztendlich erlaubte der folgende Fix eine konsistente Verbindung mit dem WLAN:

1) Editiere diese Datei:

sudo vim /etc/NetworkManager/NetworkManager.conf

2) Indem Sie das hinzufügen:

[device]
wifi.scan-rand-mac-address=no

0
2018-03-28 06:09