Frage Was tun, wenn "apt" nicht funktioniert, aber "apt-get"?


Ich benutze Ubuntu 14.

Wenn ich benutze sudo apt install snpservices, der Befehl schlägt fehl.

Wenn ich benutze sudo apt-get install snpservicesDie Installation ist perfekt.

Ich glaube, ich habe etwas kaputt ... aber was ist es?

Vielen Dank.

Ein paar Details:

(1) apt-version:

sebas@ubu14snp:~$ sudo apt --version 
apt 1.0.1ubuntu2 for i386 

(2) Fehlermeldung:

sebas@ubu14snp:/etc/apt$ sudo apt install snpservices 
Reading package lists... 
Done 
Building dependency tree 
Reading state information... Done 
E: Unable to locate package snpservices

(3) Paket soll von hier kommen:

$ cat /etc/apt/sources.list 
deb serveis.guifi.net/debian guifi/

(4) Paket, das ich benutze ist snpservices_0.2.2-9_all.deb


3
2018-03-14 20:24


Ursprung


Ich habe gerade versucht von einem 14.04 System und ich kann snpservices mit apt installieren. Was mich verwirrt ist, dass Sie ein i386-System zu betreiben scheinen, aber die Deb-Quelle bietet nur amd64-Pakete. - Sebastian Stark
Ich glaube ich benutze "snpservices_0.2.2-9_all.deb" und es sieht für mich ok aus - Sebastia.Net
Hat deine sources.list wirklich nur eine Zeile, oder hast du die Ausgabe gekürzt? - wjandrea
@SebastianStark Ich denke du hast es gefunden. Es scheint, als würde OP die 32-Bit-Version von apt auf einem 64-Bit-System. - wjandrea
Bitte posten Sie die Ausgabe von uname -a - wjandrea


Antworten:


apt install ist ab Ubuntu 14.04 verfügbar. In Ubuntu 14.04 und später ist es möglich, entweder zu verwenden apt install oder apt-get install.

Ihr apt-Paket in 14.04 ist nicht auf dem neuesten Stand. Die neueste Version von apt in Ubuntu 14.04 ist 1.0.1ubuntu2.17 von der Sicherheit Repository und Ihre Version von apt ist apt 1.0.1ubuntu2 für i386. Installieren Sie den starken Weg neu.

sudo dpkg --remove --force-remove-reinstreq apt
neu erforderlich    
       Ein Paket markiert neu erforderlich ist kaputt und benötigt
       Neuinstallation. Diese Pakete können nicht entfernt werden, es sei denn
       gezwungen mit Option --force-remove-reintreq.

4
2018-03-16 19:00



apt install funktioniert am 14.04. Ich benutze es die ganze Zeit. - wjandrea
Ich werde meine Frage wiederholen: "Was hat mein Ubuntu kaputt gemacht?" - Sebastia.Net
Oder ich kann es ändern zu: "Wie repariere ich mein System"? - Sebastia.Net
Ich brauche nicht die Erklärung, was "apt install" oder "apt-get install" tut - Sebastia.Net
Ich bin froh, dass Ihr "apt install" funktioniert, Herr Wjandrea - Sebastia.Net