Frage Erzwinge den gdm-Anmeldebildschirm zum primären Monitor


Ich habe zwei Monitore an meine Grafikkarte angeschlossen. Der primäre Monitor hat eine Auflösung von 1280x1024 und der zweite 1920x1200. Meine gdm Der Anmeldebildschirm erscheint immer auf dem zweiten Bildschirm, auch wenn er ausgeschaltet ist. Meine Frage ist, wie man zwingt gdm um den Login-Bildschirm immer auf dem primären Monitor mit der Auflösung 1280x1024 anzuzeigen?

Ich benutze die Nvidia GT9500 Videokarte im Twinview-Modus. Ich kann Xinerama nicht verwenden, da vpdau in diesem Modus nicht korrekt funktioniert.

Was ich gefunden habe, ist, dass der Mauszeiger immer in der Mitte der Vereinigung der Bildschirme erscheint und die Mitte immer auf dem Monitor mit höherer Auflösung ist. Der Anmeldebildschirm zeigt immer an, wo sich der Mauszeiger befindet.


Jetzt hat mein primärer Monitor eine Auflösung von 1920x1080. Das Problem besteht weiterhin, der Mauszeiger erscheint immer in der rechten unteren Ecke des zweiten Monitors.


22
2017-11-06 12:26


Ursprung




Antworten:


Für neuere Versionen von Ubuntu wie 13.10 oder aktualisiert 13.04 Mit Gnome 3.8 unterscheidet sich diese Prozedur, da die X-Konfigurationsdatei das Monitorlayout nicht mehr steuert. Sie müssen Folgendes tun:

  1. Legen Sie das Monitorlayout als eingeloggten Benutzer richtig fest (siehe Permanent Monitor als primär einstellen)

  2. Kopieren Sie die Konfigurationsdatei in die gdm-Einstellungen

    cp ~/.config/monitors.xml ~gdm/.config/
    

Für weitere Details, siehe https://bbs.archlinux.org/viewtopic.php?id=161903


20
2017-09-18 18:40



Bestätigt, es funktioniert auch für GNOME 3.10. Die absolute Lage von ~gdm/.config/ist /var/lib/gdm/.config/ falls sich jemand anderes wundert. - Forage
auf Gnome 3.14 gesehen: sudo cp ~/.config/monitors.xml /var/lib/gdm3/.config/ - Francois
Ich kann bestätigen, dass dieser einfache Trick auch mit Gnome 3.24.2 auf Ubuntu 17.04 funktioniert. Ich habe gerade den Befehl @Francois gepostet und jetzt funktioniert es wie ein Zauberspruch. - fgblomqvist
Funktioniert immer noch in 17.10 mit Xorg. Versuchen Sie jedoch nicht, die Benutzerkonfiguration intelligent zu gestalten und zu verknüpfen. Es wird nicht funktionieren. - raphinesse


Verwenden Sie eine Nvidia-Karte mit einem Dual-Screen-Setup?

Wenn ja, hatte ich das gleiche Problem und löste es auf folgende Weise: Den Computer ausschalten, den zweiten Monitor abziehen, den Computer wieder einschalten, 'sudo nvidia-settings' ausführen, den zweiten Monitor wieder einstecken und 'Detect' ausführen Displays 'in der Nvidia-GUI und nehmen vor dem Speichern der Einstellungen die notwendigen Konfigurationen vor. Der WICHTIGste Punkt ist, dass der Bildschirm, auf dem der Login erscheinen soll, auf "Screen Number: 0" eingestellt ist.

In meinem Fall hat das Verlassen des zweiten Monitors vor dem Ausführen von 'nvidia-settings' ihn aus irgendeinem Grund als Bildschirm 0 zurückgelassen, aber nachdem ich ihn später angeschlossen habe, wurde dieser sortiert.


1
2017-11-07 07:47



Ja, ich verwende Nvidia-Karte im TwinView-Modus. In diesem Modus ist jeder Bildschirm Bildschirm 0. Das Abziehen hat also nicht geholfen. - Kirill V. Lyadvinsky
Okay, keine Erfahrung mit TwinView, also Entschuldigung kann nicht mehr helfen


Vor kurzem habe ich das System auf die Version 11.10 aktualisiert. Ubuntu 11.10 verwendet einen neuen Display-Manager (lightgdm) und es scheint, dass der Anmeldebildschirm immer auf dem primären Monitor angezeigt wird. Dies löst mein Problem.


1
2017-12-03 20:12





Versuchen Sie, die Reihenfolge Ihrer Monitore links / rechts zu ändern. Sie ändern nicht, welche der beiden primär ist, aber es kann dazu beitragen, dass Ihr GDM angezeigt wird.


0
2017-11-06 13:59



Es hat nicht geholfen. - Kirill V. Lyadvinsky


Wenn Twinview es genauso macht, wie es das ATI Catalyst Control Center macht, gibt es eine xorg.conf, mit der Sie editieren können gksu gedit /etc/X11/xorg.conf

Der relevante Teil von mir sieht so aus:

Section "ServerLayout"
    Identifier     "amdcccle Layout"
    Screen      0  "amdcccle-Screen[1]-0" 0 0
    Screen         "amdcccle-Screen[1]-1" 1400 0
EndSection

Alles, was Sie tun müssen (nachdem Sie natürlich Ihre xorg.conf gesichert haben), ist das Ändern der ServerLayout, indem Sie die Screen-Einträge vertauschen (und die Bildschirmnummern anpassen), in meinem Fall wäre das:

Section "ServerLayout"
    Identifier     "amdcccle Layout"
    Screen      0  "amdcccle-Screen[1]-1" 1400 0
    Screen         "amdcccle-Screen[1]-0" 0 0
EndSection

0
2018-01-12 10:57



Ich habe nur einen Bildschirm in der definiert xorg.conf das hilft also nicht. - Kirill V. Lyadvinsky
@Kirill: Kannst du die Stecker tauschen und dann die Bildschirmreihenfolge in den nvidia-Einstellungen ändern? - Tobias Kienzler
Es hat nicht geholfen. Die Maus erscheint immer in der Mitte der Bildschirme und die Mitte ist immer auf dem Monitor mit höherer Auflösung. Der Anmeldebildschirm zeigt immer an, wo sich der Mauszeiger befindet. - Kirill V. Lyadvinsky


Sie können "Separate X-Bildschirmeinstellung" in den NVIDIA X Server-Einstellungen versuchen. Wenn Sie die gewünschte Anzeige auf 0 setzen, erscheint dort das Anmeldefenster. Es funktioniert für mich.


0
2017-11-30 11:08



Ich habe das versucht, aber Gnome3 stürzt jedes Mal beim Login in diesem Modus ab. - Kirill V. Lyadvinsky