Frage Wie man SSH-Root-Zugriff auf Ubuntu 14.04 aktiviert


Ich möchte das aktivieren ssh Root-Zugriff auf Ubuntu 14.04. Bearbeiten der /etc/ssh_config (PermitRootLogin ja) hat nichts beeinflusst.


118
2018-05-19 13:48


Ursprung




Antworten:


Das einfache Hinzufügen eines Passworts für root ist für Ubuntu 14.04 Server nicht ausreichend.

Sie müssen auch bearbeiten /etc/ssh/sshd_configund die folgende Zeile auskommentieren:

PermitRootLogin without-password

Direkt darunter fügen Sie die folgende Zeile hinzu:

PermitRootLogin yes

Starten Sie dann SSH neu:

service ssh reload

Für Ubuntu 16.04.1 LTS (GNU / Linux 4.4.0-59-generische x86_64) PermitRootLogin without-password wurde ersetzt durch PermitRootLogin prohibit-password.


178
2018-06-27 21:12



Wenn Sie dies über ssh tun, service ssh reload ist nützlich. - Torsten Römer
Ich habe Ubuntu auf VM ausgeführt, aber ich weiß nicht, dass diese Änderungen nicht funktionierten, bis ich die VM einmal neu gestartet habe (vielleicht muss ich zusätzlich zu den obigen Schritten auch Netzwerkdienste stoppen / starten, bin mir aber nicht sicher). - VSB
Ich muss es tun PermitRootLogin yes weil ich ein einfaches Passwort hatte - JorgeeFG
Wenn Sie dies tun, während ssh oder scp Ihnen sagt "Berechtigung verweigert, bitte versuchen Sie es erneut" in einem anderen Fenster, beenden Sie und versuchen Sie es erneut mit ssh (oder scp) anstatt einfach das Passwort erneut einzugeben. - Camille Goudeseune
Vergessen Sie auch nicht zu überprüfen, ob root in sshd_config erwähnt wird: AllowUsers root - Jan


Sie müssen ein Passwort für den root-Account einrichten und dann wird es funktionieren.

sudo passwd

Geben Sie das gleiche Passwort zweimal ein.

P.S. Vergessen Sie nach dem Ändern von / etc / ssh / sshd_config nicht, den openssh Server neu zu laden.

sudo service ssh reload

36
2018-05-19 13:51



Das wird funktionieren; aber zum OP: überlegen Sie es sich zweimal, bevor Sie es tun. Wenn Sie es immer noch tun und Ihr PC im Internet ist, ziehen Sie in Betracht, hinzuzufügen fail2ban zum System. (Dieser Kommentar bezieht sich auf das Aktivieren der root-Anmeldung über ssh; ein lokales Passwort für root ist nur eine Frage des Geschmacks). - Rmano


Mit Ubuntu 14.04 Server.

Legen Sie das Passwort fest

sudo passwd

Änderungen in / etc / ssh / sshd_config

Ändern Sie PermitRootLogin

PermitRootLogin yes

Möglicherweise müssen Sie auch den Wert von PasswordAuthentication überprüfen. Wenn es auf Nein eingestellt ist, dann wird auf Ja gesetzt

PasswordAuthentication yes

Starten Sie dann SSH neu:

service ssh restart


17
2018-02-01 09:27



Dies ist die einzige vollständige Antwort. Anderen Antworten fehlt ein Teil. - wisbucky
Außer meiner hat diese Linie nicht. Das Hinzufügen funktioniert nicht. - SDsolar
OMG, ja !! Vielen Dank! PasswordAuthentication war das fehlende Glied - mpen
Ich habe openssh-service und openssh-client auf beiden Systemen (Kali Linux und Ubuntu 18) gelöscht, neu installiert, diese Antwort angewendet und alles hat perfekt funktioniert. - mk1024


Für 14.04 müssten Sie die Zeile in / etc / ssh / sshd_config kommentieren

#StrictModes yes

3
2017-08-03 17:55



Anstatt die Überprüfung im Dateimodus zu deaktivieren, wäre es besser, das sicherzustellen /root/.ssh und die darin enthaltenen Dateien können von keinem anderen Benutzer als root gelesen werden. - Adaephon


Für mich hat keiner dieser Schritte funktioniert, ich habe sogar etwas versucht, das ich nie für etwas anderes als ein Spielzeug vm ausprobieren würde: PermitRootLogin without-password

Das einzige, was für mich funktionierte, war das PAM-Modul dafür zu deaktivieren:

UsePAM no

Diese Option befindet sich normalerweise am Ende der Datei. Um ehrlich zu sein, ich kenne die wirklichen Nachteile nicht, aber da du Root-Login nicht online erlauben solltest, ist es okay für ein privates dev-vm.

Stellen Sie trotzdem immer ein starkes Passwort ein. Nein, das ist keine Ausnahme. Nicht mal nur dieses Mal...


-1
2017-08-27 19:31



PermitRootLogin without-passwordDas bedeutet nicht, dass sich der root-Benutzer ohne Authentifizierung einloggen muss. Dies bedeutet, dass der root-Benutzer sich nicht mit einem Passwort anmelden darf. Stattdessen muss sich der Benutzer root mithilfe von RSA-Schlüsseln anmelden, was sicherer ist. - Craig
@Craig Das Problem, auf das ich mich beziehe, ist nicht, dass root dann RSA SSH-Keys benutzen müsste. Das Problem ist, dass Root ein Benutzer ist, der an der Tür Ihres SSH-Servers klopft. Was meiner Meinung nach nicht gut ist. Aber fühlen Sie sich frei, Root-Login über SSH zuzulassen, aber wie Sie gesagt haben, stellen Sie zumindest sicher, dass es Schlüssel verwendet, um dies zu tun! - Kjellski
Du hast gesagt, du würdest es nicht versuchen PermitRootLogin without-password für alles andere als eine Spielzeug-VM. Das ist es, was Sie verwenden, um die Kennwortauthentifizierung für root zu deaktivieren, so dass die einzige Möglichkeit für root die Anmeldung mit RSA-Schlüsseln ist. Sie haben nicht angegeben, dass Sie diese Option ausprobiert haben mit RSA-Schlüssel. Wenn Sie diese Option ohne Schlüssel ausprobiert haben, gibt es keinen Erfolg. Wenn du benutzt PermitRootLogin without-passwordDann können Sie sich überhaupt nicht mit der Passwortauthentifizierung anmelden, nicht mit einem starken Passwort, nicht mit einem leeren Passwort, überhaupt nicht. - Craig