Frage 16.04 LTS WLAN-Verbindung Probleme mit Realtek-Adapter


Ich habe nach der Installation von 16.04 LTS mehrere Probleme mit der WLAN-Verbindung festgestellt.

Erstens stellt Wi-Fi nach dem Schlafen oder Ruhezustand die Verbindung nicht wieder her. Manchmal wird das Netzwerksymbol nach dem Aufwachen zu einem "Pfeil nach oben und unten" (ich weiß nicht, wofür es ist), aber es ist immer noch verbunden. Manchmal ist das Netzwerk einfach verloren und es wird kein Netzwerk in der Liste angezeigt, so dass es überhaupt keine Möglichkeit gibt, WLAN zu benutzen.

Ich habe zuerst versucht, den Netzwerkmanager neu zu starten, indem ich ausgeführt habe sudo service network-manager restart. Es funktionierte, war aber keine dauerhafte Lösung.

Dann nach einem anderen Thread, fügte ich hinzu SUSPEND_MODULES="iwlwifi"zu

/etc/pm/config.d/config

Danach scheint das Reconnect-Problem behoben zu sein (kann sich automatisch wieder verbinden und das Icon ändert sich nicht mehr). Allerdings finde ich, dass die WLAN-Verbindung zufällig verloren geht (etwa alle 30 Minuten), selbst wenn der Computer läuft und das Netzwerksymbol bleibt der verbundene Zustand, wenn die Verbindung unterbrochen wird.

Ein weiteres Problem nach dem Hinzufügen des Codes ist, wenn ich meinen Computer in den Ruhezustand versetzt, wird der Bildschirm für eine Sekunde ausgeschaltet, schaltet sich dann aber für etwa 5 Sekunden wieder ein (während dieser Zeit unterbricht das System die WLAN-Verbindung). Und dann wird der Computer nach diesem ungewöhnlichen "zweiphasigen" Prozess schlafen gehen.

Bitte finden Sie unter Wireless Cards Informationen

*-network               
       description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 00
       serial: b0:c0:90:5c:1c:d5
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=4.4.0-21-generic firmware=N/A ip=192.168.0.8 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 ioport:d000(size=256) memory:df200000-df203fff

00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Sky Lake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 06)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (2) I219-V (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation GK208 [GeForce GT 730] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GK208 HDMI/DP Audio Controller (rev a1)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
03:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller (rev 01)

05/01/2016 Aktualisierung: Ich weiß nicht, was passiert ist, aber das Problem wird jetzt schlimmer. Die WLAN-Verbindung geht ungefähr alle 5 Minuten verloren und ich muss den Netzwerk-Manager neu verbinden oder neu starten.


116
2018-04-25 05:13


Ursprung


Die Pfeile nach oben und unten sind für Kabelverbindungen - ich sehe sie, wenn ich zum Beispiel ein Tethering an ein Android-Gerät verwende. Es gibt viele Fehlerberichte, die zum Beispiel mit deiner Karte zusammenhängen dieses wo scheint die Installation neuer Treiber für einige Leute funktioniert. Vielleicht wirst du etwas finden ... - Zanna
Du hättest verwenden sollen SUSPEND_MODULES="rtl8723be" anstelle von iwlwifi, wie Sie Karte verwenden nicht iwlwifi. Probiere auch echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf und neu starten - Jeremy31
Es kann die Option fwlps beheben, deaktiviert die Energieverwaltung und kann zu Verbindungsabbrüchen und anderen Problemen führen - Jeremy31
Ich habe viele Fragen auf WLAN-Problem gesehen und verstehe nicht, warum es so viele Probleme im Zusammenhang mit Netzwerk, vor allem WLAN in 16.04 LTS gibt. - d a i s y
@RyanNerd und sobald sie den Mac haben, laufen Ubuntu natürlich drauf! Der eine gute Grund, den Mac überhaupt zu bekommen :-) - zwets


Antworten:


Endlich konnte ich die Probleme beheben, nachdem ich verschiedene Methoden ausprobiert hatte.

  1. Holen Sie sich Details zu Ihrer PCI-WLAN-Karte durch Ausführen sudo lshw -class network
  2. Holen Sie sich Ihre Kartenmodellinformationen entsprechend der Produktlinie.
    Zum Beispiel, wie Sie in der Frage Beschreibung sehen können, heißt es
      product: RTL8723BE PCIe Wireless Network Adapter so ist das Modell meiner Karte RTL8723BE

    Oder product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller so ist das Modell meiner Karte RTL8101/2/6E

  3. Gib die Erlaubnis sudo chmod 755 /etc/pm/config.d/

  4. Öffnen oder erstellen config und hinzufügen SUSPEND_MODULES="rtl8723be"(ersetze rtl8723be mit deiner eigenen Modellnummer)
      Dann renne
      echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
      (Beachten Sie, dass beim Ersetzen rtl8723be mit meiner Karte, die ist RTL8101/2/6E Ich sollte nur tippen .../modprobe.d/RTL8101.conf; und /2/6E sollte nicht geschrieben werden)

Starten Sie Ihr System neu.

Jetzt sollte Ihr System in der Lage sein, sich automatisch nach dem Schlaf wieder zu verbinden, und die WLAN-Verbindung ist danach für mich niemals verloren gegangen.

"Die Pfeile nach oben / unten sind wahrscheinlich ein Fehler im Netzwerk-Manager, der dazu führt, dass der Netzwerk-Manager denkt, dass das WiFi-Gerät tatsächlich Ethernet ist.", So Jeremy31.Siehe Fehlerinfo hier Sie sollten es beheben können, indem Sie NetworkManager-1.2.0 installieren.

Danke an Jeremy31 für die Bereitstellung der Lösungen.


44
2018-05-06 03:09



Dies funktioniert wie ein Fix für das Aufwachen aus dem Suspend-Problem. Es ist die dritte Lösung, die für meinen Laptop mit einer Intel 7260 WLAN-Karte funktioniert. Aber selbst nachdem ich NetworkManager-1.2.0 installiert habe, bekomme ich immer noch die Pfeile (meine sind horizontal, nicht vertikal) und eine komplett getrennte WLAN-Karte, wenn ich versuche, das Netzwerk zu wechseln. - Rsync
Ich habe Ubuntu 16.04 vor einigen Stunden installiert und habe das gleiche Problem (falsches Icon + Wifi zufällig verloren). Schien gelöst mit sudo apt-get update && sudo apt-get dist-upgrade. Nach dem Neustart war alles in Ordnung: Verbindungen stabiler und kein falsches Icon. - gwarah
Es gibt kein Attribut "product:", das für meinen WiFi-Dongle zurückgegeben wurde. Nur "Konfiguration: ... Treiber = r8712u ..." - James Bowery
Sei vorsichtig mit dieser Lösung. Es hat mein Networking auf LM18 völlig durcheinander gebracht. Ich musste mich daran erinnern, welche Befehle ich ausgeführt hatte, damit ich die Konfigurationsdateien entfernen und neu starten konnte. Drucken Sie diese Seite für den Fall, dass Sie auf den Prozess verweisen müssen. Ich sage nicht, dass es schlecht ist, es hat offensichtlich für einige Leute funktioniert. Aber dachte, eine Warnung ist hier angebracht. - RyanNerd
@KillABug - Das obige Problem und / oder die Lösung können Realtek-spezifisch sein; Mit dem Centrino-Gerät habe ich nach dem Schlafengehen keine Probleme, verliere aber die Verbindung zufällig vor allem beim Download. Das Ignorieren von IPv6 hat das nicht behoben. - cipricus


Ich habe genau das gleiche Problem. Nach dem Aufwachen funktioniert WLAN zwar noch, aber Netzwerke werden nicht angezeigt. Ich löse das Problem, indem ich den Netzwerkmanager neu starte.

sudo service network-manager restart

Immer noch sehr nervig. Ich hoffe, sie beheben dieses Problem bald.


37
2018-04-28 04:25



Dies ist nur eine temporäre Lösung. Denkst du, es ist ein Fehler mit 16.04 LTS? - Lixu
das funktioniert für mich. es ist wahrscheinlich ein Fehler. - avi software
funktioniert auch zu verwenden nmcli con up wifi-sid, wenn Sie einen schnellen Schlag wünschen. - Rick-777
Das hat nicht für mich funktioniert. Ich verwende Xubuntu 16.04 LTS und wurde mit einem freigegebenen Windows-Laufwerk verbunden, als mein Computer in den Ruhezustand ging. Laufen sudo service network-manager restart habe mein System nur noch schlimmer eingefroren. Ich machte dann eine Abmeldung und wieder an - noch schlimmer, und jetzt verschwanden meine Desktop-Icons. Dann habe ich einen kompletten Neustart gemacht und jetzt sind meine Desktop-Icons immer noch verschwunden. Keine Ahnung warum, aber ich werde den Schlaf definitiv deaktivieren. Das ist ein schlechter Deal. Diese Art von Problemen, bei denen einfache Dinge funktionieren sollten, lassen mich Windows vermissen, und ich mag dieses Gefühl nicht. Ich hoffe Ubuntu / Xubuntu wird besser. - Gabriel Staples
Hast du schon eine Lösung gefunden? - Emad Arshad Alam


Dies ist sicher ein Fehler. Fehler wurde bei eingereicht https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1574347


30
2018-05-02 17:22



Dieser Bug ist geschlossen, kennst du einen anderen, den ich als betroffen bezeichnen kann? :) - Ads20000
Vielleicht war der Bug geschlossen, aber meiner fällt immer noch gelegentlich; und ich benutze nie Suspend. askubuntu.com/questions/938321/ ... - SDsolar


Zusätzliche Information: Ich habe das gleiche Problem wie OP beschreibt, aber nur das Problem, wo das nm-Applet-Icon zu Pfeilen wechselt und keine WLAN-Informationen anzeigt. Das WiFi funktioniert immer noch, wenn dies passiert.

$ killall nm-applet && nm-applet & 

Führt den Trick aus, das Symbol wieder anzuzeigen, also ist es nur ein Workaround für den Fall, dass jemand es in ein Skript einfügen möchte.

Kann dieses Problem auf zwei separaten Computern mit dem xubuntu-desktop-Pakets bestätigen.

Auch auf beiden Computern habe ich neuere Intel-WLAN-Karten laufen. (etwas in der Art von AC-7260)


10
2018-04-26 02:40



Hast du irgendeine Lösung gefunden? - Lixu
Danke, ich habe das gleiche Problem, aber das passiert mir nur, wenn ich die Verbindung mit dem WLAN-Router verliere, manchmal passiert es, dass mein Router abgehört wird und die Verbindung verloren geht. - Aleksandar Đorđević
Ich habe genau das gleiche Problem wie auf der kürzlich veröffentlichten Manjaro-i3-20161201 beschrieben. Und erfolgreich haben Sie es mit diesem Trick behoben. Vielen Dank! - navigaid
Eine andere Sache, die ich nützlich fand, ist, wenn du willst, entferne /etc/xdg/autostart/nm-applet.desktop, um zu verhindern, dass es beim Booten startet und benutze stattdessen stattdessen das nmtui-Dienstprogramm, um dich mit einem WLAN-Terminal zu verbinden. Ich habe die Methode ausprobiert und die Verbindung automatisch wieder hergestellt, wenn mein Laptop aus dem Schlaf erholt, auch nachdem nmtui beendet zu laufen. - navigaid


Ich hatte das gleiche Problem. Ich habe das Suspend-Wake-Problem behoben, indem ich dieses Skript erstellt habe /etc/systemd/system/wifi-resume.service (das OP, das veröffentlicht wurde, arbeitete nur für die aktive Sitzung; Beim Neustart musste es erneut aufgerufen werden):

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Dann gib einfach diesen Befehl im Terminal aus, um ihn zu aktivieren: sudo systemctl enable wifi-resume.service. Diese Lösung stammt von eine andere askubuntu Frage Antwortund funktioniert sowohl nach dem Aussetzen als auch nach dem Neustart.

Aber auch nachdem das behoben wurde, bekomme ich das gleiche Verhalten, das beim Aufwachen aus dem Suspend passiert ist, wenn ich es versuche Wifi-Netzwerke wechseln: Das WLAN ist im Wesentlichen tot, mit den beiden Pfeilen, und das Applet sagt "Gerät nicht bereit. "Ich kann das Wlan neu starten, indem ich es ausstelle sudo service network-manager restart, aber ich kann nicht zwischen Netzwerken wechseln.

Hat das jemand anderes erlebt und / oder eine Lösung?


6
2018-04-29 01:20



Da Sie das Problem immer noch haben, was nützt das Skript überhaupt? - Lixu
Das Skript behebt das erste Problem des OP: Kein Wifi beim Aufwachen aus dem Ruhezustand. Allerdings behebt es nicht das zweite Problem (für mich): Wifi-Netzwerke können nicht gewechselt werden, ohne den WLAN-Zugang zu verlieren. Wenn ich nicht klar war, existiert das zweite Problem unabhängig von dem ersten. Das Skript erstellt das zweite Problem nicht, es korrigiert lediglich das erste. - Rsync
Ich denke nicht, dass dieses Skript etwas für meine Situation tut. Es stellte sich heraus, dass die WLAN-Verbindung nach der Nutzung häufiger verloren geht. - Lixu
Versuchen Sie eines der anderen Skripts (z. B. askubuntu.com/questions/761180/ ...). Beide arbeiteten für das Wake-Suspend-Problem. Die Unfähigkeit, das Netzwerkproblem zu wechseln, führte jedoch dazu, dass ich zu 15.10 zurückwechseln musste. Außerdem stieß ich bei einer Neuinstallation von 16.04 auf ein drittes Problem: Der Netzwerkmanager erstellte jedes Mal eine neue WLAN-Verbindung, wenn ich eine Verbindung zu einem Netzwerk herstellte (z. B. WIFI_1; WIFI_2; WIFI_3). Daher musste ich jedes Mal das Passwort eingeben. - Rsync
Ich benutze keinen Lebenslauf, aber das sieht vielversprechend aus. Danke für das Posten. Hier ist meine Frage und eine gute Antwort auf das Thema: askubuntu.com/questions/938321/ ... - SDsolar


Ich benutze LinxuMint 18 Mate (ubuntu16.04) und bin in dasselbe Problem geraten.

Der Rest oben funktionierte bei mir auf meinem Thinkpad T440S nicht.

Die einzige Problemumgehung, die bisher zu funktionieren scheint, ist das Aktualisieren des Kernels auf 4.6.3

  • Gehe zu Diese Internetseite.

  • Erhalte folgende Dateien:

    linux-headers-4.6.3-040603-generic_4.6.3-040603.201606241434_amd64.deb
    linux-headers-4.6.3-040603_4.6.3-040603.201606241434_all.deb
    linux-image-4.6.3-040603-generic_4.6.3-040603.201606241434_amd64.deb
    
  • Wechseln Sie von einem Terminal zu dem Ordner, der die obigen Dateien enthält, und führen Sie Folgendes aus:

    sudo dpkg -i *.deb
    sudo reboot
    

Wenn Sie Virtualbox verwenden, führen Sie dies aus sudo /sbin/vboxconfig

Falls Sie sie entfernen möchten, führen Sie Folgendes aus:

sudo dpkg --purge linux-headers-4.6.3-040603 linux-headers-4.6.3-040603-generic 

Nach einigen weiteren Tests ist die Situation fast gleich, ich habe WLAN, aber mein nm-applet kann nicht alle WIFI um mich herum sehen. Also nicht sicher, ob das ein guter Workaround ist :-)


2
2017-08-09 09:28



Mit LM18 auch. Alle anderen Lösungen haben mein Netzwerk zerstört. Diese Lösung scheint zu funktionieren. Ich benutze Cinnamon und das Kernel-Upgrade birgt meinen Nvidia-Treiber - Nicht der Kernel ist schuld. Ich bin mir sicher, dass die Entwickler von Nvidia auf Acid B / C sind, dass sie ihren eigenen Spezifikationen nicht jedes Mal folgen können, wenn ich ein größeres Kernel-Upgrade mache. Ich verbringe eine Stunde oder länger mit der Nvidia-Treiber-Dummheit. - RyanNerd
Ich habe das Upvoted gemacht und es Upvoted gelassen, weil ein Upgrade auf den neuesten Kernel für LM18 funktioniert, wo ich nach anderen Orten Ausschau hielt, die meinem System keine schönen Dinge brachten. Leider hat das Aufrüsten auf Kernel 4.6.3 nicht dazu geführt, dass mein Wlan zu bestimmten Zeiten blöd geworden ist. Nur passiert zu Hause. Ich habe genau den gleichen Router zuhause, den ich bei der Arbeit habe. Ich bin mir nicht sicher, was hier vor sich geht. Mein Laptop hat eine Intel Wireless 7260, die anscheinend eine schlecht drainbramaged Wireless-Adapter-Version ist, die unter Linux und Windows mehrere Probleme hat. Ich denke also, ich bleibe stecken, bis der Treiber für diese Hardware aktualisiert wurde. - RyanNerd


Im Moment gibt es keine Lösung, aber ich habe ein Skript gefunden, das mir geholfen hat, weiter aufzustehen:

#!/bin/bash

# Ping you most used DNS Server and reconnect on fail


while true; do
  if ! ping -c 1 -w 1 8.8.8.8 > /dev/null; then

    # with "sudo iwconfig" you can examine your name of 'wlan0'
    nmcli d connect wlan0

  fi
  sleep 2;
done

Um dieses Skript zu starten, öffnen Sie einfach das Skript gnome-session-properties und füge es der Liste hinzu.

Das vollständige Skript (ohne Wiederverbindung) finden Sie auf diese Webseite.


2
2017-10-17 19:28





Legen Sie den WIFI-Ländercode für die aktuelle regulatorische Domäne des Kernels fest, wenn dieser nicht festgelegt ist

iw reg get

Um es einzustellen

sudo nano /etc/default/crda
REGDOMAIN=<ISOCODE>

Starten Sie neu.


1
2018-05-11 09:34



Wie oder warum würde das helfen? - A-B-B
Diese Lösung hat mir in gewissem Maße geholfen. Vorher dauerte es manchmal Minuten, um eine WiFI-Verbindung herzustellen (ich musste den Netzwerk-Manager einige Male neu starten, manchmal musste ich den Computer neu starten), aber nach dem expliziten Einstellen von REGDOMAIN funktioniert es jetzt besser. Aber nach dem Aufwachen des Computers aus dem Ruhezustand kann es manchmal immer noch nicht zum Verbinden kommen und ich muss den Netzwerk-Manager manuell neu starten. Nervig. - kovinet


nur um die akzeptierte Antwort hinzuzufügen (mit vier Schritten)

Aus irgendeinem Grund reichte mir nur ein Schritt, auch wenn ich nicht weiß, was es bedeutet:

echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf

1
2017-09-24 00:13