Frage Wie deaktiviere ich Tastenkombinationen für F1 und F10 in gnome-terminal?


Wie kann ich das ausschalten? F1 (Hilfe) und F10 (Benachrichtigungsmenü) Tastenbelegung?

Die erste brauche ich für das Bildschirm-Dienstprogramm und die zweite, um es zu beenden mc in der Konsole.

Es gibt keine solche Tastenbelegung in der Tastatürkürzel Systemeinstellungen.


115
2018-04-27 13:55


Ursprung




Antworten:


11.04

Deaktivieren der F1-Verknüpfung

  1. In einem Gnome-Terminal öffnen Bearbeiten ➜ Tastaturkürzel.

  2. Scrollen Sie nach unten zum Hilfe / Inhalt Abkürzung, klicken Sie, wo es "F1" sagt und schlagen Sie Rücktaste:

    enter image description here

Deaktivieren der F10-Verknüpfung

  1. Installiere das compizconfig-settings-managerInstall compizconfig-settings-manager Paket.

  2. Aufmachen CompizConfig Einstellungsmanager.

    • Schlagen Super Um den Dash zu öffnen, tippe "Compiz" und drücke Eingeben.
  3. Geben Sie "Einheit" in das Feld ein Filter Eintrag und wählen Sie die Ubuntu Unity Plugin.

  4. Klicken Sie auf die Schaltfläche rechts neben Taste zum Öffnen des ersten Bedienfeldmenüs und deaktiviere die aktiviert Kontrollkästchen.

    enter image description here

  5. Das hat das globale deaktiviert F10 Verknüpfung, jetzt deaktivieren gnome-terminal's F10 Abkürzung:

    • In einem Gnome-Terminal öffnen Tastaturkürzel (Bearbeiten ➜ Tastaturkürzel) und
      deaktiviere Aktivieren Sie die Menü-Tastenkombination (standardmäßig F10)

      enter image description here

  6. F10 wird von etwas in Ubuntu auf menubar_accel gemappt. Gnom? Metacität? Nicht sicher was genau es ist, das es stiehlt, aber der Schlüssel schafft es nicht zu Eclipse.

    • Führen Sie gconf-editor aus, navigieren Sie zu / desktop / gnome / interface, scrollen Sie dann nach unten zu menubar_accel und löschen Sie den F10-Wert. [Von hier gestohlen]

106
2018-06-23 18:52



Wie bearbeite ich "Tastaturkürzel" in einem Terminalfenster? Erste Linie. - jcollum
Ah, ok, es ist "öffnen Sie das Menü Bearbeiten, die Tastaturkürzel auswählen". Ich habe vergessen, dass Terminals Menüleisten haben. Ich dachte, ich sollte das tippen :) - jcollum
Alles oben zu tun löst nicht die F10 Taste in 12.04. Es ist immer noch gebunden irgendwo mit der rechten Maustaste klicken. - Paweł Gościcki
Wie kann ich die F1-Hilfe in Ubuntu 14.04 deaktivieren? Die Hilfezeile ist anscheinend verschwunden. Ich bin sehr nah daran, zurück zu ctwm zu kommen. - towi
@towi In diesem Dialogfeld müssen Sie zuerst auf die Hilfezeile klicken. Die Tasteneinstellung sollte von F1 auf "Neuer Beschleuniger ..." wechseln. Wenn Sie erneut darauf klicken, ändert sich die Einstellung in "Deaktiviert". - user100464


Deaktivieren Sie F10 in gnome-terminal in 12.04

Gib dies in die Konsole ein:

mkdir -p ~/.config/gtk-3.0
cat<<EOF > ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10"
}

* {
     gtk-key-bindings: NoKeyboardNavigation
}

EOF

Schließen Sie dann alle Terminalsitzungen. Jetzt sollte es so funktionieren wie es sollte mc beispielsweise).


44
2018-04-30 19:25



Nachdem ich Dutzende von Lösungen getestet hatte, arbeitete DIESE für Ubuntu 12.04 LTS. - NovumCoder
BEEINDRUCKEND! Meine Emacs sagten "Danke" - Cong Hui
Zum Deaktivieren anderer gnome-bezogener Bindungen würde ich vorschlagen diese Lösung auch - csguimaraes


Anfang gconf-editor und folgen /apps/gnome-terminal/keybindings/help

enter image description here

Beschreibung:

"Tastaturkürzel zum Starten der Hilfe. Wird als Zeichenfolge im selben Format wie für GTK + -Ressourcendateien ausgegeben. Wenn Sie die Option auf die spezielle Zeichenfolge" disabled "setzen, gibt es für diese Aktion keine Tastenkombination."


23
2017-08-21 20:28



ach, das ändert nichts. Ich bekomme immer den Hilfe-Bildschirm, wenn ich F1 drücke. Ubuntu 14.04 Desktop, Unity. - towi
Beachten Sie, dass Sie es einstellen müssen behindert nicht nur klar. Ich habe es fast gelesen. - Luc
Kann auch ohne GUI ausgeführt werden mit: gconftool-2 -s / apps / gnome-terminal / keybindings / help "deaktiviert" --typ string - Ddorda


Ich bin neu in Linux und dieser F10 Schlüssel macht mich verrückt. Alle obigen Tricks haben nicht funktioniert, aber ich habe jetzt eine Lösung gefunden (für Ubuntu 11.10 mit Gnome 3 classic desktop). Geben Sie in einem Terminal den folgenden Befehl ein:

gsettings set org.gnome.desktop.interface menubar-accel ""

Mit dem dconf-editor kann man feststellen, dass der F10 wirklich weg ist. Beachten Sie, dass diese Art von Tricks von der Gnome / Ubuntu-Version abhängig zu sein scheint.


7
2017-11-29 19:34



Einen Versuch wert, hat aber in Ubuntu 11.10 nicht für mich funktioniert - jcollum
+1 Dies ist der einzige in meiner 12.04 Maschine. - Radu Maris


Zum Beenden von mc (mit F10-Taste). Deaktivieren Sie "Schlüssel, um das erste Bedienfeldmenü zu öffnen" im Unity-Compiz-Plugin (ccsm)


4
2018-04-29 10:33





@kholis ist korrekt für die Deaktivierung von F10 in Unity, aber wenn Sie ein Newb wie ich sind, benötigen Sie ein wenig mehr Informationen, damit dies funktioniert.

Wenn nicht bereits installiert, installieren Sie compizconfig-settings-manager:

sudo apt-get install compizconfig-settings-manager

Starten Sie den neu installierten Einstellungsmanager und filtern Sie nach "Einheit"

Bearbeiten Sie "Schlüssel, um das erste Bedienfeldmenü zu öffnen", um es zu deaktivieren, oder zu einem anderen Schlüssel zu ändern.

Ich habe noch keine Möglichkeit gefunden, F1 zu ändern.


4
2018-04-30 17:36





Die Anweisung an http://ubuntuforums.org/showthread.php?t=1317325 (Zitat unten) funktioniert auch in Ubuntu 11.04. (Es scheint, F1 sowohl auf dem Desktop als auch im Terminal zu deaktivieren. Das heißt, F1 sendet keine Ansi-Sequenz an die Shell im Terminal, wenn OP das was wollte.)

  1. Gehe zu System - Einstellungen - Tastaturkürzel
  2. Erstellen Sie eine neue Verknüpfung. Nennen Sie es "nichts tun" und schreiben Sie "falsch"   (ohne Anführungszeichen) im Feld "Befehl". Drücken Sie ok.
  3. Scrolle zum Ende der Liste und finde deinen neuen Befehl. Klicken   auf der "Deaktiviert", auf der rechten Seite, und drücken Sie F1.

3
2017-08-22 02:12



Vielen Dank. Ich arbeite an Gnome Classic und nichts half bis 'nichts tun'. Danke nochmal. - Konrad Nowicki


Sie können es einfach mit deaktivieren CCSM (Klicken Sie auf Installieren, wenn Sie es nicht installiert haben).

Dann geh zu Desktop -> Ubuntu Unity Plugin -> Taste zum Öffnen des ersten Bedienfeldmenüs  und deaktivieren Sie es oder ändern Sie es in eine andere Tastenkombination.

enter image description here

Hinweis: Es scheint, dass diese Methode in Unity2D nicht funktioniert.


3
2017-10-26 22:03



Ich habe die Tastenkombination mit CCSM deaktiviert, aber das Drücken von F10 öffnet das Menü immer noch. - Conrad.Dean
komisch, ich habe es deaktiviert und F10 trifft nichts. - Binarylife
Verwenden Sie Unity2D? In Unity 2D scheint das nicht zu funktionieren. Beitrag aktualisiert. - Binarylife


Dies ist ein Tipp für Thnkpad-Benutzer, insbesondere T60. Ordnen Sie die F1-Taste neu, um zu entkommen. Dies beseitigt das lästige Popup der Terminalhilfe, wenn Sie F1 drücken. Sie tun dies oft aufgrund der witzigen Platzierung von ESC auf T60s.


2
2017-12-03 17:42