Frage Wie zu beheben "sudo: kann nicht geöffnet werden ... Read-Only-Dateisystem"?


Der Titel ist vielleicht nicht so beschreibend, wie ich es gerne hätte, aber er könnte keinen besseren ergeben.

Das Dateisystem meines Servers wurde schreibgeschützt. Und ich verstehe nicht, warum es so ist und wie man es löst.

Ich kann SSH in den Server und beim Versuch, Apache2 zum Beispiel zu starten, bekomme ich Folgendes:

username@srv1:~$ sudo service apache2 start
[sudo] password for username:
sudo: unable to open /var/lib/sudo/username/1: Read-only file system
 * Starting web server apache2                                                                                                                                                                                                               (30)Read-only file system: apache2: could not open error log file /var/log/apache2/error.log.
Unable to open logs
Action 'start' failed.
The Apache error log may have more information.

Wenn ich versuche, den Server neu zu starten, bekomme ich:

username@srv1:~$ sudo shutdown -r now
[sudo] password for username:
sudo: unable to open /var/lib/sudo/username/1: Read-only file system

Sobald ich es manuell neu starte, startet es einfach ohne irgendeine Warnung oder Nachricht, die sagt, dass etwas falsch ist.

Ich hoffe, dass mir jemand in die richtige Richtung zeigen könnte, um dieses Problem zu lösen.


112
2017-10-07 15:41


Ursprung


Ich empfehle @ John, die Antwort auf die letzte gepostete Antwort von Bibhas zu ändern, da es tatsächlich funktioniert, wo die anderen Antworten gar nicht hilfreich sind. - Joshua Robison
Für MicroSD: askubuntu.com/questions/213889/ ... - Ciro Santilli 新疆改造中心 六四事件 法轮功
Jeder, diese Frage ist für einen Server, kein PC. Wenn Sie dieses Problem auf Ihrem Dual-Boot-PC haben, überprüfen Sie bitte The **quick start** option can be found in **power options** in the control panel of Windows. Ich habe das gleiche Problem mit einem Ubuntu auf AWS - vanduc1102


Antworten:


Das Dateisystem wird normalerweise schreibgeschützt, während das System ausgeführt wird, wenn ein Dateisystemkonsistenzproblem vorliegt. Dies ist in angegeben fstab wie errors=remount-ro und tritt auf, wenn ein FS-Zugriff fehlschlägt oder eine Notfall-Nur-Lese-Neuinstallation angefordert wird Alt+SysRq+U. Du kannst rennen:

sudo fsck -Af -M

um eine Überprüfung aller Dateisysteme zu erzwingen. Wie eine der anderen Antworten sagt, schaut dmesg ist auch sehr hilfreich.

Edit: Vergiss nicht das -M in der Befehlszeile.


51
2017-10-07 15:58



Ich denke, du solltest nicht Macht Ein Dateisystemcheck auf anderen r / w eingehängten Dateisystemen. Das könnte Ihre Daten beschädigen. Ergänzen Sie die -M Option um angehängte Dateisysteme zu überspringen. (-M Do not check mounted filesystems and return an exit code of 0 for mounted filesystems. von FSCK (8)) - gertvdijk
Das hilft nicht, ich bekomme nur den gleichen Fehler, wenn ich versuche, diesen Befehl auszuführen. sudo: unable to open /var/lib/sudo/kuplack/1: Read-only file system  fsck from util-linux 2.20.1 - Mark Kramer
Aber ... -M wird angehängte Dateisysteme auslassen, einschließlich / dev / sda1 (oder was auch immer gemountetes Laufwerk enthält / var / lib / sudo / ...). @MarkKramer: Ich empfehle dringend, bei der Installation von Linux immer das Root-Passwort zu setzen sudo su; passwd. Dann kannst du verwenden su -c fsck -Af -M. - naught101
Ja, für mich musste ich -M entfernen, da / dev / sda1 gemountet wurde, und um dein Leben einfacher zu machen, füge -efy hinzu (das y bedeutet, dass alle Ansagen ja beantwortet werden) ... ich spiele schnell und locker mit VMs, also ' M normalerweise mit dieser Art von Lösung in Ordnung, aber wenn dies nicht gesichert Hardware ist, könnte einen anderen Ansatz und lesen dmesg. - FreeSoftwareServers
@ DarshanChaudhary Die -M flag bewirkt, dass fsck angehängte Dateisysteme überspringt. Siehe die fsck (8) Manpage. - hexafraction


Hier ist der Befehl, der mein Problem gelöst hat:

mount -o remount /

besser als ein neu starten oder Sudo fsck -Af 


40
2018-01-30 16:23



Nicht besser, wenn das Betriebssystem Ihre Festplatte schreibgeschützt gemacht hat, um eine mögliche Beschädigung zu verhindern. - Drew Noakes
Nicht nur das - nur root kann das Dateisystem neu mounten und sudo funktioniert nicht, wenn das Dateisystem schreibgeschützt ist. - Nathan Osman
Hilft nicht, ich bekomme nur die gleiche Nachricht: sudo: unable to open /var/lib/sudo/kuplack/1: Read-only file system  mount: cannot remount block device /dev/sda2 read-write, is write-protected - Mark Kramer
o ja das hat funktioniert. - R T
Aaaaw Ja! Vielen Dank, Fella! - shramee


Die Antwort mit Hexafraktion hat bei mir nicht funktioniert. Jedes Mal, wenn ich es versuchte sudo fsck -Af -M Es zeigte nur

$ sudo fsck -Af -M
fsck from util-linux 2.20.1

und sonst nichts. Kein Fehler oder irgendetwas. Für mich war das Booten in eine Live-CD und das Ausführen funktioniert -

sudo fsck.ext4 -f /dev/sda1

Die fragliche Partition wurde bereitgestellt /dev/sda1 war ein ext4 Dateisystem.


32
2018-02-17 15:44



Danke für diese Antwort. Dies ist das einzige, was tatsächlich funktioniert hat - Joshua Robison
-M bedeutet, keine angehängten Dateisysteme zu machen. Dein Dateisystem / dev / sda1 wurde gemountet (ich vermute bei /). Also wurde es übersprungen. - dalore
sudo fsck.ext4 -f /dev/sda1 funktioniert. Immer noch ein Neustart benötigt. - efkan
Es hat für mich auf ubuntu 16.04.3 funktioniert. Danke - Rosário Pereira Fernandes


Versuche zu laufen dmesg | grep "EXT4-fs error" um zu sehen, ob Sie Probleme mit dem Dateisystem / Journaling-System selbst haben. Ich würde Ihnen empfehlen, Ihr System dann neu zu starten. Ebenfalls, sudo fsck -Af Antwort von ObsessiveSSOℲ wird nicht weh tun.


10
2018-06-24 18:17





Wenn Sie Ihr Root-Dateisystem zwingen wollen, als RW neu zu mounten, können Sie Folgendes tun.

mount -o remount,rw /

9
2018-06-01 05:07





Beachten Sie, dass dies manchmal dadurch verursacht werden kann, dass der Computer die Systemzeit vergisst - die Überprüfung der Festplatte schlägt fehl, da die Daten im Journal in der Zukunft stehen!

Das Einstellen der BIOS-Zeit (und das Überprüfen der BIOS-Batterie) behebt dieses Problem für mich, ohne eine Wiederherstellung der Festplatte vornehmen zu müssen.


6
2018-02-23 02:15



Willkommen bei Ask Ubuntu! ich empfehle bearbeitenDiese Antwort wird um spezifische Details erweitert. (Siehe auch Wie schreibe ich eine gute Antwort? für allgemeine Ratschläge, welche Art von Antworten auf Ask Ubuntu am wertvollsten sind.) - David Foerster
Ich bin ziemlich sicher, dass mir das gerade passiert, weil mein Computer mir gesagt hat, dass er heute Morgen seine Zeit vergessen hat. - nomen


In der Regel setzt linux Ihre Dateisysteme nur dann in den Lesemodus, wenn Fehler auftreten, insbesondere bei Fehlern auf der Festplatte oder im Dateisystem selbst, z. B. bei einem falschen Journaleintrag.

Du solltest besser deine überprüfen dmesg für plattenbezogene Fehler.

Google diskutiert darüber ausführlich und Sie können diejenigen auswählen, die näher an Ihrer Konfiguration sind, aber einen Blick auf dmesg ist normalerweise genug.


1
2017-10-07 15:58



Was sollte man sich ansehen / grepfür in dmesg Ausgabe? - isomorphismes
Wenn Sie sich entschieden haben, Ihren privaten Ordner zu verschlüsseln, dmesg ist zwangsläufig voller nutzloser Fehler von ecryptfs. - Nathan Osman


(Gelöschte vorherige Antwort)

Edit: Das Hauptproblem war auf der Windows-Seite. Nach der Aktualisierung von Windows 10 wurde die Schnellstartoption automatisch aktiviert. Beim Deaktivieren dieser Option und erneutem Starten des Computers ging das Problem verloren. Windows 10 hat mir tagelang starke Kopfschmerzen bereitet :(

Die Option "Schnellstart" finden Sie unter "Energieoptionen" in der Systemsteuerung. Deaktivieren Sie das !!! :)


1
2017-12-23 08:18





Wenn Sie Ihren Rechner mit Ubuntu und Windows gleichzeitig dual booten und dieses Problem auftritt, dann ist dies der Fall, weil Windows das Dateisystem ändert. Versuchen Sie, den schnellen Start zu deaktivieren

Systemsteuerung> Hardware und Sounds> Energieoptionen> (auf der linken Seite) Wählen Sie aus, was den Deckel schließt> Ändern Sie Einstellungen, die derzeit nicht verfügbar sind> Deaktivieren Sie 'Schneller Start einschalten'

Der Start von Ubuntu wird das Problem lösen. Hoffe das hilft!

https://youtu.be/KJ-0KPZhAFo


1
2018-04-25 08:03